New Wii U 3.1.0E, Need some advice

Discussion in 'Wii U - Hacking & Backup Loaders' started by vpd, May 3, 2016.

  1. vpd
    OP

    vpd GBAtemp Regular

    Member
    152
    24
    Sep 2, 2009
    With the release of the new exploit I thought I would finally get a Wii U, I got lucky and got the last Splatoon Pack (disc version) that was in the store, and it's on System Menu 3.1.0E!

    I'm not sure where to go from here, should I update to 5.3.2?
    I hear that the Splatoon (pal) disc I have has the 5.3.2E update on, or should I try get to another system menu version?

    Second issue is blocking updates, my useless router won't less me use opendns, blocking/filtering on router itself is next to useless. What is the best alternative method to block the updates?
     
  2. Dylon99

    Dylon99 Lord of Dank

    Member
    541
    326
    Jan 12, 2016
    Netherlands
    Some cave in the mariana trench
    Use Tubehax DNS for blocking updates.
     
  3. x65943

    x65943 Resident Greekaboo, Amateur Dog Father

    Member
    2,563
    2,155
    Jun 23, 2014
    United States
    Indiana
    Update to 5.3.2, some have said it is the easiest for the IOSU exploit. I wouldn't update past that just yet.
     
  4. vpd
    OP

    vpd GBAtemp Regular

    Member
    152
    24
    Sep 2, 2009
    Think I will keep my Wii U completely offline and use a wi-fi sd card for self hosting the exploit as described here> https://gbatemp.net/threads/how-to-...-sd-card-no-accidental-system-updates.406279/

    I've also had a look but can't seem to find much info, but does anyone have any guides or info for achieving the same as the wi-fi sd card, but using a raspberry pi.

    Is there any benefits to stay on a system menu version below 5.3.2?

    Yeah think I will go to 5.3.2, definitely don't plan to go beyond that!
     
  5. AboodXD

    AboodXD I hack NSMB games, and other shiz.

    Member
    2,686
    1,407
    Oct 11, 2014
    United Arab Emirates
    Not under a rock.
    Update to 5.5.1. ;)
     
  6. vpd
    OP

    vpd GBAtemp Regular

    Member
    152
    24
    Sep 2, 2009
    yeah, like that's gonna happen!
     
  7. Blue_Mew

    Blue_Mew Shiny Mew!

    Member
    2,376
    993
    Oct 2, 2015
    United Kingdom
    Faraway Island
    There is a new kernel exploit that was leaked yesterday but it is still best to stay on lower firmware.
     
  8. AboodXD

    AboodXD I hack NSMB games, and other shiz.

    Member
    2,686
    1,407
    Oct 11, 2014
    United Arab Emirates
    Not under a rock.
    What do you mean? The 5.5 exploits were released today. :\
     
  9. Kohmei

    Kohmei GBAtemp Advanced Fan

    Member
    771
    463
    Feb 17, 2013
    United States
    You're not referring to this, are you?
    [​IMG]

    Because 5.3.2 is past it
     
    Bug_Checker_ likes this.
  10. vpd
    OP

    vpd GBAtemp Regular

    Member
    152
    24
    Sep 2, 2009
    Yeah that was the main reason I went out and got a Wii U today, but I got really lucky and got one with a lower system menu version.
     
  11. Blue_Mew

    Blue_Mew Shiny Mew!

    Member
    2,376
    993
    Oct 2, 2015
    United Kingdom
    Faraway Island
    Yes the kernel exploits have been released however IOSU will be easier to install in the future on lower firmwares.
     
    Bug_Checker_ likes this.
  12. vpd
    OP

    vpd GBAtemp Regular

    Member
    152
    24
    Sep 2, 2009
    Yup, but it's still advised to stay at lower versions.


    Is there any more info on this, as I won't update to 5.3.2 if there is anything more to this.
     
    Bug_Checker_ likes this.
  13. Kohmei

    Kohmei GBAtemp Advanced Fan

    Member
    771
    463
    Feb 17, 2013
    United States
    Both smea and hykem developed IOSU exploits for 5.5, so it's not that they're unexploitable. And as we don't have any of them right now, I'm not sure how relevant it is. I would still advise against needlessly updating but it's really up to you
     
    Bug_Checker_ likes this.
  14. vpd
    OP

    vpd GBAtemp Regular

    Member
    152
    24
    Sep 2, 2009
    I'm not sure if I should update or not now, Loadiine GX2 isn't as compatible with 3.1.0, and the only disc I have to update with is 5.3.2
     
    Last edited by vpd, May 3, 2016
  15. Dylon99

    Dylon99 Lord of Dank

    Member
    541
    326
    Jan 12, 2016
    Netherlands
    Some cave in the mariana trench
    NEVER UPDATE™
     
  16. x65943

    x65943 Resident Greekaboo, Amateur Dog Father

    Member
    2,563
    2,155
    Jun 23, 2014
    United States
    Indiana
    Almost no one is below 5.3.2 at this point. I don't think any devs are looking at systems lower than this.

    Therefore I think you're safe updating. Why would devs be wasting their time on fws no one has access to?
     
  17. KingpinSlim

    KingpinSlim Newbie

    Purchasing Wii U's at firmwares lower than that is actually surprisingly easy and not as much of a challenge as some claim online.

    Since the Wii U systems stocked at retailers are not moving as fast as other consoles of this generation there is still a very high likelihood of receiving one that is below 5.x.x.

    I got mine a short while ago and it was 4.x.x.

    Unless you buy a Wii U that has already been in use and therefor updated you still have a good shot at receiving lower firmwares.
     
    Last edited May 3, 2016
  18. mech

    mech ♥️♥️♥️♥️♥️♥️♥️♥️

    Member
    4,762
    3,040
    Oct 26, 2014
    Tuvalu
    There are devs with 3.1.0 so don't rush into updating from that firmware.


    Lol this for example, https://nwert.wordpress.com/2016/05/03/ioctlvhax/
     
    Last edited by mech, May 3, 2016
  19. vpd
    OP

    vpd GBAtemp Regular

    Member
    152
    24
    Sep 2, 2009
    I think if I update to 5.3.2 it will be due to compatibility issue's with games in loadiine. I'm not doing anything for now as I'm waiting for a wi-fi sd card I've just ordered to selfhost the exploit, and will keep looking for an easy to follow guide for hosting from a raspberry pi with no internet access in the meantime.

    Thanks for that info/link mech.
     
    Last edited by vpd, May 3, 2016
  20. SirByte

    SirByte GBAtemp Fan

    Member
    494
    191
    Dec 30, 2012
    Canada
    I'm still at 3.1.0U, and staying there for now as all the games I play work with it. As you can see from the link above, there are vulnerabilities, long since patched, that are being kept under wraps and start to trickle out slowly now. Who knows what the 4.0.0 -> 4.0.2 -> 4.0.3 -> 4.1.0 -> 5.0.0 -> 5.1.0 -> 5.1.1 -> 5.1.2 -> 5.2.0 -> 5.3.0 -> 5.3.1 -> 5.3.2 -> 5.4.0 -> 5.5.0 -> 5.5.1 updates patched. As they all had "Further improvements to overall system stability and other minor adjustments have been made to enhance the user experience".

    All I need is a userland + Kernel + IOSU and a way to boot into 5.5.1 RedNAND CFW (signature checks patched out, auto-update patched out, etc.)
     
    mech likes this.