New vita

Discussion in 'PS Vita - Hacking & Homebrew' started by joseph0042, Apr 19, 2015.

  1. joseph0042
    OP

    joseph0042 GBAtemp Regular

    Member
    141
    35
    Nov 5, 2012
    United States
    Hey guys, I just bought a vita and it is on 1.67. Should I update it to 3.18 manually? I don't have a PS3 though. Is there anyway to get the games onto it without one? Does the download queue bug still work? If 3.18 is the best fw to be on, is there a particular US game that works best for cfw?
     
  2. Cyberdrive

    Cyberdrive GBAtemp Regular

    Member
    134
    27
    Aug 6, 2013
    Serbia, Republic of
    You will need a PS3 at least once, to activate the Vita and download the exploitable game on it. There's no way around it other than updating to the latest firmware.
    Download queue only works for a week or two after the release of the latest firmware and only for the immediate previous firmware. I think that it doesn't work for 3.36 users anymore since firmware 3.50 is now almost a month old.

    If you aren't going to play Vita games that require firmware version newer than 1.67, you can keep 1.67 if it allows PS3-to-Vita transfers. It's especially suitable for attempts of hacking native side due to lack of the countermeasures Sony added in newer firmwares (for example, http://en.wikipedia.org/wiki/Address_space_layout_randomization was introduced in 1.80 IIRC)
    If you want to play newer Vita games, I would advise against updating past 3.18, since that is the most functional firmware to date which still supports recent (but not the newest) Vita games. You'll want to use XS Moto for PS1 games and Talkman Travel Tokyo for PSP games if you update to 3.18. Older firmwares may have better PSP exploit games, but these two are the most convenient for 3.18 users.
     
    OldDude likes this.
  3. OldDude

    OldDude Newbie

    Newcomer
    3
    0
    Apr 21, 2015
    Finland
    Thanks Cyberdrive for your post :)

    I'm in the same boat as Joseph. Just bought a Vita yesteday (got a new one for 80 Eur which seemed quite cheap). Its on FW 1.81, and tried connecting it to my PS3 but got the message that it needs a new FW to do so.

    Before I start upgrading my FW to 3.18 I'd have a few questions. Will I be able to get Netflix on 3.18? That is kind of mandatory, as I know my kids will like to watch Netflix on it (they are always fighting over our Ipad for that). Also, will I be able to use the remote play and other functionality of my PS4 on it? I don't really see a need for it though, but if Netflix will be impossible then I'll likely just update it to the newest official firmware.
     
  4. joseph0042
    OP

    joseph0042 GBAtemp Regular

    Member
    141
    35
    Nov 5, 2012
    United States
    Thanks guys. I ended up just updating to 3.5 and using the Ape hack. Did this for remote play on ps4.