NULL

Question Retroarch Rumble Mupenplus

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by Elalexyzoner, Mar 21, 2019.

  1. Elalexyzoner
    OP

    Elalexyzoner Alex95

    Member
    3
    Jun 5, 2016
    Mexico
    Near Texas
    Can anyone show me how to enable the rumble with the newest core of Mupen...? Thanks in advance.
     
  2. Milenko

    Milenko GBAtemp Advanced Maniac

    Member
    9
    Oct 16, 2017
    Australia
  3. Elalexyzoner
    OP

    Elalexyzoner Alex95

    Member
    3
    Jun 5, 2016
    Mexico
    Near Texas
    I didn't get right the explanation of that thread:( they said to enable the rumble feature in the 1st player in core options, then enable Rumble but in System setting but i didn't work, or it doesn't work with the Pro controller...?
     
  4. seanp2500

    seanp2500 GBAtemp Advanced Fan

    Member
    6
    Jun 2, 2010
    United States
    Works with my pro controller you gotta go to settings turn it off then on then go to options when a game is loaded change mem pak for player one to rumble save your game options and reload it should work after that
     
  5. Elalexyzoner
    OP

    Elalexyzoner Alex95

    Member
    3
    Jun 5, 2016
    Mexico
    Near Texas
    What setting? Retroarch or Switch?
     
  6. Elalexyzoner
    OP

    Elalexyzoner Alex95

    Member
    3
    Jun 5, 2016
    Mexico
    Near Texas
    Well... i did everything and my Switch refused to work... maybe its just mine
     
  7. seanp2500

    seanp2500 GBAtemp Advanced Fan

    Member
    6
    Jun 2, 2010
    United States
    first turn it off then on in nintendo switch controller settings the setting vibration

    then after load mupen core save rumble as player 1 pak change from memory to rumble sav that option reload game what game u playing?
     
  8. DollyWhipDoll

    DollyWhipDoll Royalty & Unbothered. LMFAO!!! ;)

    Member
    6
    May 18, 2018
    United States
    First off, Make sure RetroArch is not running.


    Go to Switch's Settings menu, down to controllers, turn vibration off and back on again

    After that, go to RetroArch, load core, load content, go to Quick Menu, then Options, scroll toward the bottom for the controller section, be sure rumble is turned on for the game, go to the top of the Options menu and save the settings for that game before backing out, restart RetroArch and you should have rumble
     
  9. hippy dave

    hippy dave BBMB

    Member
    14
    Apr 30, 2012
    United Kingdom
    Just because nobody mentioned it already - it only works on some games. There was a list linked from the retroarch thread.

    e: found the link.
     
    Last edited by hippy dave, Mar 21, 2019
  10. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    18
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Yup. And it's pretty obvious which games support it as they will ask you to insert it. The only case I remember not being entirely obvious was Zelda OoT. You had to first collect enough Skulltulas to get the Stone of Agony to even be aware that the rumble pak was supported. Which is something you can easily play through the entire game without getting.
     
    Last edited by The Real Jdbye, Mar 21, 2019
  11. FlexingTiger

    FlexingTiger Advanced Member

    Newcomer
    2
    Jan 25, 2017
    United States
    I just tested this feature, and rumble only worked at first time, maybe there was something wrong in the new feature.
     
  12. regnad

    regnad Button Masher

    Member
    8
    May 19, 2008
    Did you figure it out? You need to do three things, which apparently hasn't been made clear and drove me up the wall until I figured it out.

    1) Go to Switch system settings, turn off vibration, then turn it on again. You have to do again this every time you shut down the Switch.

    2) Open RA. Go to RA settings, input, enable device vibration.

    3) Launch Mupen core. Run a game that uses rumble. Then while the game is running back out to the menu (+ and -) and go to options, go down toward the bottom and change Player 1 Pak to rumble.

    — Posts automatically merged - Please don't double post! —

    What do you mean by "first time"? It works for me all the time.

    Did your settings get saved? By default settings get saved when you close RA, but you may have changed that. Did you check to make sure your rumble settings were still set correctly?
     
    stick267 likes this.
Loading...