New DSiXL user, with DSTTi card...

Discussion in 'NDS - Console and Game Discussions' started by thegofa, May 29, 2012.

May 29, 2012
  1. thegofa
    OP

    Newcomer thegofa Newbie

    Joined:
    May 29, 2012
    Messages:
    8
    Country:
    New Zealand
    Hi All,

    My first post so I hope its in the right place, apologies if it isnt.

    Ive just bought a DSi XL which has Version 1.4.4A Firmware on it. It came with a DSTTi card and an 8gb card in it.

    Can someone please tell me if this will work in the DSi XL and if so where do I find the files I need to play all the games on the card.

    I have a lot of bought games but there are some very old ones on the card I cant even buy any more.

    Thanks for any help you can give.
    TG.
     
  2. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    What's the site printed on the cart?

    And you'll have to put it in and try to run it. If the DSi itself gives you an error message about restarting it, then it won't work. If it doesn't and the cart just fails to load properly, then it should work.
     
  3. thegofa
    OP

    Newcomer thegofa Newbie

    Joined:
    May 29, 2012
    Messages:
    8
    Country:
    New Zealand
    The DSTTi cart has the 8gb chip in it with a whole ton of games on it, but when I start the DSi XL with it inserted it says an error has occured and restart the DSi :(

    Isnt there anything we can do, flash firmware etc? (I had a PSP and flash uprgraded many times so im an old hand)

    Thanks for helping.
    TG.

    EDIT: Sorry the card has ndstt. com on it but thats a pretty defunct site now.
     
  4. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    You can't edit the DSi's firmware, you'll need to update the flash cart's firmware. Two problems with that though.

    1 - There's no universal firmware. You'll need the specific update for your cart model from the site.
    2 - You need to be able to run the cart in order to update it.

    Get a new cart, and make sure the store you buy it from updates their carts before sending them out.
    http://gbatemp.net/t290097-which-flash-cart-should-i-get
     
  5. thegofa
    OP

    Newcomer thegofa Newbie

    Joined:
    May 29, 2012
    Messages:
    8
    Country:
    New Zealand
    Well it would seem the Supercard DSTwo is the choice here then. Will the 8gb mem card I have fit in it, and if so where do I get the software (menu etc).

    Thank you for being so helpful Rydian, sorry to ask such dumb questions.
    TG.

    Edit: Sorry also you said make sure the store updates the cart, is that onboard or does it need a mem card to put that on from the start??
     
  6. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    If it's a MicroSD it should work.

    The setup guide is here; http://gbatemp.net/topic/290190-the-supercard-dstwo-beginners-guide/

    And no problem.

    And it's onboard. It's placed on the MicroSD, but then you have to run it and it updates the card's onboard memory itself, which is why you can't update your current (since you can't run it to update it).
     
  7. thegofa
    OP

    Newcomer thegofa Newbie

    Joined:
    May 29, 2012
    Messages:
    8
    Country:
    New Zealand
    My son has a DS Lite, which will run the cart & the games on the mem card. Can I use that to update it?

    Hes got himself a new 3DS so doesnt use it but it works fine. And yes it is a Micro SD 8gb.

    TG.
     
  8. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Yeah you can use a DS Lite to update it, and after the update it'll work on the DSi/XL and 3DS.
     
  9. thegofa
    OP

    Newcomer thegofa Newbie

    Joined:
    May 29, 2012
    Messages:
    8
    Country:
    New Zealand
    OMG thats great news. I still need your advice im afraid, then I promise to leave you in peace.

    How do I get this cart and card to work on this DSi 1.4.4 ? Never done this before, only flashing PSPs a long time ago.

    Not sure what files to get, where to put them or how to upgrade things.

    Thanks for your patience Rydian, it is very much appreciated.
    TG.
     
  10. chris888222

    Member chris888222 GBAtemp's Flygon Fan

    Joined:
    Oct 11, 2010
    Messages:
    5,532
    Country:
    Singapore
    Updating the DSTTi or DS2?

    You need to download the latest kernel files (or OS files - whatever you call it) from the site printed on the cart. You also need to make sure that it supports V1.4.4 or else it's pretty pointless.

    Where to put the files? Open up your MicroSD on the computer, the first screen you see is the place you paste the files. The flashcart sites call it the root of the MicroSD. This also applies for DS2.

    I'm sure there are some custom firmware for the DSTTi (something like Wood firmware for R4) which can let it run on V1.4.4 if the official kernel can't. I'm not too sure about this since I don't own a DSTTi.
     
  11. thegofa
    OP

    Newcomer thegofa Newbie

    Joined:
    May 29, 2012
    Messages:
    8
    Country:
    New Zealand
    Sad face, didnt work for me. I d/l the 1.4.1 firmware update and the 1.17 TT menu. Put these onto the DSTTi and started the DSLite.

    Menu came up, im like sweeeeeet, clicked on the 1.4.1 updater, went through to 100%, said power off, did that.

    Put the cart into my DSiXL and started it. In the menu was "Alex Rider - Stormbreaker - DHS" as the game in the slot???

    Clicked it and BAM, "error has occured, hold button to restart" etc...

    Really though it might work for me :(

    Thanks everyone for trying to help me, appreciate all your efforts.
    TG.
     
  12. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Yeah the game icon changes as a way to trick the DSi/XL/3DS into running it.

    Also you used the 1.4.1 update, but what you need is 1.4.4. I didn't mention updating your current cart because the site doesn't have the update you need, thus the suggestion to get a new cart that has updates.
     
  13. thegofa
    OP

    Newcomer thegofa Newbie

    Joined:
    May 29, 2012
    Messages:
    8
    Country:
    New Zealand
    Its cool, I will leave the old cart and fill it up with games so we can use it on the old DS Lite.

    Will get a new one, Supercard DSTwo seems a good choice, and try again.

    If I get lost I will come see you again, but in the meantime, thank you for all your help.

    Cheers,
    TG.
     
  14. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    You're welcome, and good luck.
     
  15. chris888222

    Member chris888222 GBAtemp's Flygon Fan

    Joined:
    Oct 11, 2010
    Messages:
    5,532
    Country:
    Singapore
    If you lack $$, the Acekard 2i is another solid choice.
     
  16. thegofa
    OP

    Newcomer thegofa Newbie

    Joined:
    May 29, 2012
    Messages:
    8
    Country:
    New Zealand
    Thanks Chris, I will take a look at that one too, thanks for your help too mate.

    TG.
     

Share This Page