Neo MK5 loader update v1.23a

Discussion in 'GBAtemp & Scene News' started by shaunj66, Feb 19, 2007.

Feb 19, 2007

Neo MK5 loader update v1.23a by shaunj66 at 11:16 AM (1,463 Views / 0 Likes) 9 replies

  1. shaunj66
    OP

    Administrator shaunj66 Administrator

    Joined:
    Oct 24, 2002
    Messages:
    9,830
    Location:
    South England
    Country:
    United Kingdom







    Neo MK5 loader update v1.23a

    Out now








    The Neo team have recently released an updated loader for their MK5 flash cart. Read only DLDI support, increased ROM compatibility and a few other bug fixes have been added. Here's the full change log:
    [​IMG] Download: MK5 loader v1.23a
    [​IMG] MK5 Homepage


     
  2. Qpido

    Member Qpido Call me Q.

    Joined:
    Jul 12, 2006
    Messages:
    634
    Country:
    Netherlands
    Are people even buying this product?

    Q~
     
  3. zatelli

    Member zatelli GBAtemp Advanced Fan

    Joined:
    Jun 27, 2003
    Messages:
    540
    Location:
    Always on the move...
    Country:
    France
    Why not? One shouldn't be that narrow minded. If previous iterations sucked, it doesn't necessarly mean this one does.
    Just my 2 cents. I would wait for a proper review before I'd make my mind.
     
  4. Modrak

    Member Modrak GBAtemp Regular

    Joined:
    Dec 14, 2006
    Messages:
    158
    Country:
    Czech Republic
    But it could hint people that it will suck too [​IMG]
    I think we have a winner on the Slot-1 market and that's the R4/M3Simply. What you get for the price is amazing. No other cart has 100% compatibility.
     
  5. Monkey01

    Member Monkey01 GBAtemp Advanced Fan

    Joined:
    Aug 27, 2006
    Messages:
    586
    Location:
    The Netherlands
    Country:
    Netherlands
    AceKard? [​IMG]
     
  6. quartercast

    Member quartercast GBAtemp Regular

    Joined:
    Oct 18, 2006
    Messages:
    250
    Country:
    Australia
  7. Modrak

    Member Modrak GBAtemp Regular

    Joined:
    Dec 14, 2006
    Messages:
    158
    Country:
    Czech Republic
    Oh, thanks for the screwup called "AKFS" and not being able to use it on Mac. (no offence, but points down for that)
    I think that R4/M3Simply really shines [​IMG]
     
  8. sylver78

    Newcomer sylver78 Advanced Member

    Joined:
    Oct 16, 2006
    Messages:
    94
    Country:
    France
    Update your information and learn that the new Acekard (Acekard+) is supporting FAT now (not only their AKFS) [​IMG]
    Read more about it : http://gbatemp.net/index.php?showtopic=43999
    And it's also have a DLDI driver available [​IMG]

    Sylver
     
  9. Moztruitu

    Newcomer Moztruitu Newbie

    Joined:
    Mar 7, 2006
    Messages:
    4
    Country:
    Spain
    Some time ago i made the mistake to buy a Neoflash Mk3.......two years have passed since i bought this and the mk3 still don't work well.

    It's sure and not only for my opinion, that the Neoflash products are a swindle, a fraud, a deceit.

    I can't recuperate my money, but almost i can advise everybody to don't waste money and time in any product of Neo-Team.
     
  10. Rankio

    Member Rankio GBAtemp Fan

    Joined:
    Mar 7, 2007
    Messages:
    417
    Country:
    United States
    I made the mistake of ordering a Neo2 also and man, that really turned me off from this company. Surprisingly the MK5 is really good. So far I have had zero problems, everything I've thrown at it works. Plus 60 bucks for 2gigs is pretty good.

    Only thing I wish they would change is the menu. The 3D boxes are ugly and the cart doesn't auto-boot. Apparently this cart isn't exactly made by the NeoTeam, I think they licensed it from someone else. There are 3 or 4 other carts that are similar.

    After picking up the MK5, I rarely use my G6. I still can't part with the G6 though, something about it I just like too much.
     

Share This Page