Need help with new mobo/cpu.

Discussion in 'Computer Hardware, Devices and Accessories' started by TrolleyDave, Jul 27, 2011.

Jul 27, 2011
  1. TrolleyDave
    OP

    Former Staff TrolleyDave Philosolosophising

    Joined:
    Jan 1, 2007
    Messages:
    7,762
    Location:
    Wales, UK
    Country:
    United Kingdom
    Last week my PC went belly up. The PSU cut out and wouldn't come back on. I replaced it with a new 500w PSU hoping that would solve the problem but it didn't unfortunately. It would power the mobo (CPU fan spun, power switch worked for on/off) but do nothing else. Guessing that the PSU going took out the mobo/cpu I bought new ones. They arrived today but after installing couldn't get them to work either! lol They had the exact same problem that my old mobo/cpu had.

    As a test I decided to install the old mobo/cpu in another case with the 500w PSU and lo and behold they came to life! Guessing that there was some kind of problem with my other case (although I'm still confused as to how that's even possible! lol) I moved the new mobo/cpu into the other case but still had no luck. [​IMG] As a test I removed the ram and switched the PC but wasn't greeted with the usual error beeps. The new mobo is a Biostar A780L3L 760G, the new CPU is an Athlon x2 250 and I bought new DDR3 RAM as the board doesn't handle my old DDR2. All I get on boot is a black screen, it never reaches the BIOS/post stage and like I say there's no error beeps if I try booting with no ram installed.

    My old board is a Biostar GF8100 m2g+ which has an AM2+ socket and claims to be compatible with the new CPU. I updated the BIOS as the Biostar website stated and stuck the AM3 chip in it but still no joy. It powers up, then after a few seconds powers down again, then a few seconds later powers up again and repeats this cycle til I switch it off. The power switch works to switch it off when it's in this loop as well.

    Anyone got any ideas or am I right in thinking that the CPU is DOA?
     
  2. raulpica

    Supervisor raulpica With your drill, thrust to the sky!

    Joined:
    Oct 23, 2007
    Messages:
    10,670
    Location:
    _____________ PowerLevel: 9001
    Country:
    Italy
    As the old case, maybe there's something which shorts things on the under-side of the board.

    Have you tried powering up the new mobo/cpu on a table or something?

    If it doesn't beep with no RAM, then it doesn't even gets at the phase that it checks for the RAM.

    Before that, it checks for the CPU, the Southbridge and the Northbridge a few other things, and then it gets onto the RAM. That makes me think that the CPU might've been fitted wrongly. Try to fit it in place again [​IMG]

    Also check all the little pins beneath the new CPU. Some might've been bent accidentally!
     
  3. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,736
    Country:
    United Kingdom
    Before you get to raulpica's advice can I suggest you look at the switches- I have had quite a few die these last few months (this last year?) and that sounds like classic switch bounce failure (not to mention if this is the same PC you have been nursing along the last couple of years even more so). As a test I usually jump the pins manually (if I feel like being dramatic I will use my keys or something small enough and random enough) and watch it all spring to life.

    Bonus is your reset button should still be good but if not or it is not viable a PTM (push to make) switch can be found easily enough or you can cut the wires and "hotwire" your PC.
     
  4. qlum

    Member qlum Posting when needed

    Joined:
    Sep 25, 2008
    Messages:
    562
    Location:
    The Pirate Homeworld
    Country:
    Netherlands
    never mind
     

Share This Page