NDS or NDSi?

Discussion in 'Acekard' started by RhiGhost, Aug 4, 2009.

  1. RhiGhost
    OP

    RhiGhost GBAtemp Regular

    Member
    169
    0
    Jun 4, 2008
    Australia
    Ok so I just sold my DSi to a friend because I had updated it to firmware 1.4 and my Acekard 2i did not work anymore.
    I really loved using he DSi and would rather have one than a DS but would I be better just buying a DS so I don't have to worry about
    future updates on the DSi? I know there probably will be an update for the Acekard but I don't want to wait lol.
    I could buy a DSi and not update but like I said, who knows what Nintendo will bring out in the next updatem, they could even make them mandatory.
    Your thoughts?
     
  2. PettingZoo

    PettingZoo yesss

    Member
    1,711
    1
    Oct 5, 2008
    in the trap
    I'm not sure they would be able to force the DSi firmware update on you seeing as they don't do that with the Wii. You shouldn't have sold it imo because the M3 team said they would come up with a fix in a week. Though obviously it would be a bit longer than a week other teams could have solved the problem and then other teams branching off from that update.
     
  3. PenguinSlap

    PenguinSlap GBAtemp Regular

    Member
    101
    0
    Aug 1, 2009
    United States
    I will say DS Lite because the CycloDS is the best flashcart for it.
    But I have a DSi with AceKard 2i and DSTTi firmware 1.3.
    But overall the DSi, because there might be CycloDSi.
    I been waiting for that CycloDSi.
     
  4. zero383

    zero383 GBAtemp Advanced Fan

    Member
    649
    0
    Apr 4, 2009
    Canada
    Vancouver - #1 City in Canada
    Why did you update the firmware? You didn't have to if you didn't want to unless you really wanted the new changes.
     
  5. benjaminlibl

    benjaminlibl Funky Member

    Member
    789
    0
    Jul 15, 2009
    Senegal
    Singapore
    Wow, you are very impatient and probably very rich. Anyways.

    I don't see how they could make firmwares mandatory though, unless there a new games only for DSi that require something like that. They can't make you go on the internet without your permission.
     
  6. RhiGhost
    OP

    RhiGhost GBAtemp Regular

    Member
    169
    0
    Jun 4, 2008
    Australia
    I had updated the firmware before I knew it locked out the Acekard, I didn't even think twice because I hadn't seen any warnings on here at that time.
    I'm not rich...I sold the DSi to my friend for the amount I paid for it, so I can go buy another one without the update on it, or a DS.
    Thats my question. I don't want to buy another DSi if this is going to happen again and not be fixable, I'm worried about the future DSi updates thats all.
     
  7. benjaminlibl

    benjaminlibl Funky Member

    Member
    789
    0
    Jul 15, 2009
    Senegal
    Singapore
    It is going to happen again. There is a very high chance Nintendo will keep releasing firmwares that make flashcarts unusable. But again, you don't have to install them. And it IS fixable.
     
  8. Da-Bomb1

    Da-Bomb1 GBAtemp Advanced Fan

    Member
    795
    0
    Apr 19, 2009
    Canada
    BC, Canada
    If you don't install them, it'll prevent you from playing any DSiWare games you've bought in the past, I hear.
     
  9. dhjohn

    dhjohn GBAtemp Regular

    Member
    124
    0
    Jul 9, 2009
    United States
    Right now, all Dsiware games are still usable without updating. You just cannot buy new ones.
     
  10. RhiGhost
    OP

    RhiGhost GBAtemp Regular

    Member
    169
    0
    Jun 4, 2008
    Australia
    I got a DSi [​IMG]
    End of discussion