ROM Hack Mii Plaza puzzle hacked meet.dat won't import in JKSM

NicNamSam

Member
OP
Newcomer
Joined
Oct 27, 2019
Messages
11
Trophies
0
Age
27
XP
56
Country
United States
I have an old 3DS that I transferred everything FROM to my new 3DS. I then created a new account on my old 3DS. Because of this, my Mii Plaza is empty. I only have 2 puzzle panels at the moment.

I tried following the tutorial here: gbatemp.net/threads/streetpass-mii-plaza-puzzle-swap-save-editor.420765/

But when I try to import/restore the edited meet.dat, JKSM throws an error: "There was an error opening the file for writing." and then "0x00000001"

If I edit even one single bit of the meet.dat with a hex editor, JKSM throws the error. I'm thinking there's two possibilities.

1) I have to unlock the panels first. I don't know what the logic is behind unlocking panels. I tried turning off and on spotpass as an online guide said, but I didn't get any new panels. I got a notification that I did (several actually, since I've done it several times), but I don't actually have any new panels. Shouldn't there be a hack to get all the panels anyway? EDIT: I used the online editor to complete only a puzzle panel I had unlocked and JKSM is still throwing the error. I don't think the panel thing is the issue.

2) It's an issue with JKSM. Before I updated to the most recent version of JKSM, I couldn't even import a meet.dat file that I just exported. It would throw the same error as above. The newest version can now import a meet.dat file that I just exported with no problem. But maybe there's still an issue somewhere?
 
Last edited by NicNamSam,

You may also like...

General chit-chat
Help Users
    KenniesNewName @ KenniesNewName: Don't forget to like them +1