1. DeeVeeBee

    OP DeeVeeBee Newbie
    Newcomer

    Joined:
    Aug 24, 2020
    Messages:
    3
    Country:
    United States
    Hey all, I've been trying for hours to get MPT to run, but everytime I start it up it jist freezes on a black screen that requires a hard reset. I've gotten it to run once on USBLoader and once on WiiFlow, but after that it just refuses to boot up. I've messed around with my cIOS settings a bunch and still can't figure it out. Any help would be appreciated as I really want to play this game.

    Also, this is the first time I've ever tried to load a game like this. I only recently learned how to mod my Wii, and am not really very skilled when it comes to this kind of stuff.
     
    jeannotte likes this.
  2. jeannotte

    jeannotte GBAtemp Psycho!
    Member

    Joined:
    Jun 15, 2016
    Messages:
    3,215
    Country:
    France
    Hello ,

    Post a syscheck report here, following this guide == <https://gbatemp.net/threads/posting-a-system-check.300279/

    What are the versions of the loaders ??
     
    alexander1970, XFlak and Lacius like this.
  3. DeeVeeBee

    OP DeeVeeBee Newbie
    Newcomer

    Joined:
    Aug 24, 2020
    Messages:
    3
    Country:
    United States
    Here is my syscheck:

    SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
    ...runs on IOS58 (rev 6176).

    Region: NTSC-U
    System Menu 4.3U (v513)

    Drive date: 07.14.2008
    Homebrew Channel 1.1.2 running on IOS58

    Hollywood v0x21
    Console ID: 64509759
    Console Type: Wii
    Shop Channel Country: United States (49)
    Boot2 v4
    Found 128 titles.
    Found 49 IOS on this console. 14 of them are stubs.

    IOS3 (rev 65280): Stub
    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 256): Stub
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 1032): No Patches
    IOS20 (rev 256): Stub
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 2816): Stub
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 3072): Stub
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 5120): Stub
    IOS51 (rev 4864): Stub
    IOS52 (rev 5888): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 6400): Stub
    IOS61 (rev 5662): No Patches
    IOS62 (rev 6430): No Patches
    IOS70 (rev 6912): Stub
    IOS80 (rev 6944): No Patches
    IOS202[60] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
    IOS222[38] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223[38+37] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS224[57] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
    IOS249[57] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS250[56] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65280): Stub
    BC v6
    MIOS v10
    Report generated on 08/25/2020.

    USBLoader is v3.0 rev1272. WiiFlow is v5.4.3.

    I actually got USBLoader to run last night after using ModMii to replace some of the IOS files, and got a decent ways into the game, but after turning off my Wii the problem started up again. Then, this morning after I ran the syscheck, both loaders just freeze when I try to boot them up. I'm so confused....
     
    jeannotte likes this.
  4. jeannotte

    jeannotte GBAtemp Psycho!
    Member

    Joined:
    Jun 15, 2016
    Messages:
    3,215
    Country:
    France
    Test the version of usb loader gx (1271), here ==>https://sourceforge.net/projects/usbloadergx/files/Releases/New revisions (3.0+)/

    version 1272 of usb loader gx has some problems, it has been downgraded.

    For wiiflow, use version 5.4.6 ==>https://github.com/Fledge68/WiiFlow_Lite/releaseshttps://wii.guide/priiloader

    Install priiloader to block updates, by following this guide ==>https://wii.guide/priiloader

    what is your usb support (usb key, external hard drive) ??
     
    Last edited by jeannotte, Aug 25, 2020
    alexander1970 likes this.
  5. DeeVeeBee

    OP DeeVeeBee Newbie
    Newcomer

    Joined:
    Aug 24, 2020
    Messages:
    3
    Country:
    United States
    Okay, so I installed rev1271 and Priiloader. Went to boot up USBLoader, and now it's just stuck on "Initialize USB device", smh.

    I'm using a SanDisk Ultra USB 3.0 key.
     
    Last edited by DeeVeeBee, Aug 25, 2020
    jeannotte likes this.
  6. jeannotte

    jeannotte GBAtemp Psycho!
    Member

    Joined:
    Jun 15, 2016
    Messages:
    3,215
    Country:
    France
    Hello,

    OK for usb loader gx and Priiloader.

    Is your usb key plugged into port 0 of the Wii ??

    The problem comes from your USB key (often black screen or does not start)

    Get an external hard drive in FAT 32 and you will be fine.
    Western Digital generally works well with wii.

    USB compatibility ==>https://wiki.gbatemp.net/wiki/USB_Devices_Compatibility_List
     
    alexander1970 and XFlak like this.
  7. TokyoRebirth

    TokyoRebirth Newbie
    Newcomer

    Joined:
    Nov 16, 2020
    Messages:
    8
    Country:
    United States
    Hey,

    I'm not the OP, but I have the exact same situation going on as he has. My Wii was new and I followed the latest banner bomb tutorials. However, I use an external drive instead of a USB drive (FAT32, stuck into the bottom port if you move the Wii horizontally).

    I tried a ton of versions of MPT and all (!) do the same thing: I can get into the menu with no problem, I can also change options and play around with the menu, load up the to idle screen so a clip is showing, but once I click on one of the games, the games freezes after the "Metroid Prime X is loading" screen. It goes directly into a black screen, followed by my Wii just rebooting without a picture, so I have to turn it off.

    Other games work with the rev1271 USB Loader GX with no problem at all. I also checked everything from the Priiloader Tutorial you linked in one of your posts.

    cIOS 249 and 250 both not the alt version are also installed and so far working (the alt version gave me some freezes, so I had to move back to the standard version) - since the last time I hacked a wii is 14 years ago... do I miss any cIOS? Back then I recall I installed a ton of cIOS but now it feels so empty lol

    My Wii is holy to me since I have a WiiDual installed in it. ;)
     
    jeannotte likes this.
  8. jeannotte

    jeannotte GBAtemp Psycho!
    Member

    Joined:
    Jun 15, 2016
    Messages:
    3,215
    Country:
    France
    Hello,

    Post a syscheck report by following this guide ==>https://gbatemp.net/threads/posting-a-system-check.300279/

    Maybe your game is corrupt, try to re-dump (original copy of the game).
     
    TokyoRebirth and alexander1970 like this.
  9. TokyoRebirth

    TokyoRebirth Newbie
    Newcomer

    Joined:
    Nov 16, 2020
    Messages:
    8
    Country:
    United States
    Did the SysCheck, here you go:

    SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
    ...runs on IOS58 (rev 6176).

    Region: PAL
    System Menu 4.3E (v514)
    Priiloader installed
    Drive date: 12.18.2008
    Homebrew Channel 1.1.2 running on IOS58

    Hollywood v0x21
    Console ID: 134897833
    Console Type: Wii
    Shop Channel Country: United Kingdom (110)
    Boot2 v4
    Found 72 titles.
    Found 48 IOS on this console. 16 of them are stubs.

    IOS3 (rev 65280): Stub
    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 256): Stub
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 1032): No Patches
    IOS20 (rev 256): Stub
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 2816): Stub
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 3072): Stub
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 5120): Stub
    IOS51 (rev 4864): Stub
    IOS52 (rev 5888): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 6400): Stub
    IOS61 (rev 5662): No Patches
    IOS62 (rev 6430): No Patches
    IOS70 (rev 6912): Stub
    IOS80 (rev 6944): No Patches
    IOS222 (rev 65280): Stub
    IOS223 (rev 65280): Stub
    IOS249[56] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
    IOS250[57] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
    IOS251[58] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65280): Stub
    BC v6
    MIOS v10
    Report generated on 10/31/2010.

    I also used different versions / images. (my original copy is 14.000 km west of me... So I won't be able to get a new rip anytime soon)
    I also tried to extract the images. There is a tool flying around that extracts Metroid Prime 1 and 2 out of the trilogy, but even there the same thing happened. It always happens when the game tries to load.

    Since the SysCheck, I'm a bit curious - should the IOS revisions be always patched (since it says "No Patches")? And thank you for the quick response. There are a few people out there with the same problem, but all of the threads are 5 to 9 years old. Since then, much has changed for the homebrew community of the Wii, and I was glad to find a "fresh" thread out here. ;)
     
    alexander1970 and jeannotte like this.
  10. TokyoRebirth

    TokyoRebirth Newbie
    Newcomer

    Joined:
    Nov 16, 2020
    Messages:
    8
    Country:
    United States
    If there is anything else I can share, just ask. Up until now I tried different things but the outcome was the same :/
     
  11. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08
    Member

    Joined:
    Mar 17, 2010
    Messages:
    20,900
    Country:
    Norway
    Sounds like a classic IOS reloading issue. I thought this is fixed on the cIOS level now so you don't have to mess with any USB loader settings, but you can try to change the "Block IOS Reload" setting in USB Loader GX.
     
    TokyoRebirth likes this.
  12. TokyoRebirth

    TokyoRebirth Newbie
    Newcomer

    Joined:
    Nov 16, 2020
    Messages:
    8
    Country:
    United States
    Just tried that in all three options - auto, off and on. But it still happens :/
     
  13. TokyoRebirth

    TokyoRebirth Newbie
    Newcomer

    Joined:
    Nov 16, 2020
    Messages:
    8
    Country:
    United States
    I wonder if there is anything in the SysCheck of notice... Since I don't know what to look at - I read the tutorial linked in the SysCheck review, but it went right through with no freeze at all.
     
  14. XFlak

    XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    11,468
    Country:
    Cyprus
    Try using cios250 in the game specific settings, perhaps this title requires base 57 which you have installed to slot 250 as an alternative (instead of 249)
     
    alexander1970, KiiWii and jeannotte like this.
  15. TokyoRebirth

    TokyoRebirth Newbie
    Newcomer

    Joined:
    Nov 16, 2020
    Messages:
    8
    Country:
    United States
    I did that already before posting in this thread - Kirby Return to Dream Land is like that too. It freezes up when I use slot 249, but it works with 250. Metroid however does not. And all of that irritates me, because I followed the latest tutorials you can get.

    Am I missing some cIOS? Or does MPT have problems with a split WBFS file? Since it's a FAT32 drive, I'm unable to use a whole file like that. Or I'm missing something and the Wii is able to read exFAT all of a sudden... ;)
     
    Last edited by TokyoRebirth, Nov 19, 2020
  16. XFlak

    XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    11,468
    Country:
    Cyprus
    Try reripping, others have managed to get it to work with a similar setup so it should work for u.

    Or try a different/updated loader.

    As a last resort you can try the alt-dol method which is pretty much obsolete these days because we've gotten around the ios reloading issue. I think some loaders may offer you alt-dol's to choose from from the game itself, otherwise you may have to extract it and point the loader to it. TBH it's been so long I don't recall all the specifics, but that's it in a nutshell

    Edit: with the alt-dol method, you basically bypass the game's main menu and select which of the 3 metroid prime games u want to play by selecting the corresponding alt-dol, then you load right into it. To switch games, u need to go back to the loader and change the alt-dol
     
    Last edited by XFlak, Nov 19, 2020
    jeannotte likes this.
  17. tswntk

    tswntk GBAtemp Advanced Fan
    Member

    Joined:
    Aug 6, 2012
    Messages:
    990
    Country:
    Switzerland
    if your loader is updated enough, you don't need the alt-dol method.
    MPT is famous for having bad dumps (yes, due to dual layer) floating around, if you go to bad download sites, than no matter how many download you've tried, they are bad.

    Also noted that MPT is NOT compatablw with emu nand, turn emunandsave to off

    PS: don't ask where to find good dumps - its against forum rules and I will ignore/report PM on this matter.
     
    Last edited by tswntk, Nov 20, 2020
  18. TokyoRebirth

    TokyoRebirth Newbie
    Newcomer

    Joined:
    Nov 16, 2020
    Messages:
    8
    Country:
    United States
    That's OK. I haven't asked for any dumps ;)
    I think my rom dumps are quite good so far.

    I managed to get it to work, however whatever I try it's not compatible in USB Loader GX. It works in WiiFlow Lite (the latest one you can download currently)

    Now... why is that the way it is? I mean, does the Loader change so much stuff while launching? Or does WiiFlow use other settings I can clone to the USB Loader GX? I'm unfamiliar with the Loader. And from what I read, USB Loader GX is more compatible with the games than WiiFlow. At least it works, finally. I was going to turn of the Wii in the Second the game started playing lol
     
  19. tswntk

    tswntk GBAtemp Advanced Fan
    Member

    Joined:
    Aug 6, 2012
    Messages:
    990
    Country:
    Switzerland
    I completed MPT at least in Normal and Hard mode for the 3 games and hyper mode for one the games with usbloadergx 1262
    enough said.
     
    jeannotte likes this.
  20. XFlak

    XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    11,468
    Country:
    Cyprus
    I believe all the main loaders had to be updated to support no ios reloading with compatible cIOSs. I think GX has an option for this as well, you should make sure ios reloading is blocked! If it doesn't work, or the option is missing, try updating your USB loader. The latest one for gx I believe is this one here:

    https://gbatemp.net/posts/8856063/
     
    jeannotte likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - USBLoaderGX, Metroid, WiiFlow