Luma3DS 8.0 and its problems

Discussion in '3DS - Homebrew Development and Emulators' started by BlastedGuy9905, Jun 6, 2017.

  1. BlastedGuy9905
    OP

    BlastedGuy9905 Ace Bricker

    Member
    1,218
    725
    Apr 13, 2017
    United States
    Outside your windows ᕙ(◔ᗜ◔)ᕗ
    I've just updated to 8.0 and B9S v1.2 (the menu is awesome btw) and I noticed that the version was quite unstable...
    In the menu, I was playing around with InputRedirection (AMAZING function), and I was in a game session. I wanted to stop InputRedirection, so I opened the menu, and stopped it from the Misc. options. Actually...
    "would've" stopped is more reasonable, since when I pressed the button, I got an exception error. R.I.P save file.
    Also, the chainloader is completely broken. I wanted to start GodMode9 to move my boot.firm to CTRNand too, so I could boot without an SD card. It literally just jumps straight to an exception.
    Did I do something wrong? Is this version broken?

    Note: I have the stable version, not the hourly one, so that's not the problem.
     


  2. thisisallowed

    thisisallowed 中国御宅族

    Member
    545
    123
    Oct 8, 2015
    China
    Jinan, Shandong
    When I played around with the code of 8.0, I accidently stopped the GPU and caused top screen flickering for the whole night. But that doesn't count as a bug.
     
  3. BlastedGuy9905
    OP

    BlastedGuy9905 Ace Bricker

    Member
    1,218
    725
    Apr 13, 2017
    United States
    Outside your windows ᕙ(◔ᗜ◔)ᕗ
    lol, nice job. have you got it working again?
     
  4. XxShalevElimelechxX

    XxShalevElimelechxX GBAtemp Regular

    Member
    181
    118
    Mar 30, 2016
    Israel
    Reddit says its a prerelease, i didnt check it myself tho, but if it is, i suppose there wipp be a stable version very soon.
     
  5. thisisallowed

    thisisallowed 中国御宅族

    Member
    545
    123
    Oct 8, 2015
    China
    Jinan, Shandong
    Just a hard reset did it. Anyway, now my shitty fork has shutdown+reset in the menu just like NTR. Shutdown isn't working properly tho, you must exit the menu for it to take effect.
     
    Last edited by thisisallowed, Jun 6, 2017
    Ryumaru likes this.
  6. BlastedGuy9905
    OP

    BlastedGuy9905 Ace Bricker

    Member
    1,218
    725
    Apr 13, 2017
    United States
    Outside your windows ᕙ(◔ᗜ◔)ᕗ
    nice!
     
  7. phalk

    phalk Handheld Maniac

    Member
    426
    260
    Apr 23, 2009
    Brazil
    Can you add to your fork an option to save the hbmenu target app to the luma config so it would change automatically each boot? I'd use it if you could implement that ;p
     
  8. Omegapsy

    Omegapsy Advanced Member

    Newcomer
    99
    22
    Feb 20, 2012
    United States
    • The GodMode9 error might be just you having an outdated FIRM file for it. Since I am on 8.0 /w b9s 1.2 and can load GM9 with no problems.
    • Try the version I have attached to this post and tell me if it works.
     

    Attached Files:

  9. Bluespheal

    Bluespheal GBAtemp Regular

    Member
    107
    28
    Sep 5, 2016
    Mexico
    Have you had luck booting Rosalina? mine just stays on a black screen and I have to shut it down...
     
  10. BlastedGuy9905
    OP

    BlastedGuy9905 Ace Bricker

    Member
    1,218
    725
    Apr 13, 2017
    United States
    Outside your windows ᕙ(◔ᗜ◔)ᕗ
    I just got the new one. Still, thanks.
    Go back to an older version of luma (7.1, whatever) and download b9s 1.2. Then, get luma 8.0 rosalina again, and it should be solved?
     
  11. Bluespheal

    Bluespheal GBAtemp Regular

    Member
    107
    28
    Sep 5, 2016
    Mexico
    Already done that, twice... any ideas?
     
  12. BlastedGuy9905
    OP

    BlastedGuy9905 Ace Bricker

    Member
    1,218
    725
    Apr 13, 2017
    United States
    Outside your windows ᕙ(◔ᗜ◔)ᕗ
    erm...
    do you have any payloads that launch automatically? delete them. they may be the older verison of the firms.
     
  13. MartinThibaultYo

    MartinThibaultYo Member

    Newcomer
    13
    2
    Mar 7, 2012
    France
    Hey! I don't know if it's related but I can't run several 3DSXs with Luma 8's new homebrew channel and I also get the exception error, not only on several boot payloads but also on Themely (CIA and 3DSX) when applying any theme and several other CIAs too (Luma Updater for example).
    So I was wondering if it is a known issue and if there is a solution ? Should I go back on the previous Luma and B9S versions to wait for a more stable Luma version or is it unrelated ? Especially since some Luma 8 new functions are useless to me (2DS).

    Thanks in advance if you take the time to answer ;) !
     
  14. BlastedGuy9905
    OP

    BlastedGuy9905 Ace Bricker

    Member
    1,218
    725
    Apr 13, 2017
    United States
    Outside your windows ᕙ(◔ᗜ◔)ᕗ
    Same...

    — Posts automatically merged - Please don't double post! —

    GodMode9 can be fixed, along with Decrypt9WIP. Just download the newest releases.
     
  15. MartinThibaultYo

    MartinThibaultYo Member

    Newcomer
    13
    2
    Mar 7, 2012
    France
    I already updated both, it just keeps showing an exception.. And frankly, Themely and the CIA apps are the ones really bothering me since I don't get why it shows the exception.
     
  16. BlastedGuy9905
    OP

    BlastedGuy9905 Ace Bricker

    Member
    1,218
    725
    Apr 13, 2017
    United States
    Outside your windows ᕙ(◔ᗜ◔)ᕗ
    Are you ABSOLUTELY SURE that you have the newest versions? Check the github pages, just in case :D
     
  17. MartinThibaultYo

    MartinThibaultYo Member

    Newcomer
    13
    2
    Mar 7, 2012
    France
    Yes, I am sure, GodMode9 from 5/31 and Decrypt9WIP from 5/20, aren't they the last ?
     
  18. BlastedGuy9905
    OP

    BlastedGuy9905 Ace Bricker

    Member
    1,218
    725
    Apr 13, 2017
    United States
    Outside your windows ᕙ(◔ᗜ◔)ᕗ
  19. MartinThibaultYo

    MartinThibaultYo Member

    Newcomer
    13
    2
    Mar 7, 2012
    France
    I was referring to the date in the title of the zip (GodMode9-20170531-232521) but yeah I meant the 1st of June release, I'm going to try the Decrypt9WIP release but here's the exception that shows up for the 20/5 release ;)
    Warning: Spoilers inside!
     
    Last edited by MartinThibaultYo, Jun 6, 2017
  20. BlastedGuy9905
    OP

    BlastedGuy9905 Ace Bricker

    Member
    1,218
    725
    Apr 13, 2017
    United States
    Outside your windows ᕙ(◔ᗜ◔)ᕗ
    You have a 2ds, too? A RED/WHITE ONE?!?!? That would be the same as mine :D
    Btw, don't ask me about error codes. I have NO clues.

    Edit: But yeah. When I'm getting an error, it's usually the ARM9 processor with the data abort error.
     
    Last edited by BlastedGuy9905, Jun 6, 2017