L4T Ubuntu Applcation Install guides.

Discussion in 'Switch - Tutorials' started by StarGazerTom, May 2, 2019.

  1. Centergaming

    Centergaming GBAtemp Advanced Fan

    Member
    6
    Apr 17, 2016
    United States
    I can't seem to get the mainline dolphin to work... always gives me a "Failed buffer" or smth for both Dolphin-Emu and Dolphin-Master... Mind explaining how you got it working, please? :/

    Edit: Nvm, just checked the Backend and changed it to OpenGL, apparently Vulkan is broken
     
    Last edited by Centergaming, May 24, 2019
  2. snoofly

    snoofly GBAtemp Advanced Fan

    Member
    8
    Aug 18, 2015
    United Kingdom
    I’ve been using flatpak to install a few apps with good success, Dolphin, Fuse and Vice stand-alone emus for ex. Moonlight and kodi should work too

    Recommend anyone to look into setting it. Just google ubuntu flatpak
     
  3. ZachyCatGames

    ZachyCatGames GBAtemp Addict

    Member
    9
    Jun 19, 2018
    United States
    Hell
    For Vulkan you need to enable fullscreen, it's weird
     
    Centergaming likes this.
  4. Centergaming

    Centergaming GBAtemp Advanced Fan

    Member
    6
    Apr 17, 2016
    United States
    Oh, huh... yeah, thats weird, thanks
     
  5. tansoftware

    tansoftware Member

    Newcomer
    2
    Apr 15, 2019
    Canada
    How did you get flatpak to work ?

    I thought flatpak needs squashfs to work. Squashfs is still broken in Ubuntu L4T. @bylaws even confirmed that it was still a work in progress at this point.

    It would be great if you could explain how you got flatpak to work.

    Thanks.
     
  6. snoofly

    snoofly GBAtemp Advanced Fan

    Member
    8
    Aug 18, 2015
    United Kingdom
    I had no issues, just followed these steps
    https://flatpak.org/setup/Ubuntu/
    using the ppa option.
    Re usage, I think some small niggle came and found advice for step3 to ensure the repo was deleted and then not to use the if-no-exists
    but really had no problems with it at all aside from flatpakref files not seeming to be recognised so i always use the command line install
     
  7. MushCow

    MushCow Newbie

    Newcomer
    1
    May 7, 2019
    Germany
    A little tutorial for Microsoft Office Online.
    Microsoft Office Online shortcuts

    Source: sites.google /site/linuxwebapps/microsoft-online-apps (offline)
     

    Attached Files:

    Last edited by MushCow, May 25, 2019
    Carlos_DobleC likes this.
  8. Neo_

    Neo_ Advanced Member

    Newcomer
    2
    Jan 28, 2017
    I installed Desmume!
    sudo apt install desmume
    Although It is a bit slow. Tried Pokémon White and Super Mario 64, they don't work full speed. SM64 is playable, but PW is too slow. Maybe there is a build of Desmume that works better for L4T?
     
    mattyxarope likes this.
  9. Hamdan

    Hamdan GBAtemp Regular

    Member
    4
    Dec 14, 2018
    Pakistan
    I mean like in consoles, where you can select keys by pushing joystick in certain directions. I know it's specific but i find reaching my fingers onto the keyboard both difficult and finicky
     
  10. monokin1114

    monokin1114 Member

    Newcomer
    2
    Apr 21, 2019
    Canada
    If you have the joycon setup as a mouse you can use thet instead of the touch screen. But it isnt ideal I have found
     
  11. Refriger8tor

    Refriger8tor GBAtemp Regular

    Member
    4
    Sep 2, 2013
    United States
    A kitchen near you.
    So joycons work for me as a mouse and in dolphin, and I was able to get them set up to control the menu in Retroarch, but they don't seem to work in-game? I have it all mapped out under User 1 in the menu.
     
  12. Drban789

    Drban789 GBAtemp Regular

    Member
    3
    Jun 28, 2018
    United Kingdom
    Hello why is there an installation for 1.7ghz overclock? Isnt l4t ubuntu 1.2 patch already use 1.7ghz?
     
  13. ZachyCatGames

    ZachyCatGames GBAtemp Addict

    Member
    9
    Jun 19, 2018
    United States
    Hell
    The command forces it to run at the highest speed possible (which is either 1.7ghz or 2ghz depending on your settings). By default it adjusts its speed based on CPU load
     
  14. MrSaturn

    MrSaturn Member

    Newcomer
    1
    May 29, 2019
    United States
    When I launch retroarch I just get a black screen with an _occasional_ yellow blur - should I reinstall? I thought Retroarch had some sort of UI now but I haven't used it since like 2014
     
  15. Drban789

    Drban789 GBAtemp Regular

    Member
    3
    Jun 28, 2018
    United Kingdom
    hello ive tried everything to install retroarch im about to get a hammer and smash my switch. Ubuntu is like a stubborn child who wont stfu when he needs to do as his told.
    !Anyways i followed the guide how to install. The packages the program the update commands etc.
    Once i actually to open it a pixelated yellow weird looking huge logo areas and then retoarch goes blanks.
    How am i the only one experiencing this lol. need assitance
     
  16. pietempgba

    pietempgba GBAtemp Advanced Fan

    Member
    5
    Jun 9, 2016
    United States
    you're not the onlyone with the issue
     
  17. Neo_

    Neo_ Advanced Member

    Newcomer
    2
    Jan 28, 2017
    How do I activate Vulkan graphics in Dolphin? I know you have to go fullscreen but I can only select OpenGL or software renderer and fullscreen changes nothing.
     
  18. dixeflatline

    dixeflatline Member

    Newcomer
    2
    Dec 16, 2010
    United States
    Somewhere near you
    @Drban789 @MrSaturn @pietempgba Downgrade from RA 1.7.7 to 1.7.6, RA will work again.
     
    Last edited by dixeflatline, Jun 2, 2019
  19. MrSaturn

    MrSaturn Member

    Newcomer
    1
    May 29, 2019
    United States
    @dixeflatline tried it, no dice. I tried 1.7.6, but after installation it showed as 1.7.7 anyway? Then I tried the other available version on apt, 1.4.1, but it didn't work either.
     
  20. dixeflatline

    dixeflatline Member

    Newcomer
    2
    Dec 16, 2010
    United States
    Somewhere near you
    What i did to get working and @Refriger8tor was able to do what I did confirmed mupen64 was working.

    ##Creating RetroArch.list file with PPA from https://launchpad.net/~libretro/+archive/ubuntu/stable?field.series_filter=bionic
    echo "deb http://ppa.launchpad.net/libretro/stable/ubuntu bionic main
    deb-src http://ppa.launchpad.net/libretro/stable/ubuntu bionic main" | sudo tee /etc/apt/sources.list.d/RetroArch.list

    #Removing testing/PPA of RA
    sudo rm -f /etc/apt/sources.list.d/libretro-ubuntu-*

    #Backup retroarch.cfg
    cp ~/.config/retroarch/retroarch.cfg /tmp/retroarch.cfg.bak

    #Uninstall and remove RA
    sudo apt remove -y retroarch* libretro-*
    rm -rf ~/.config/retroarch

    #Install RA
    sudo apt-get update
    sudo apt-get -y install retroarch*
    sudo apt-get install --only-upgrade -y retroarch*

    #Install ALL cores
    sudo apt-get update
    sudo apt-get -y install libretro*
    sudo apt-get install --only-upgrade -y libretro*

    #Copy back original retroarch config
    cp /tmp/retroarch.cfg.bak ~/.config/retroarch/retroarch.cfg

    #Output RA Version
    retroarch --version

    #Lock package from upgrading once you confirmed on 1.7.6.
    sudo apt-mark hold retroarch*

    #unlock package once issues with newer RA builds work for upgrading past 1.7.6
    sudo apt-mark unhold retroarch*
     
    Last edited by dixeflatline, Jun 3, 2019
Quick Reply
Draft saved Draft deleted
Loading...