Jewel Quest Corrupted My SD Card? {please help}

Discussion in 'Wii - Emulation and Homebrew' started by Deftoner, Jun 3, 2014.

  1. Deftoner
    OP

    Deftoner Newbie

    Newcomer
    9
    2
    May 7, 2014
    United States
    hey all! so today I put the homebrew channel on my wii along with a few emulators, the WiiMap, Wii Physics - all was working great, until I started using the Homebrew Browser & I began to download "Jewel Quest" - it didnt finish downloading, it wouldnt finish so I canceled it. I went back to the homebrew channel and now "Jewel Quest" is sitting there and it wont let me delete it.. I noticed that after exiting the homebrew channel & going back, all of my apps are missing & I have to restart the wii to see them ... so I take the sd card out & put it into my computer, I thought I'd delete it manually - well it wouldn't let me delete Jewel Quest either, and I was unable to safely eject my sd card :hateit: now, my computer will not read my sd card.. I tried to scan it/repair it, & it just sits there..... I put the card back into my Wii .... I can still use my emulators, but I cannot open the Homebrew Browser.. it just locks up now. please help :( I was so excited...it worked so well..

    I have a PNY SD card (8 gigs)