ixtreme 1.6 is out

Discussion in 'Xbox 360 - Games & Content' started by shanefromoz, May 15, 2009.

  1. shanefromoz
    OP

    shanefromoz GBAtemp Advanced Fan

    Member
    947
    33
    Jun 18, 2007
    Hi Guys,

    Just letting you know.
    You can check 360mods.net and get all the info you need.

    Cheers
     


  2. FAST6191

    FAST6191 Techromancer

    pip Reporter
    22,915
    8,592
    Nov 21, 2005
    Damn and here I went and updated people to 1.51.
    To save others the hassle one NFO:
    Code:
    Team HyperX Presents IXtreme 1.6 firmware for Benq, Samsung and Liteon drives
    ------------------------------------------------------------------------------
    
    IXtreme fw for Benq, Samsung and Liteon drives!
    
    
    Features
    --------
    
    -Strict Wave 3 compliance! hybrid (modified disks) will not boot! 
    
    -Strict drive speed compliance - 12x only for game discs! 
    
    -Support for SS V2! 
    
    -Integrated 0800 for game dumping including SS v2! 
    
    -Full support for all known game exceptions! eg ddr etc! 
    
    -One shot boot mode! - allows a one off boot of gamedisc without -stealth/partition checks (will still use stealth), use activate.iso disk to activate each time! 
    
    -Support for easy drive key/version info cmd, same as liteon! 
    
    -Strict stealth/wave checking, one shot boot mode will boot wave(x)! 
    
    
    More Info
    ---------
    
    
    Strict Wave 3 compliance means wave 3 games will only boot if they have correct PFI/DMI/SS and timestamp for wave 3
    
    Strict drive speed compliance means games will only boot if drive is set for the initial speed of 12x, any modification of this make games fail to boot
    
    SS v2 suports multiple timing samples for challenges type 5 and 7 , stroing them in the SS. This is a pre-requiste for SS v3 which has support for the so called AP2.5 check. Since this has never been used or may never be used by MS we will adopt a wait and see approach and continue to monitor for its usage.
    
    With drive in Windows mode (Tray half open on powerup) 0800 mode is activated allowing easy dumping of game disc including SS v2. In this mode the drive is also able to output drive key, fw version and drive type by using a simple custom inquiry command.
    
    Game exceptions are integrated in the fw for games that do not comply with the strict wave checks but are legitimate. These are Dance Dance Revolution Universe, Stoked, Ping 17 disk, afro samurai
    
    One shot boot mode allows you to boot a Wave X or non stealth game by using the activate.iso disk as a flag. Just insert the activate disc and the next disc inserted will boot without any strict checks. This will still utilise full stealth if available. As soon as that disc is booted the flag is cleared, and you will have to re-insert the activate disk again to enable one shot boot. As always use with caution.
     
  3. Lakerfanalways

    Lakerfanalways GBAtemp Advanced Fan

    Member
    882
    10
    Feb 20, 2009
    United States
    I am not very familiar with the stuff posted that comes with 1.6..I currently have 1.5.1..is 1.6 really necessary, I just don't want any issues with any of the newer games that come out that might require it..I had someone flash my drive for me, so if necessary, I will have to go back and have him put in the update
     
  4. triassic911

    triassic911 Burst Mode

    Member
    2,743
    344
    May 9, 2007
    United States
    NYC, USA
    It looks like 1.6 isn't NECESSARY but it has some nice addons.
     
  5. Tanas

    Tanas GBAtemp Addict

    Member
    2,258
    25
    Aug 19, 2006
    I've just flashed my Lite-on with 1.6 now all my none working games work fine [​IMG]
     
  6. shanefromoz
    OP

    shanefromoz GBAtemp Advanced Fan

    Member
    947
    33
    Jun 18, 2007
    Hi,

    So im on 1.5 and i have discs that i have patched to work with wave 3.
    If i upgrade to 1.6 will that mean that these discs will no longer work?

    Cheers
     
  7. Moose13

    Moose13 GBAtemp Regular

    Member
    249
    15
    Sep 21, 2008
    United States
    New York
    Those patched discs will no longer work with 1.6
     
  8. blueskies

    blueskies GBAtemp Advanced Fan

    Member
    825
    0
    Nov 14, 2003
    United States
    Santa Barbara, CA
    damn, its days like this i miss my xbox. 1.6 AND Bionic Commando on the same day!
     
  9. Chanser

    Chanser :o

    Member
    1,648
    139
    Jun 27, 2006
    Monaco
    Beware there is a repack for lite-on firmware. Anyway flashed, been waiting for 1.6 since 1.5 not 1.51.
     
  10. Zerrix

    Zerrix GBAtemp Maniac

    Member
    1,144
    0
    Mar 11, 2008
    Gambia, The
    Earth
    I just updated from 1.51 to 1.6 and I like the 0800 Dumping mode! [​IMG]
    Now I can backup all my games! WooT !
     
  11. Rock Raiyu

    Rock Raiyu Clock Up

    Member
    5,066
    38
    Jul 14, 2007
    United States
    Walking the path of heaven
    I've been waiting for it for a while now. I'm upgrading from 1.5 to 1.6 as we speak.

    Finished updating. I was scared for a minute cause none of my backups or originals were working. But then I restarted the 360 and they work now.
     
  12. deathfisaro

    deathfisaro Narcistic Deathfisaro Fan

    Member
    2,053
    0
    Mar 16, 2007
    Canada
    Vancouver, BC
    Just want to confirm, the "patched" discs meaning patched to work on 1.5 or lower right?

    Because some wave 3 games I got came with stealth related files that I actually needed to embed before burning. Hopefully discs that run on 1.51 also run on 1.6.
     
  13. Lakerfanalways

    Lakerfanalways GBAtemp Advanced Fan

    Member
    882
    10
    Feb 20, 2009
    United States
    Yeah I'm not understanding this patched thing either. I am currently running 1.5.1..does this mean that if I want to upgrade to 1.6, that all of my burnt games will not work and I will have to burn them all over again or no
     
  14. moosh01

    moosh01 GBAtemp Fan

    Member
    306
    0
    Nov 9, 2008
    United States
    Patched means wave three games that were patched for 1.5 or below, to remove the wave three video partition!
     
  15. Rock Raiyu

    Rock Raiyu Clock Up

    Member
    5,066
    38
    Jul 14, 2007
    United States
    Walking the path of heaven
    It's not safe to do that is it? I thought that could possibly get you banned.
     
  16. Joe88

    Joe88 [λ]

    Member
    11,461
    2,647
    Jan 6, 2008
    United States
    NYC
    well nobody has gotten banned from it yet

    and people are still too lazy to update
    some people are still on 1.4...
     
  17. triassic911

    triassic911 Burst Mode

    Member
    2,743
    344
    May 9, 2007
    United States
    NYC, USA
    They'll work if you use the activate.iso disc. Hopefully you aren't playing these patched games online.
     
  18. Sportsmaniac1322

    Sportsmaniac1322 GBAtemp Maniac

    Member
    1,183
    0
    Jun 26, 2008
    United States
    Forman's Basement
    No Hitachi firmware? That's disappointing [​IMG]
     
  19. olliepop2000

    olliepop2000 GBAtemp Fan

    Member
    457
    0
    Apr 4, 2009
    North West UK
    Don't worry it will be out soon, say, in a couple of months
     
  20. Sportsmaniac1322

    Sportsmaniac1322 GBAtemp Maniac

    Member
    1,183
    0
    Jun 26, 2008
    United States
    Forman's Basement
    It doesn't bug me too much I guess. It's not a huge, essential upgrade, but I just wish that the Hitachi drive would be updated as much as the rest. I know the Hitachi is a lot harder, but it just kind of sucks.