It's been 2 years, do I need to update my CFW/Homebrew?

Discussion in '3DS - Homebrew Development and Emulators' started by roveer, Aug 13, 2019.

  1. roveer
    OP

    roveer Advanced Member

    Newcomer
    2
    Oct 1, 2012
    United States
    I hacked my 3ds a while back (looks like 12/22/2018) from the dates on the directories on my SD Card. As far as I can tell sighax is at 9.1-89cc6ed and says there is a 10.0.1 update. It also says Lumaupdater is at 2.3 and there is a 2.4 update available. I'm way out of the whole hacking thing and don't want to make any mistakes and brick the console. I'm going to install some new games.

    Do I need to upgrade any of the cfg/hacks before installing/running new games?

    If I should, is there a guide for doing that or can I just let the update programs do their thing? I see a guide called Updating B9S on 3ds.hacks.guide that does this:

    What You Need
    Should I be doing this update?

    My Nintendo FW is 11.9.0-42U and I don't want to update it.

    Thanks for your help.
     
  2. Quantumcat

    Quantumcat Dead and alive

    Moderator
    20
    GBAtemp Patron
    Quantumcat is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Nov 23, 2014
    Australia
    Canberra, Australia
    If you're on 11.9 then you don't need to update B9S. You can update Luma by just downloading the latest boot.firm and copying it over the one on your SD card. There's no danger in updating your firmware, and you won't be able to play online until you do. And it will annoy you with prompts to update as well. But your choice.
     
  3. roveer
    OP

    roveer Advanced Member

    Newcomer
    2
    Oct 1, 2012
    United States
    So it's save to install the latest 3ds firmware?

    If I do, all my games will still work?

    If I do, do I have to do the B9S update as well as the luma and signax?

    Sorry if I'm mistating, I've been out of this for a while.
     
  4. Quantumcat

    Quantumcat Dead and alive

    Moderator
    20
    GBAtemp Patron
    Quantumcat is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Nov 23, 2014
    Australia
    Canberra, Australia
    Everything will work. All you have to do is download the latest Luma boot.firm and paste it over the one on your SD card. Then you can do an update from System Settings.
     
  5. roveer
    OP

    roveer Advanced Member

    Newcomer
    2
    Oct 1, 2012
    United States
    Worked, and worked. Thanks so much for the help.
     
    Quantumcat likes this.
  6. Altomations

    Altomations Newbie

    Newcomer
    1
    Aug 5, 2019
    Belgium
    Dont fully update luma, i heard it was better to keep it at 9.1 or something.
    If you do update it fully you can use NTR CFW
     
Loading...