Is it possible to upgrade to 6.2 from 5.1 with 7.0 out?

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by Vidness, Feb 11, 2019.

  1. Vidness
    OP

    Vidness Newbie

    Newcomer
    2
    Mar 15, 2009
    United States
    Son upgraded me to 7. My backup was old and brought me back at 5.1. 6.2 is a requirement for certain games. What can I do in this scenario? I would be good if I could get to 6.2, but not sure how.
     
  2. noctis90210

    noctis90210 GBAtemp Advanced Fan

    Member
    4
    Dec 24, 2013
    Use choijudourNX
     
    Silent_Gunner and Vidness like this.
  3. Vidness
    OP

    Vidness Newbie

    Newcomer
    2
    Mar 15, 2009
    United States
    After further research after my post, this indeed seems to be the answer. Thanks!
     
    LeviDL likes this.
  4. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    9
    Nov 6, 2002
    Portugal
    Proud to be Portuguese 100%!
    I updated our Switch from 3.0.0 with 6.2.0 using ChoiNX. So I can downgrade back to 3.0.0 using ChoiNX if I want to. Well, a warm/coldboot are coming for 4.1.0 I think. A permanent CFW. :)
     
    Silent_Gunner and Vidness like this.
  5. Sumandora

    Sumandora GBAtemp Regular

    Member
    2
    Nov 13, 2018
    Germany
    ChoiDojour..... no other method
     
  6. Garou

    Garou GBAtemp Advanced Fan

    Member
    5
    Jan 13, 2015
    ChoiDujourNX
    just saying, because those are 2 different app and iirc ChoiDujour cannot be used to update to 6.2.0 (6.0 max I think)
     
  7. Sumandora

    Sumandora GBAtemp Regular

    Member
    2
    Nov 13, 2018
    Germany
    does work tried it on my EmuNAND was on 6.2 and downgraded to 6.1 so 6.0 isnt max
     
  8. Garou

    Garou GBAtemp Advanced Fan

    Member
    5
    Jan 13, 2015
    ah okay. because I remember reading somewhere that it doesn't work on 6.2
     
  9. Lacius

    Lacius GBAtemp Guru

    Member
    15
    May 11, 2008
    United States
    As has already been stated, use ChoiDujourNX to update to 6.2.0 or wait for CFW to support 7.0.0 in the coming days/weeks.

    This is true of some games and especially updates, but a lot of games that "technically" require 6.2.0 actually require something lower. If you're installing games using Tinfoil, you can ignore these fake system requirements by selecting the ignore option. You can use something like Switch Backup Manager to check what the actual system version requirement is by looking at the master key revision requirement for an NSP file.

    It's also possible to decrypt a game and re-encrypt it to require a lower master key revision (if you have the newer keys), but it's much easier to just update to 6.2.0.
     
    Last edited by Lacius, Feb 13, 2019 at 1:27 AM
    Vidness likes this.
  10. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    ChoiDujourNX is firmware-agnostic unless Nintendo rewrites firmware installations. ChoiDujour does not support firmware 6.2
     
  11. Sumandora

    Sumandora GBAtemp Regular

    Member
    2
    Nov 13, 2018
    Germany
    but it support 6.1 ^^
     
  12. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Yes but the original point was that it didn't support 6.2. I guess I should have just stated ChoiDujour supports a max firmware of 6.1 in the first place.
     
    Sumandora likes this.
  13. Silent_Gunner

    Silent_Gunner GBAtemp Regular

    Member
    3
    Feb 16, 2017
    United States
    Wait, are you for real?
     
  14. Garou

    Garou GBAtemp Advanced Fan

    Member
    5
    Jan 13, 2015
    which part?
    update to 6.2 and then downgrade is already possible using ChoiNX
    warmboot on 4.1.0 is what dejavu supposed to do, but it hasn't been released since forever
    permanent CFW? I don't think it exists
     
  15. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    9
    Nov 6, 2002
    Portugal
    Proud to be Portuguese 100%!
    I talked with someone who was an expert. I am wrong. Sorry. According to him:

    Nice guy, thought. Anyway, there you have it. :)


    everything else is warmboot
     
Loading...