Homebrew Input User 1 Binds - lost Mapper input on update

dsearnack

Well-Known Member
OP
Newcomer
Joined
Nov 25, 2017
Messages
46
Trophies
0
Age
37
XP
99
Country
United States
Howdy all! Saw @guicrith mention in the nightly thread that she committed some major fixes... where can i see those commits? retroarch github?
Also are setting up the nightlies as easy as deleting the old folder, old cias, adding new and installing though fbi?

Yesterday I spent many hours trying to get Retroarch 1.7 to load after copying files over FTP. Coming from version 1.6.7 with Mapper showing as the 1st Input--- but no matter how i tried to install or update my files I could not retain the mapper in 1.7

(this is how you set up the 3ds controller options to be keyboard presses, and turns the C stick to a mouse)

I updated the cia for dosbox and retroarch, as well as transferring over the retroarch folder. After I open dosbox or retroarch cia and check the following options, some where missing or different (ie mapper input type was unknown)
in 1.6.7 under
Quick Menu and then Options I see:
Create Game Options File
Machine Type
Gamepad Emulated Mouse
CPU cycles...
CPU cycles...
CPU cycles...
CPU cycles...
Retropad Y
Retropad X
Retropad B
Retropad A
Quick Menu then CONTROLS
User 1 Device Type shows Mapper ---- after I first installed 1.7 this went to Unknown and the above menu for OPTIONS was only showing CPU
cycles...
I tried running 1.7 cias (dosbox and retroarch) with the 1.6.7 retroarch.cfg and retroarch-core-options.cfg files but they still load with UNKNOWN mapper... also changing this (other options are gamepad keybaord mouse) then makes it so you can not select the "unknown" input. I also tried running the 1.7 cias on the 1.6.7 retroarch folder files -- and running the 1.6.7 cias on the 1.7 folder

Also keeping the "unknown" input does not still give you the same control, IE buttons for mapper are never mapped though to the console

So I believe it is somewhere in the builds... Ive tested the nightlies with the same results. No Mapper input

what am i doing wrong? appreciate all the help!



Another bit of into that may help...I noticed a set of Retroarch settings had changed/ was missing in 1.7 when running dosbox.
Going into Main menu, Input... the Input Hotkey Binds was empty.. and Input user 1 binds... shows device types as retropad, gamepad, joystick, no mapper... and all "buttons" that should be there with assigned variables are missing too

edit:
looking at the nightlies thread again i see i should be using 3dsx instead of cias... will report back

Switched to 3dsx files and same issue.... I can assume... this time I do get to see the error and have included the screen shot with the warnings about inputs being unknown lol
 

Attachments

  • 2034-12-27_12-45-59.948_bot.bmp
    225.1 KB · Views: 262
Last edited by dsearnack,

guicrith

Well-Known Member
Newcomer
Joined
Apr 29, 2013
Messages
72
Trophies
0
Age
43
XP
628
Country
United States
Do you go to the main menu and select "Quit RetroArch"?
Thats when options are actually saved so if you change them and close retroarch with the home button before you do that you will lose all preference changes from that session.
 

dsearnack

Well-Known Member
OP
Newcomer
Joined
Nov 25, 2017
Messages
46
Trophies
0
Age
37
XP
99
Country
United States
Correct, First time I run it I open the dos box core, let it run, then quit, re-open and the symptoms are the same
re-install 1.6.7 and do the same, Mapper input is there -- are there any other cores that rely on the mapper input? I wouldn't mind testing another few cores in 1.7
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    M4x1mumReZ @ M4x1mumReZ: @BentlyMods, Priiloader and BootMii as boot2 and you're all set