I'm trying to build a make file but keep getting an error?

Discussion in 'Wii U - Hacking & Backup Loaders' started by Reecey, Dec 16, 2016.

  1. Reecey
    OP

    Reecey Mario 64 (favorite game of all time)

    Member
    4,339
    1,121
    Mar 7, 2010
    At Home :)
    Hi, I am trying to build a make file cbhc.elf but I keep getting this error at the end:

    linking.... cbhc.elf
    c:/devkitpro/devkitppc/ ../lib/gcc/powerpc-eabi/6.2.0/ ../ ../ ../ ../powerpc-eab
    i/bin/ld.exe: cannot find -liosuhax
    collect2.exe: error: ld returned 1 ext status
    make [1]: *** [/c/wiiu_folder/haxchi-2.3u1_v1.3/installer/ cbhc.elf] Error 1
    make: *** [build] Error 2

    Press any key to continue . . .

    I have re-installed devkitPro and the 1.6.0 update fully, I have put dimoks full libiosuhax_master/source in devkitPro/portlibs, I have put fix94's armips.exe in the devkitPro/msys/bin folder, I have got everything in my environment variables setup. I have also put the libiosuhax files in haxchi-master/installer/src.. I think I have just about done everything I know off, it zips the roms up fine in installer/data but this error keeps popping up at the end of the make for cbhc.elf. I was wandering if anyone else had this error and had solved it! Thanks any help will be appreciated. The strange part is, all the rest of the master folders make a file without issues, this is the only master folder I am having difficulties with.

    Please no flaming, I just want some help that's all so if your here to flame don't bother!
     
    Last edited by Reecey, Dec 16, 2016
  2. Voxel

    Voxel Fable Junkie

    Member
    GBAtemp Patron
    Voxel is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,195
    5,884
    Jun 27, 2015
    United Kingdom
    England, UK
    Looks like you need to compile libiosuhax first. (Or just cut out the middleman and get the precompiled version here)

    place the "include" and "lib" folders into the 'powerpc-eabi' folder (should be located at C:\devkitpro\devkitPPC\powerpc-eabi\) and try to compile again. the source should now be able to compile and add libiosuhax.
     
    Reecey likes this.
  3. Reecey
    OP

    Reecey Mario 64 (favorite game of all time)

    Member
    4,339
    1,121
    Mar 7, 2010
    At Home :)
    Your a super star, it worked first time! :) That's what I must of been missing. It does get confussing with these libiosuhax folders there are so many different ones out there.

    — Posts automatically merged - Please don't double post! —

    You can shut thread now mods. Thanks @Voxel you saved me a lot of hair.
     
    Voxel likes this.
  4. kajeinarsson

    kajeinarsson Member

    Newcomer
    24
    2
    Dec 10, 2016
    trying to compile getting error:

    make[1]: Leaving directory `/c/my_folder/iosuhax-master/dsrom/CBHC'
    zip -JXjq9 ../installer/data/animalcrossing.zip animalcrossing.nds
    make: zip: Command not found
    make: *** [animalcrossing.zip] Error 127