I really need help >>>Noob Lost<<<

Discussion in '3DS - Flashcards & Custom Firmwares' started by destructor1, Feb 14, 2016.

  1. destructor1
    OP

    destructor1 Advanced Member

    Newcomer
    59
    5
    Feb 13, 2016
    Gambia, The
    Hi All,

    where do i have to post to find help sorting things out to install rxtools and reinand and stuff.
    I´ve manged to succesfully downgrade from 10.3 to 9.2 on my N3ds XL, followed this https://gbatemp.net/threads/tutoria...luding-emunand-coldboot-cia-installer.405589/ and a couple of other tut´s but it just won´t work out. I have totaly no more clue as i was following a shitload of threats and tuts and things to get things up and running.
    I´ve allready unlinked Nands (i think) and can start into sysNand and emuNand But from here i am lost. I wanna install a couple of cia´s and here is where the hassle begins. I need to start rxtools in order to create the xorpad files, but rxtools won´t load. and further more trying to start reinand it gives me the Couldn´t load ARM9 payload error. I tried to start things from what i recall should be ctr bootmanager. trying to boot in pasta throws me into sysnand, this is correct so far i´m pretty sure though.
    When rxtools fails it either gives me a black or red screen and the n3dsxl needs to be shut off pressing power for a couple of secs.
    I´ve really read a ton of stuff about this and i´m working in this for about 2 days now but i cant get it to work.

    I could install three cia´s though before, but all the others won´t install FBI says signature wrong kinda thing.

    If anybody could prvide me with the correct tools, point me to the right direction, tell me where the mistakes are i am obviously doing please feel free to help me out as far as possible.

    Coldboot doesn´t work either...:( Using browserhax to start ctrbootmanager/HBL...

    If this is the wrong section i am sorry, couldn´t find somewhere else to ask for help.

    Thanks in advance

    BR

    Destructor
     
    Last edited by destructor1, Feb 14, 2016


  2. destructor1
    OP

    destructor1 Advanced Member

    Newcomer
    59
    5
    Feb 13, 2016
    Gambia, The
    No one ??
     
  3. A_Random_Guy

    A_Random_Guy Officially That Dev

    Member
    862
    459
    May 22, 2015
    Malaysia
    Smea's closet
    When downgrading, do you receive any errors or something during the downgrading process?
     
  4. destructor1
    OP

    destructor1 Advanced Member

    Newcomer
    59
    5
    Feb 13, 2016
    Gambia, The
    Downgrade went fine without any probs. U think something went wrong during Downgrade?
     
  5. mashers

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    Please post the exact error messages you get when installing CIAs and attempting cold boot. Just saying that it doesn't work or gives 'an error' isn't enough to go on to try and solve the problem.
     
    wormdood likes this.
  6. destructor1
    OP

    destructor1 Advanced Member

    Newcomer
    59
    5
    Feb 13, 2016
    Gambia, The
    ok, true, sorry.
    coldboot just does not work, meaning pressing L does not trigger anything, just starts in emunand like nothing would have been pressed. Pressing select or any other button gives the same thing, no result (maybe launcher.dat wrong?)

    Installing cia´s in emunand gives me
    Source: SOURCE_FSFILE_WRITE (0X1C)
    Module: MODULE_NN_AM (0X20)
    Level: LEVEL_Permanent (0x1b)
    Summary: Invalid argument (0x7)
    Description: Invalid signature (0x6a)
     
  7. funnystory

    funnystory Banned

    Banned
    1,472
    479
    Sep 20, 2008
    United States
    You have to set coldboot up in the settings of your themehax installer.
     
  8. mashers

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    Did you set up the launch button in menuhax manager? Which trigger type did you select?

    Does this happen with all CIAs? Which CFW are you using? What emunand system version? What region is your console and what region is the CIA? Have you tried re-downloading the CIA? Also consider trying another SD card if possible (will mean setting up emunand again, but sometimes a bad SD card can cause this error I think).
     
  9. destructor1
    OP

    destructor1 Advanced Member

    Newcomer
    59
    5
    Feb 13, 2016
    Gambia, The
    Wow, rereading my stuff i see that i REALLY did not not provide much Information - My bad - Sorry for that.
    So let´s start over:

    It´s a new 3DSXL running on 9.2 in Emunand i guess. How do i figure out what sysnand i am using ? CFW is cakes.
    Region is EU, the cia´s are mostly US, except for Mariokart 7 and new SMB2 which was EU. Luigi´s Mansion was US as well, but i could install it but it was not shown in Homemenu, MK7 and NSMB2 did, which is because of region i suppose.
    But i can´t install for example Bigbluemenu.cia, SaveDatafiler.cia,Playcoinsetter.cia.... and any others
    I will try to use another SD card as soon as i get one.

    Do you think setting up everything from scratch might help, if i do so, would this mean to link Nands again? And if so, how do i do this? How can i "roll bakc" changes i made ?

    Trigger was set to L in Menuhax in Emunand, but somewhere i read in emunand it´s not recomended to use it in emunand, so i deinstalled it.

    checking Version in Sysnand under Settings it shows 9.2 as well if i am correct.

    ok, just tried the following:

    booted the ds, triggered browserhax, startet ctrbootmgr went to more>fileexplorer startet rxtools.3dsx. rxtools won´t start but boots the ds into sysnand.
    is this correct ? Don´t think it is.
     
    Last edited by destructor1, Feb 15, 2016
  10. pre10c

    pre10c GBAtemp Fan

    Member
    300
    41
    Jan 15, 2016
    Belgium
    i think you re in sysnand instead of emunand, you can find out by opening settings and check what firmware you are running to find out what nand is booted. the signature fails are because your booted nand is not region free patched. if its sysnand setup menuhax to boot into emunand, if its emunand you need freemultipatcher to make it regiofree.

    once everything works i suggest setting different themes on sysnand and emunand so you know what nand is booted
     
    Last edited by pre10c, Feb 15, 2016
  11. destructor1
    OP

    destructor1 Advanced Member

    Newcomer
    59
    5
    Feb 13, 2016
    Gambia, The
    ok, question on that:
    if in sysnand - entering Settings and exiting settings will trigger DS to reboot, correct ?
     
  12. pre10c

    pre10c GBAtemp Fan

    Member
    300
    41
    Jan 15, 2016
    Belgium
    that's correct
     
  13. destructor1
    OP

    destructor1 Advanced Member

    Newcomer
    59
    5
    Feb 13, 2016
    Gambia, The
    ok, then i´m defenitly in emunand when booting up.
    And both are in 9.2
     
  14. mashers

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    Ok, just a few thoughts:

    1. Setting up menuhax on sysnand is strongly recommended as this will cold boot into emunand once configured correctly. Don't install menuhax in emunand as you'll get stuck in a loop
    2. It might be failing to install the CIAs because your emunand is on 9.2. Or since this is a downgraded system, you might have had a partial downgrade which is causing problems installing CIAs. Either way you should update your emunand to 10.5. First verify that you are definitely in emunand, then enter system settings and update to 10.5. DO NOT DO THIS ON SYSNAND.
    3. Install the FBI CIA onto emunand rather than launching through HBL. I believe it is more reliable that way
    4. Install and run FreeMultiPatcher on emunand before attempting to install or run any out of region CIAs

    Give all that a try and if it doesn't work, try another SD card with a fresh emunand.

    — Posts automatically merged - Please don't double post! —

    Exiting system settings will also trigger a reboot if you are in emunand. The system rebooting when exiting system settings is NOT an indicator of which nand you are in.
     
  15. pre10c

    pre10c GBAtemp Fan

    Member
    300
    41
    Jan 15, 2016
    Belgium
    the partial downgrade problem should'nt be a problem in emunand?? the error he posted few post back is the one if signature check failing wich means the nand he is in is region locked, wich either means he is sysnand or cakes/reinand who dont patch it on boot, but if i recall correctly he said he uses rxtools wich patches on boot.
     
  16. mashers

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    It is if the emunand was created from a sysnand with an incomplete downgrade, since the emunand starts off as a clone of sysnand.
     
  17. pre10c

    pre10c GBAtemp Fan

    Member
    300
    41
    Jan 15, 2016
    Belgium
    oh yeah true that :P that's what you get when browsing gbatemp at work :P. but the partial downgrades usually had systemsettings or browser not working, wich the op doesnt suffer from so could it still be a partial downgrade?
     
  18. mashers

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    Well a partial downgrade means that one or more of the 9.2 CIAs did not install properly (or at all). The effect of that will depend which one was not installed, so will be unpredictable. However, there are lots of other reasons for these errors, some of which you have noted and some were in the numbered list I posted above.
     
  19. pre10c

    pre10c GBAtemp Fan

    Member
    300
    41
    Jan 15, 2016
    Belgium
    i guess using sysupdater again with the 9.2 files should fix the partial downgrade i guess?
     
  20. mashers

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    It might, but it would be easier just to update emunand to 10.5.