I Can't Get the Remote Touch server to work

Discussion in 'NDS - Emulation and Homebrew' started by Distorted Soul, Jun 21, 2009.

  1. Distorted Soul
    OP

    Newcomer Distorted Soul Member

    Joined:
    Mar 22, 2009
    Messages:
    14
    Country:
    United States
    1. I run the command prompt (like the README says).

    2. I type the path "C:\Documents and Settings\ROSS\Desktop\PC Remote Control\server\rtdsserver_multi-win.exe (port number here)" (like I (think) the README says)

    4. I hit enter (like the README says)

    5. The Command Prompt says "'C:\Documents' is not recognized as an internal or external command, operable program or batch file."

    I don't understand what I'm doing wrong. [​IMG]
     
  2. kobykaan

    Member kobykaan GBAtemp Addict

    Joined:
    Aug 27, 2007
    Messages:
    2,994
    Country:
    United Kingdom

    not tested it but could be the directory names are too long and have spaces!

    try putting the EXE just on your C: directory and run it from there eg c:\rtdsserver_multi-win.exe
     
  3. Distorted Soul
    OP

    Newcomer Distorted Soul Member

    Joined:
    Mar 22, 2009
    Messages:
    14
    Country:
    United States
    Oh, spaces? Thanks, I forgot about that. I tried it the way you said and it worked! Thank you very much. [​IMG]
     
  4. kobykaan

    Member kobykaan GBAtemp Addict

    Joined:
    Aug 27, 2007
    Messages:
    2,994
    Country:
    United Kingdom
    congrats [​IMG]

    not used remote touch as yet but know from experience that a lot of programs that use command lines etc don't like long directory listings or ones that have spaces in [​IMG]
     
  5. zerofalcon

    Member zerofalcon GBAtemp Advanced Fan

    Joined:
    Mar 14, 2009
    Messages:
    534
    Location:
    Somewhere close to my NES
    Country:
    Antarctica
    Easy way method:
    Create a .txt file open it and type rtdsserver_multi-win.exe 235 (or any port you choose) and save it.. rename .txt file to rtdsserver_multi-win.bat
    rtdsserver_multi-win.exe, cygwin1.dll and rtdsserver_multi-win.bat in the same folder.. double click on rtdsserver_multi-win.bat and enjoy. No more typing commands. Open the client on your nds card choose ip and port and thats all.
     
  6. Optimatum

    Newcomer Optimatum Member

    Joined:
    Jun 7, 2009
    Messages:
    22
    Country:
    Singapore
    Shouldn't it be "cd " and not just ""?
     
  7. Distorted Soul
    OP

    Newcomer Distorted Soul Member

    Joined:
    Mar 22, 2009
    Messages:
    14
    Country:
    United States
    Thanks, it worked! I've definitely got this under control.
     
  8. ShadowEO

    Member ShadowEO GBAtemp Regular

    Joined:
    Mar 31, 2009
    Messages:
    217
    Location:
    Ohio, USA
    Country:
    United States
    Sorry to bump but You had the command correct, just you should put quotes before and after the path like so

    "C:\Documents and Settings\Username\My Documents\rtdsserver.exe" (port), The command line argument should be the only thing outside the quote. It has nothing to do with how many characters or spaces there are in it. Just for future reference.
     

Share This Page