Homebrew I cannot launch Homebrew

NorthWestWind

Member
OP
Newcomer
Joined
Aug 19, 2020
Messages
6
Trophies
0
Age
22
XP
43
Country
Hong Kong
Recently, I bought a second-hand 3DS. The region is U. It was already hacked so I don't know what happened during hacking. The first thing I do when I went home is format the system. After formatting, I found that FBI is still on the system (I don't know if that is intended since the CFW doesn't go away either). I used L + Down + Select to check if it is using Luma3DS and it is. Then, I tried to install some CIAs, and it went pretty well. I also updated Luma3DS from v9.1 to v10.2

Since it was hacked, I tried to follow the Finalizing Setup part in 3ds.hacks.guide. There's no problem with installing CIAs since FBI is already installed. However, when I tried to open the Homebrew Launcher Wrapper, it told me "Luma3DS is not configured to launch Homebrew" or something like that with some instructions down below. I followed the instructions, and nothing happened. Then, I headed to "Download Play" and tried to do the "Switch hb. title to current app" thing, and then "Save settings". When I re-launch "Download Play", nothing happened. The normal "Download Play" just show up and I don't know what to do.

Also, this might not be related, but I used FBI to install FBI and the one come with the system cannot even update. Now I have 2 FBIs in my 3DS.

Edit: I went to the FBI I installed and deleted the title of the old FBI. Turns out it is the "Health and Safety Injection" thing.

Can someone help?
 
Last edited by NorthWestWind,

NorthWestWind

Member
OP
Newcomer
Joined
Aug 19, 2020
Messages
6
Trophies
0
Age
22
XP
43
Country
Hong Kong
OK I'm here to solve my own problem.

Since nobody replies, I went to the Nintendo Homebrew Discord and asked for help. Someone then sent me a config.bin and told me to replace the current one I have in my sd:/luma and I did that. Then, I opened Homebrew Launcher again and it just worked, like magic.

If you want the file, find me on Discord (NorthWestWind#1885) because I cannot post link or upload that file. If it doesn't work for you, don't blame me.
 
Joined
Jan 1, 2018
Messages
7,292
Trophies
0
XP
5,812
Country
United States
Rosalina menu injecting Homebrew Launcher to an arbitrary system or wrapper title.
***

Don't confuse GodMode9 Health & Safety ⇄ .CIA/.APP injection for Luma3DS injection. Not the same thing.
If you deleted H&S through FBI, try reinstalling it by doing,
  • System SettingsOther SettingsSystem Update
 

NorthWestWind

Member
OP
Newcomer
Joined
Aug 19, 2020
Messages
6
Trophies
0
Age
22
XP
43
Country
Hong Kong
I finally figured out what is causing me this problem.

Turns out Homebrew only not run when external FIRMs and modules are enabled in Luma3DS settings. Therefore, I went and checked the luma/sysmodules folder and I found a mysterious .cxi file. I deleted that and now everything works.
 
  • Like
Reactions: fmkid
General chit-chat
Help Users
  • No one is chatting at the moment.
    kenenthk @ kenenthk: If a bleach spill just get more bleach