I am a total asswipe please help

Discussion in 'Wii - Hacking' started by PrestonThomas, May 3, 2014.

  1. PrestonThomas
    OP

    PrestonThomas Member

    Newcomer
    22
    1
    Nov 25, 2011
    So my Wii was working great I could load Wii and Cube backups. I thought there might be updates for the softmod and such so i downloaded pimp my wii and proceded to install whatever failes it said i had to have.

    Sadly this has turned out into a nightmare.

    The homebrew channel is upside down. anything I run wont work or if it does and need the USB or Wii SD slot to load up anything it fails. The firmware version is 4.2 and I did try to update it to see if it could see any files it needed but it just says its up to date.

    Is there anything I can do to sort this mess out
     
  2. XDel

    XDel Author of the Alien Breed Odamex Projekt.

    Member
    1,407
    413
    Jul 25, 2012
    United States
    Solaris
    First things first, re-install Homebrew channel, that should make it right side up if I recall correctly.
     
  3. PrestonThomas
    OP

    PrestonThomas Member

    Newcomer
    22
    1
    Nov 25, 2011
    I just found out that even orginal Discs wont load up :( .... I see the little title screen on the wii menu I click on start and I get a black screen :(
     
  4. PrestonThomas
    OP

    PrestonThomas Member

    Newcomer
    22
    1
    Nov 25, 2011
    ok i got it to boot the batman disc (I used this to do the homebrew channel at first) the it says the files are not on the SD card but they are.
     
  5. PrestonThomas
    OP

    PrestonThomas Member

    Newcomer
    22
    1
    Nov 25, 2011
    Ok got to the warning screen of the homebrew installing app and once I press 1 it hangs
     
  6. air2004

    air2004 Air

    Member
    1,610
    439
    Oct 24, 2008
    United States
    Anytown
  7. brausm08

    brausm08 GBAtemp Advanced Fan

    Member
    721
    17
    Nov 15, 2009
    United States
    USA - Midwest
    HBC is upside down because the IOS it is running on is not clean...reinstall that IOS and HBC will right itself.
     
  8. PrestonThomas
    OP

    PrestonThomas Member

    Newcomer
    22
    1
    Nov 25, 2011
  9. brausm08

    brausm08 GBAtemp Advanced Fan

    Member
    721
    17
    Nov 15, 2009
    United States
    USA - Midwest
    you'll have to use bathaxx (or bannerbomb) to launch MMM so you can install a clean IOS58...then reinstall HBC.

    EDIT: there's actually a feature in Modmii specifically for your new situation... 'H' from the home screen should get you to where you need to go.
     
  10. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,042
    8,560
    Oct 27, 2002
    France
    Engine room, learning
    You don't need to reinstall HBC, you need to reinstall IOS58.
    use IOS58 installer.

    If the HBC is still upside-down after that, press home button and look which IOS it's using. if it's not IOS58, you will have to reinstall HBC after installing IOS58.
    It will now works fine as you installed a clean IOS for the installer.


    After that, you will probably have to fix other IOS (which Pump my wii probably patched without reasons!), and installed old cIOS instead of latest.
    the best way is to do it manually, or use modmii to generate files and a personal guide for your situation.

    Let us know when you fixed your HBC. We will guide you from there.


    As a general rule: Don't try to fix what's not broken :)
    If you don't need to update, don't.
    If you find something which require an update, then look how to do it correctly, don't use outdated tools or tutorials thinking it's still good. Things change quickly and guides are not always updated.
     
  11. PrestonThomas
    OP

    PrestonThomas Member

    Newcomer
    22
    1
    Nov 25, 2011
    Thanks everyone for your help. Once I got the Ios58 installed I could get my homebrew channel back to normal and then following the softmod guide that fixed all the problems. I can now play Wii and Cube backups.

    I wont be using that pimpmywii anymore thats for sure.

    1 thing I have to ask is when I was doing the NAND backup there was 2 bad blocks. Do I have to worry about that ?
     
  12. brausm08

    brausm08 GBAtemp Advanced Fan

    Member
    721
    17
    Nov 15, 2009
    United States
    USA - Midwest
    no worry on bad blocks.... bad blocks usually originate during the manufacturing of the NAND chip. most wii's have a few (mine has 2).... i've seen wii NANDs with more than a dozen! ....and a couple wiis with zero.
     
  13. PrestonThomas
    OP

    PrestonThomas Member

    Newcomer
    22
    1
    Nov 25, 2011
    Well i have to repeat myself in saying thank you to all that have helped me. I dont think I could have sorted that one out. :bow:
     
  14. air2004

    air2004 Air

    Member
    1,610
    439
    Oct 24, 2008
    United States
    Anytown
    I have zero