How to stop update nag on 3DS with Gateway 3DS and Decrypt9

Discussion in '3DS - Flashcards & Custom Firmwares' started by ceanth, Sep 2, 2016.

  1. ceanth
    OP

    ceanth Advanced Member

    Newcomer
    51
    0
    Sep 26, 2005
    Hi all,

    I have a 3DS which is on FW 4.3 and I am running Gateway 3DS. I have a CIA game which I want to play but I have not had much experience with CIA games.

    From what I have read, I can see that I need to use BigBlueMenu to install the CIA game which EMUNAND which will then have its own place on my 3DS, this I am ok with however I wanted to stop my 3DS from producing the update nag in EMUNAND as I intend to play the CIA game online.

    I found the following page which outlines a method to stop this from happening:

    https://gbatemp.net/threads/poc-removing-update-nag-on-emunand.399460/page-3

    On that page it suggests to use Decrypt9 to dump the import.db file and then inject import.db.

    The issue I am having is that I do not know how to load Decrypt9 on my 3DS using Gateway!

    The question is:

    1. Is there a better way to stop the update nag?

    2. How can I load Decrypt9 on my 3DS using Gateway?


    Thanks,
     
  2. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,562
    1,699
    Feb 13, 2015
    Italy
    Imola
    You're most likely confusing the "update nag" (daily reminder to update) with the fact online has been blocked to outdated OS versions:

    1- The very purpose of an emunand is to be updated independently of the sysnand, so (after updating your gateway's launcher.dat) you should be able to update your emunand too

    2- Consider following Plailect's guide to install arm9loaderhax, which (with some divergences from the actual guide, as Gateway users would not want to boot Luma but a boot manager, and they also need to keep emunand instead of deleting it) will give you a more convenient and faster way to boot your system, while also allowing you to conveniently run arm9 homebrew, and decent brick immunity!
    On the other hand, if you don't need your Gateway anymore and are fine with using cias only, feel free to follow said guide literally and be welcome to the world of free CFW!
     
    hobbledehoy899 likes this.
  3. ceanth
    OP

    ceanth Advanced Member

    Newcomer
    51
    0
    Sep 26, 2005
    Hi Ryccardo,

    Thank you for the reply!

    Am I right in assuming that update nag is due to the 3DS having downloaded a new firmware? In order to play online do you have to have the latest firmware, or can you remain on a lower firmware?

    Regarding updating EMUNAND, I am only concerned that the newer versions of the software may break the gateway card working on EMUNAND. I found it a little difficult knowing whether it was safe or not to update my EMUNAND so I decided to simply stop updating it in fear of breaking the gateway setup which I have.

    I am happy using gateway so I would like to keep it. The game in question was in CIA format hence the question but playing CIA isn't really the issue, the issue is about updating my EMUNAND.
     
  4. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,562
    1,699
    Feb 13, 2015
    Italy
    Imola
    Since 10.4 or something, Nintendo is actively blocking older versions from connecting.
    This is done by checking the version of the "friends" driver, but updating it separately isn't recommended.

    A very valid concern: however, the latest version of the Gateway software is well capable of running an 11.0 emunand, and when future system updates will be released... be sure that you will find an answer on these forums very quickly :)
     
  5. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,922
    1,434
    Nov 17, 2008
    United Kingdom
    Quantumcat likes this.
  6. Atro

    Atro Advanced Member

    Newcomer
    91
    32
    Aug 4, 2016
    United States
    He's not confusing the inability to use online features like the browser or friends list with the update nag. The update nag is a notification that appears when you startup your 3ds on a non-updated firmware. It means the update is downloaded and ready to install. You can normally just tap something like 'no' to get rid of it. It's more of an annoyance, really.

    Also, unless he chooses to get rid of emuNAND, switching to a9lh won't do anything to solve his issue.
     
  7. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,922
    1,434
    Nov 17, 2008
    United Kingdom
    I just dont get why you wouldnt update now the guide is so quick to use and GW works perfectly.

    Just my 2 cents.
     
  8. Atro

    Atro Advanced Member

    Newcomer
    91
    32
    Aug 4, 2016
    United States
    That's not really the point. a9lh is completely unrelated to the op's issue.
     
  9. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,562
    1,699
    Feb 13, 2015
    Italy
    Imola
    It is, considering A9LH is the best way to run arm9 software like Decrypt9 :)
     
    KiiWii likes this.
  10. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,922
    1,434
    Nov 17, 2008
    United Kingdom
    But, but, but: I have all of the above working, and no nag...... because I'm updated with Plailects guide and AL9H and Luma and gateway and payload and .... etc etc....
    Just my opinion. Maybe I'm not reading OP's issue right. Either way, I'm out of this one. :grog:
     
    Last edited by KiiWii, Sep 5, 2016 - Reason: grammar
  11. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,678
    752
    Aug 22, 2015
    United States
    Hell
    Outdated entrypoints and setups are bound to fail. It is better to setup the latest entrypoints now while you are still able to do it remotely safely.
     
    astronautlevel and KiiWii like this.
  12. Atro

    Atro Advanced Member

    Newcomer
    91
    32
    Aug 4, 2016
    United States
    Neither of those are the problem here.

    This issue would persist even without a hacked 3ds. It's just a simple nag regarding the system update.
    I use a9lh, Luma, and Gateway myself and I still get this issue. My sysNAND is not updated, and I don't plan on updating it. The difference is, it doesn't bother me so much that I'd need to take action to fix it.
    But it's not the only way, right? This occurrence happens even on non hacked 3dses, it can be solved without decrypt9, but by updating. Op is just reluctant to update, is all.

    To the op, if you're using the latest launcher.dat from Gateway, you can update your emuNAND to the latest. It supports 11.0. Just make sure to do it from the system settings.
     
  13. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,922
    1,434
    Nov 17, 2008
    United Kingdom
    See I went from 4.2 with emunand 10.x to just AL9H luma 6.1 with sys 11.0.0-33 no emunand.... yet.
     
  14. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,678
    752
    Aug 22, 2015
    United States
    Hell
    We are here to reduce problems, not add to them. Mset is a very outdated entrypoint, and 4.5 is an outdated sysnand to be running on. By moving away from mset, and going to a9lh, they will actually be able to use modern tools for the 3ds, which will save a lot of pain and hassle later down the road. Gateway is a basically dead cfw, which is controversial as fuck to be using as a primary cfw in 2016.
     
  15. Atro

    Atro Advanced Member

    Newcomer
    91
    32
    Aug 4, 2016
    United States
    Yes, I can very clearly see that. I, on the other hand, as well as the OP, have emuNAND.
    Okay, let me ask you this then. Luma3DS, as good as it is now, with little bugs and pretty good usability, as well as A9LH, let's say something better than both of those comes onto the scene. Will you tell people they shouldn't use what they are because something better is out? THE arm9loaderhax, with 100% bootrate, brick protection and pretty great stability. This entry point, that's revolutionized the scene, would you want to tell people that it's deprecated and that they shouldn't use it because it's old?

    Honestly, I get that MSET is old. I get that there are better alternatives, but it's not horrible just because it's old. If we were arguing the usage of Palantine here, there'd be a good reason to upgrade because it had like a 10% bootrate. MSET with Gateway works at a pretty good rate. If op were looking to update to something better because his current method bothered him, I'd definitely want to join the people who tell him to use Plailect's guide and upgrade to a9lh, but simply telling him to do so and ignoring his problem is not the right way to approach things. I'm trying to help others with their core issues, not peer pressure them into doing something they don't want to do. If a9lh directly solved the OP's problem, I'd have no qualms with responses regarding it.

    tl;dr: updating to newer things is not always the solution to a problem.

    EDIT: and gateway still gets updates. it's not dead until its developers jump ship and stop pushing the product.
     
    Last edited by Atro, Sep 5, 2016
    Ryccardo and retrofan_k like this.
  16. retrofan_k

    retrofan_k GBAtemp Advanced Maniac

    Member
    1,818
    1,114
    May 31, 2013
    Belarus
    Caves
    Updating to newer methods does not always fix issues, which is true, yet there are instances were it is needed and best to keep up with the times. If the OP chooses the a9lh route, it would fix his issue with D9 and still be able to use GW without any pissing about.

    People have opinions and i agree with the A9lh, if not stay as you are, if the needs dont suit.
     
    ihaveamac and KiiWii like this.
  17. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,678
    752
    Aug 22, 2015
    United States
    Hell
    We cannot get a better entrypoint than a9lh without having bootroms, and even if we get bootroms, we don't know if there is an exploitable bug in it. One of their questions was "How can I use decrypt9 with gateway?" The answer is that it is complicated to do, and you have to temporarily lose gateway access or use the browser. These methods are both outdated, and I'm pretty sure there is a bug in decrypt9 right now that breaks older entrypoints (it may just be the 3dsx version, idr).

    The next issue is why we tell people to upgrade. The answer is that it is hard to give support to outdated stuff. No one on this site wants to put up with trying to figure out your errors because you are using mset, or some other 2 year old exploit. Everyone will be much happier when you use something which people understand. (If you want a crappy example: Contact tech support for some free software and tell them that you are using some ancient stable build of their program (we are going to go with chrome for this). You found a bug with syncing bookmarks, they are going to tell you to update before doing anything else (and probably laugh at you when you cannot hear them).)

    Lastly, you are offering a temporary solution. Yeah mset works, and will probably work forever, but the entire community is moving away from it. People aren't even looking at 4.x anymore outside of a safe firmware to upgrade to for injecting ctrnand backups.
     
  18. Atro

    Atro Advanced Member

    Newcomer
    91
    32
    Aug 4, 2016
    United States
    It's a "what if" situation. The point of the question isn't whether or not it'll happen, it's what would you do IF it were to happen.

    Yes, people are moving away from 4.x, that is clear to see, but are you forgetting that the op's issue is not relative to using mset in the first place? The point of my previous tirade was to make it clear that updating to a9lh won't solve the person's problem. It's an issue that persists even without custom firmwares. It's a simple thing to fix, and it'd only not work if there was no support for the latest update on emuNAND.

    Another point I was trying to make is that the op actually WANTS to continue using mset. I wouldn't condone peer pressuring someone into doing what they don't want to, only to offer a solution that wouldn't fix the given problem in the first place. Although I do agree, it'd make things easier.

    I, for example in the past got tired of using mset, so once menuhax came out, I brought myself to update to 9.2 and use that instead. Same case with a9lh, I was tired of menuhax failing, so I made the switch as soon as a9lh became somewhat feasible to install. It came with risks, but I did it. For OP, he actually likes what he's using, and what he's using works. What's the point of telling him to switch?

    I agree that a9lh is the way to go, and I understand that these things are outdated, but in the end it boils down to the problem at hand, and taking the op's interests into consideration.
     
  19. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,678
    752
    Aug 22, 2015
    United States
    Hell
    I read back through the thread, and the OP never once said they want to stick with mset directly. We aren't peer pressuring someone into converting to a9lh, only saying that it is there. OPs knowledge appears to be very outdated (bigbluemenu for example), they probably didn't know about a9lh until someone mentioned it here. Giving short term solutions will only lead to more questions and issues in the future, and they will still be told to switch to a9lh.
     
    Last edited by ih8ih8sn0w, Sep 5, 2016
  20. Quantumcat

    Quantumcat Dead and alive

    Member
    11,854
    6,369
    Nov 23, 2014
    Australia
    Canberra, Australia
    Just my two cents: the longer you spend with outdated methods, the fewer and fewer people there will be who remember them and who can help you troubleshoot issues. Eventually, no one will be able to help and if you wish to continue using outdated stuff you had better be an expert at it because you will have to fix your own problems.
    Meanwhile if you update, 99% of the community is available to help you troubleshoot problems and you'll get through any hiccup in five minutes. Not to mention, there is a reason for inventing these newer methods, there will be some sort of improvement that you can benefit from.