Help on updating Menu on DSTT

Discussion in 'DSTT' started by mlp, May 11, 2010.

  1. mlp
    OP

    mlp Newbie

    Newcomer
    8
    0
    May 11, 2010
    Hi there,

    I've had a read of a few threads and have a rough idea of what I need to do but can anyone give me a bit of advice/help please?

    I have a DSTT card (and 4GB Kingston memory card) and can't get the more recent releases to play on it. I have updated to the v1.17a12 software and also updated the latest latest extinfo/infolib/savlib files. ( I get errcode =-4 when loading Sonic And Sega All Stars Racing.

    Do I also need to update the menu software from here If so when running the r4.bat file it asks what kind of card I use and the options are R4/N5/M3 Simply - What do I select for the DSTT?

    Is there a guide for updating the menu with screenshots?

    Any help gratefully received.

    Thanks
    mlp
     
  2. lolzed

    lolzed The GBAtemp Pichu

    Member
    2,466
    13
    Sep 13, 2008
    There
    well if you read a bit more in THIS section,not R4,you'll see the TTYSauto in the first page [​IMG].
    Also you sure you got the latest infolib/extinfo/savlib Pong made(read stickies)?They got Racing fixed already/
     
  3. flamingo24

    flamingo24 GBAtemp Regular

    Member
    286
    0
    Mar 28, 2010
    If you have a DSTT you should stick with TTMenu and not YSMenu if compatibility is a concern, certain games run better using the updated files with TTMenu (i.e. Rooms - Fushigi na Ugoku Heya (J) YS = Freeze, SMT: STRANGE JOURNEY (U) YS = Save Problem, & the BAHAMUT dump of Ivy the Kiwi YS = Broken). These games work fine using TTMenu.
     
  4. lolzed

    lolzed The GBAtemp Pichu

    Member
    2,466
    13
    Sep 13, 2008
    There
    ok got mah facts wrong,thanks
     
  5. flamingo24

    flamingo24 GBAtemp Regular

    Member
    286
    0
    Mar 28, 2010
    No, Pong mentioned its a bug with YSMenu.
     
  6. mlp
    OP

    mlp Newbie

    Newcomer
    8
    0
    May 11, 2010
    Thanks for the replies so far guys.

    Ok I've kept the DSTT menu just now and updated to the files from this link http://filetrip.net/h25123605-TTDS-EXT-INFO-SAV.html

    If I try and load Sonic Classic Collection I get a blank white screen straight away.

    I also have a 90K file appearing now called TTiCheck_v2.1nds and when I open that I get a message saying Card version not supported
    Update this program from http://www.ndstt.com

    Any thoughts on where I'm going wrong here?
     
  7. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,933
    Sep 8, 2009
    One's inner self

    hmmmm

    well dude

    what card have you got (i aint going reading all your posts)

    please make sure you have TTDS 1.17.12a FAKE KILLER Removed (if your card is fake it will break if you use the one with fake killer)

    if you then add my files to the TTMenu folder you should be fine
    you must also make sure your sonic rom is drycpted
     
  8. retrogamefan

    retrogamefan GBAtemp Advanced Fan

    Member
    791
    163
    Oct 8, 2009
    Are you using the (E) version of Sonic Classic Collection? If so, you need to use eNDryptS Advanced 1.2 to decrypt the (E) dump to make it work.

    The TTiCheck is ONLY for a DSTTi, not a DSTT

    Cheers,
    retrogamefan
     
  9. mlp
    OP

    mlp Newbie

    Newcomer
    8
    0
    May 11, 2010
    I tried that (I assume the rom just needs to be in the same folder as the .exe file?) I hit option 1 to Decrypt then the dos screen disappeared but when I copy the rom back onto my memory card and try and load it I get the blank white screen again.

    Sorry to be a pain in the backside guys [​IMG]
     
  10. retrogamefan

    retrogamefan GBAtemp Advanced Fan

    Member
    791
    163
    Oct 8, 2009
    yes, place the game into the same folder as the .exe

    does your screen look like this when you use endrypts advanced 1.2 after you press 1?

    [​IMG]
     
  11. mlp
    OP

    mlp Newbie

    Newcomer
    8
    0
    May 11, 2010
    Thanks retrogamefan

    No when I enter 1 the dos screen disappears straight away and I get another file (PatchEngine.tx1) appearing in the folder as below.

    [​IMG]
     
  12. retrogamefan

    retrogamefan GBAtemp Advanced Fan

    Member
    791
    163
    Oct 8, 2009
    You are missing 1 file : PatchEngine.dat 797kb. Is that in the archive you downloaded? There should be 3 files.
    [​IMG]
     
  13. mlp
    OP

    mlp Newbie

    Newcomer
    8
    0
    May 11, 2010
  14. retrogamefan

    retrogamefan GBAtemp Advanced Fan

    Member
    791
    163
    Oct 8, 2009
    It is the TTMenu.dat file you are using which is causing the errcode=-5 [​IMG] (just tested that file myself with the same result). Do you know if you have a real or fake DSTT?
     
  15. mlp
    OP

    mlp Newbie

    Newcomer
    8
    0
    May 11, 2010
    I think it's a fake, I got it from Deal Extreme a year ago - with hindsight I probably should have got another card or the real mccoy. All the older games still work fine though.

    Is there any card at the moment that would play all the newer games without the need to modify them? I've heard good reports about the CycloDS, it is a bit more expensive but probably better in the long run?
     
  16. retrogamefan

    retrogamefan GBAtemp Advanced Fan

    Member
    791
    163
    Oct 8, 2009
    I also got my DSTT from DealExtreme but that was nearly 2 years ago but I received a real DSTT, so you might (and I stress might) be lucky and have a real DSTT.

    I think your best option is either an Acekard 2i running AKAIO or the new Supercard DSTWO. Both will work if you end up upgrading your DS to a DSi or DSiXL
     
  17. mlp
    OP

    mlp Newbie

    Newcomer
    8
    0
    May 11, 2010
    Will both these play the recent games without any need to modify?

    Thanks for all your help.
     
  18. retrogamefan

    retrogamefan GBAtemp Advanced Fan

    Member
    791
    163
    Oct 8, 2009
    They should do. All you may need to do is a firmware update for them, to make the latest games playable. All flash cards need to be updated (files or firmware)at some stage.
     
  19. mlp
    OP

    mlp Newbie

    Newcomer
    8
    0
    May 11, 2010
    A very big thank you to retrogamefan for all his help via email, he's got me up and running now [​IMG] Very much appreciated