Help Creating Forwarder for UQM

Discussion in 'Wii - Emulation and Homebrew' started by DEFIANT, May 13, 2010.

May 13, 2010

Help Creating Forwarder for UQM by DEFIANT at 3:24 AM (1,204 Views / 0 Likes) 6 replies

  1. DEFIANT
    OP

    Member DEFIANT GBAtemp Fan

    Joined:
    Dec 9, 2008
    Messages:
    344
    Location:
    Gallifrey
    Country:
    United States
    I've tried creating a forwarder channel using customizemii. I'm using the static base wad. Have my banner and icon all showing up good on the wii(no brick). When I click on start, the screen gives me this green bar horizontally across my screen or gives me a code dump depending on the nand loader I choose(comex=green bar or waninkoko=code dump). All current ios's from the "ios newbie thread" here: http://gbatemp.net/t212497-best-cios-selection-for-newbies

    I'm at a loss on how to create a channel that forwards to SD:apps/uqm/boot.dol

    Here is the project home page: http://wiki.uqm.stack.nl/Wii_Port#Source

    I just can't seem to get it to load even using the forwarder option in customizemii.

    If some would like to help me, I can upload the game, banner, and icon I created so maybe thay can fiddle with it.
     
  2. DEFIANT
    OP

    Member DEFIANT GBAtemp Fan

    Joined:
    Dec 9, 2008
    Messages:
    344
    Location:
    Gallifrey
    Country:
    United States
    Here is the game and icons I'm trying to use.

    http://rapidshare.com/files/387070659/UQM.rar

    If any one out there could make me a forwarder for this game, I would be ever so grateful. I'm having zero luck making it work for this game myself.

    On the other hand, I've had great success with my own dosbox forwarder and multi mod manger forwarder.
     
  3. DEFIANT
    OP

    Member DEFIANT GBAtemp Fan

    Joined:
    Dec 9, 2008
    Messages:
    344
    Location:
    Gallifrey
    Country:
    United States
    Still trying to reach the developer for the source code.

    If I use SFCC.Executable.v1.0 and choose usb loader gx wad, I can actually get to the games splash screen but then the game freezes. GRRRR!

    I know this is a really obscure game and all and I'm sure I'm the only one who cares but I could really use some help or advice.

    EDIT: OK... I've been reading something about "entrypoint" and how memory gets overlaped. Could that be the reasion why I can't forward to the game? If thats the problem, how do I fix it?
     
  4. DEFIANT
    OP

    Member DEFIANT GBAtemp Fan

    Joined:
    Dec 9, 2008
    Messages:
    344
    Location:
    Gallifrey
    Country:
    United States
    Hard work + Perseverance = I fing got it to work...yeha!!

    This is how I did it.

    I used a homebrew app called "Universal Forwarder". Great little program by the way.

    I moved UQM boot.dol to sd:\forwarder\ and renamed UQM boot.dol to defualt.dol so this program loads by default with no button presses.

    Used cusomizemii to load "static wad" and forwarded Universal Forwarder's boot.dol file so that when I click on this channel, it starts UQM in sd:\forwarder\.

    It's a round about way, but what the hell, it works. I'm so stoked. Been at this every day for 5 days trying to figure this out.

    anyways...here it is my custom channel for UQM game. Enjoy, I put some time into for sure.
    http://rapidshare.com/files/387784143/The_...ters_-_TUQM.wad

    Now only if I could figure out how to add sound to my channel...don't suppose anyone could help me with that??

    EDIT: Easier setup.
     
  5. Krestent

    Member Krestent What to post?

    Joined:
    Mar 31, 2009
    Messages:
    3,952
    Country:
    United States
    Don't bump this topic every day. From the rules:
    To answer your question, try removing anything you have attached to your Wii remote.
     
  6. DEFIANT
    OP

    Member DEFIANT GBAtemp Fan

    Joined:
    Dec 9, 2008
    Messages:
    344
    Location:
    Gallifrey
    Country:
    United States
    No offense...

    Yes I know the bumping rule.

    If you read each and every post carefully, you would of seen that each post contained updated a new information. And second, I solved my problem in the last post making it more relevant that the others, so your offer of removing attachments is mute. And since THAT post is the only back to back in the same day that makes the board rule a grey area. Unless you just needed a reason to tell me how I'm breaking the rules, in that case I acknowledge that and will refrain from making similar posts in the future. Thank you.
     
  7. Krestent

    Member Krestent What to post?

    Joined:
    Mar 31, 2009
    Messages:
    3,952
    Country:
    United States
    After I quoted the rule, I gave you an answer. Also, for providing updates, there's an edit button which I know you know how to use, as you've used it.
     

Share This Page