HDD Issues preventing Windows 7 installation.

Discussion in 'Computer Hardware, Devices and Accessories' started by MrMcTiller, Oct 1, 2018.

  1. MrMcTiller
    OP

    MrMcTiller GBATemp's Tiller

    Member
    4
    Mar 7, 2017
    United States
    Iowa
    Hi,

    I recently started to work on an HP Elitebook 8530w. It had Windows 7 Professional on it, but for some reason one day, it didn't want to boot Windows. I tried to boot into the System Recovery, but after the little loading screen, it went to a black screen. Eventually, it showed the mouse cursor, but that is as far as it went. I created a Windows 7 Professional 64-bit disk and booted into the system recovery, but it didn't work. So, I decided to just try to reinstall Windows. I got to the Install Now screen, pressed "Install Now". I agreed to the terms and all of that stuff. Once I got to the screen where you pick a disk, I deleted the partitions and made new ones. I clicked continue and it gave me this error.

    "Windows could not format a partition on disk 0. The error occurred while preparing the partition selected for installation. Error code: 0x80070057"

    I tried again, but it gave me the same error.

    I used my GParted boot disk and booted into GParted. I deleted the partition and created a new Partition Table. (mdos)

    I tried to make a new NTFS partition, but it failed. It failed, and showed "unknown" as the partition. I deleted the "Unknown" partition and tried to make a FAT32 partition. FAT32 worked perfectly fine.

    I deleted the FAT32 partition and tested to see if other filesystems work.

    I tested the following:

    XFS: Success

    UDF: Success

    REISERFS: Success

    REISER4: Success

    NTFS: ERROR writing to /dev/sda1: Input/output error, ERROR writing non-resident attribute value. add_attr_sd failed: Input/output error, Couldn't create root directory: Input/output error

    NILFS2: Success

    LVM2 PV: Success

    EXT2: ERROR (Took too long, so I force canceled... but I am assuming it would have failed)

    EXT3: ERROR ext2fs_mkdir: Input/output error while creating root dir

    EXT4: ERROR mkfs.ext4: Input/output error while writing out and closing file system

    LINUX-SWAP: Success

    JFS: Success

    HFS+: Success

    HFS: Success

    FAT32: Success

    FAT16: Success

    F2FS: ERROR (See gparted_details_f2fs.txt for more info)

    BTRFS: Success
     

    Attached Files:

  2. gamefreak955

    gamefreak955 Member

    Newcomer
    1
    Oct 16, 2018
    Canada
    maybe try a low level format with dban. my guess is the disk has invalid sectors that the controller not error correcting
     
    MrMcTiller likes this.
  3. alexander1970

    alexander1970 GBAtemp Advanced Fan

    Member
    3
    Nov 8, 2018
    Austria
    Austria
    Hello.
    If the Problem is not solved til today:

    If it is an SSD HDD ( I think so: https://support.hp.com/at-de/document/c03289202 )

    and you´re able to remove it from your Laptop you can try to format it in an other PC.I had an case with an Toshiba and an Samsung SSD and that Error Code you´ve mentioned above,that couldn´t format the SSD in the original Pc/Laptop by the Windows 7 Installation.Then we´ve tried it in another PC that works for us.Its worth a try.:)

    Good luck.
     
    MrMcTiller likes this.
  4. MrMcTiller
    OP

    MrMcTiller GBATemp's Tiller

    Member
    4
    Mar 7, 2017
    United States
    Iowa
    I would try it, but I don't have another PC.
     
Loading...