Having trouble updating from 6.0 to 9.2 on my 2DS with sysUpdater

Discussion in '3DS - Flashcards & Custom Firmwares' started by Icarus, Oct 29, 2015.

  1. Icarus
    OP

    Icarus fire walk with me

    Member
    1,146
    10
    Feb 3, 2006
    United States
    Big Appleu
    Hey everyone, I'm very new to the scene (since yesterday really). I just got a used 2DS with 6.0 firmware and I went ahead and installed rxtools and did the whole emunand thing which works great. I wanted to use themehax which requires me to be on 9.2 so I installed FBI on sysnand then installed sysupdater. Everything is fine up to this point. I go into the devmode to update. I have my 9.2 full update files (bunch of cias) in the updates folder on the root of my sd card. But for some reason, sysupdater just can't detect them. I keep getting the same error:

    titleException:
    main.cpp:97: Result: 0xD8E08067
    Failed to get CIA file info!

    I'm out of ideas at this point, I've been trying to figure this out all day but no luck! I've been following this tutorial to a T and everything worked out fine except for this step and I can't find anything on Google on this. The files are definitely there, I even tried the modified version and a 9.0, all in the updates folder, but I keep getting the same error. I also tried deleting and installing sysUpdater many times, nothing worked. Any advice would be greatly appreciated!
     
  2. Tony_93

    Tony_93 GBAtemp Addict

    Member
    2,197
    1,004
    Jun 13, 2015
    United States
    California
    Are you sure you downloaded the cias for the old 3DS and not the ones for N3DS? Update packages are different, also check the region.
     
  3. Icarus
    OP

    Icarus fire walk with me

    Member
    1,146
    10
    Feb 3, 2006
    United States
    Big Appleu
    Definitely the old 3DS. Unless there are separate CIAs for 2DS that I've never seen.
     
  4. Icarus
    OP

    Icarus fire walk with me

    Member
    1,146
    10
    Feb 3, 2006
    United States
    Big Appleu
    Ok well I'll be damned. It looks like the problem was me using a Mac. I've downloaded the same files on a Windows machine and unzipped and transferred, it works now. It's so weird. Thank you for all the help anyway!
     
  5. NoSmokingBandit

    NoSmokingBandit GBAtemp Fan

    Member
    411
    138
    Jan 17, 2009
    United States
    I just had this exact problem and smacked myself in the head for not realizing what it was instantly. OSX writes extra data about files in a "._" version of that file, which is generally hidden on any *nix OS.

    So if you look at your updates folder you'll see 123456789.cia. What you won't see is the ._123456789.cia that is created along side it. Sysupdater tries to update using that file and luckily fails before anything goes horribly wrong.

    One can fix this by doing all of this in windows as Icarus did, or cleaning out the 'dot files' by running "dot_clean *path to sd card*" in terminal then ejecting immediately after.
     
    Ronhero likes this.
  6. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,004
    1,055
    Jun 28, 2014
    United States
    Arizona Bay
    Welcome! I see your post count is high what part of the site did you keep to before?

    Thanks for taking the time to explain why.
     
  7. Yangarang

    Yangarang GBAtemp Regular

    Member
    185
    68
    Nov 14, 2015
    Australia
    I found a fix for it