GBArunner: Sonic Advance and Sonic Advance 2 issues

Discussion in 'NDS - Emulation and Homebrew' started by EDboyDSi19, Nov 19, 2019.

  1. EDboyDSi19
    OP

    EDboyDSi19 Member

    Newcomer
    1
    Nov 18, 2019
    United States
    I load both games just fine with GBArunner. Afterwards, after the Gameboy Advance logo, I came across this weird 4 rectangle borders slowly closing up the screen with a music playing. Can't proceed or do anything. Not even resetting works. But Sonic Advance 3 works fine. Is there something I need to do?
     
  2. StarGazerTom

    StarGazerTom GBAtemp Advanced Maniac

    Member
    11
    Feb 2, 2015
    Any chance of a video? I've never seen nor heard of this before.
    Bad roms maybe?
     
  3. FAST6191

    FAST6191 Techromancer

    pip Reporter
    24
    Nov 21, 2005
    United Kingdom
    Some would say the issues are that you are playing Sonic Advance. Bust out a nice megadrive/genesis emulator and play something fun.

    That said what version of GBArunner are you using and what hardware are you trying it on? For some things it is more of a proof of concept than a thing to use for fun.

    I am not aware of these games doing anything on the anti piracy/counter emulator/counter flash cart front so anything there if it is a good ROM is an emulation issue (or possibly user failure but if you get other things going then probably not that).
     
  4. EDboyDSi19
    OP

    EDboyDSi19 Member

    Newcomer
    1
    Nov 18, 2019
    United States
    Going to provide a video soon. I am using GBARunner2 from my DSi, using Twilight Menu ++.
     
  5. EDboyDSi19
    OP

    EDboyDSi19 Member

    Newcomer
    1
    Nov 18, 2019
    United States
    Ok, I don't have a video, but I took some screenshots of how they look when loaded with GBARunner2 on my DSI with Twilight Menu ++, after the logo, this shows for Sonic Advance: https://imgur.com/3Y4s9f8 https://imgur.com/fqsrPT4 I hope these helps.
     
    Last edited by EDboyDSi19, Nov 19, 2019
  6. zfreeman

    zfreeman GBAtemp Advanced Fan

    Member
    8
    Mar 9, 2013
    United States
    Pennsylvania
    Doesn't the compatibility list say you have to patch them? I thought it was related to them checking for link cable capability.
     
  7. EDboyDSi19
    OP

    EDboyDSi19 Member

    Newcomer
    1
    Nov 18, 2019
    United States
    Can you show me the compatibility so I can see? I'm not fully aware of it if it needs patching.
     
  8. zfreeman

    zfreeman GBAtemp Advanced Fan

    Member
    8
    Mar 9, 2013
    United States
    Pennsylvania
  9. EDboyDSi19
    OP

    EDboyDSi19 Member

    Newcomer
    1
    Nov 18, 2019
    United States
    Hmmm, I see now, looks like Sonic Advance is unplayable, same to SA2. Bummer.
     
  10. Rahkeesh

    Rahkeesh GBAtemp Maniac

    Member
    7
    Apr 3, 2018
    United States
    This is down to GBARunner2 not supporting link cable emulation correctly. Both of these games are link compatible.

    There is a build somewhere that emulates link cable with wifi and can run the games correctly, but that has not been rolled into the main branches.
     
  11. EDboyDSi19
    OP

    EDboyDSi19 Member

    Newcomer
    1
    Nov 18, 2019
    United States
    Guess I'll wait and see what happens.
     
  12. StarGazerTom

    StarGazerTom GBAtemp Advanced Maniac

    Member
    11
    Feb 2, 2015
    Glad we atleast found what the problem was.
     
Quick Reply
Draft saved Draft deleted
Loading...