GBA Expansion Pack Loads Bad!!!

Discussion in 'NDS - ROM Hacking and Translations' started by emilito, Sep 5, 2009.

  1. emilito
    OP

    emilito Member

    Newcomer
    26
    0
    Sep 1, 2009
    United States
    Hi, I have a M3 DS real and it works fine!!! But with it i get a gba expansion pack, rumble pack and gba expansion pack for the original ds. And when i was putting the gba expansion pack into the gba expansion pack for the original ds, and was trying it, it didn't work!!! Some roms work, but not all, and when it's working the game looks broken. I have the gba expansion into the ds without m3 ds real and it's says: "a ds option pack is insert" And when i try to load GBA exloader it says: "No expansion pack insert" The same problem with the rumble pack. And I tried also with only the gba expansion pack for the nds lite and the same problem.

    Help me out is there any way to fix it by modding it or a program???
     
  2. Chrono_Tata

    Chrono_Tata GBAtemp Advanced Fan

    Member
    851
    0
    Jan 26, 2008
    Thailand
    Why is this here and not in the M3 section?

    Anyway, the DS recognise the M3 GBA expansion pack as an option pack. That is normal.

    GBAExploader doesn't work with the GBA expansion pack because the M3 team BAWWW to Rudolph probably threatening him with lawsuits if he doesn't remove support for M3 products from GBAExploader, so he did. I believe you can get a patch to patch GBAExploader to make it work with M3 stuff, or you can just look around for an old version of GBAExploader. Google around.
     
  3. emilito
    OP

    emilito Member

    Newcomer
    26
    0
    Sep 1, 2009
    United States
    I think i have a patch to patch thing, it's calling: GBA_ExpLoader_v0.58b_unexcluded.ips and i have the GBA exploader v0.58b what do I do now??
     
  4. Fat D

    Fat D GBAtemp Maniac

    Member
    1,124
    53
    Nov 18, 2006
    Gambia, The
    If you have a M3DS, you are better off not using GBA ExpLoader anyway, as the built-in GBA support is superior on all terms. And the exclusion should block M3 Slot-1 devices only, not M3 Slot-2 carts as expansions.
     
  5. emilito
    OP

    emilito Member

    Newcomer
    26
    0
    Sep 1, 2009
    United States
    I don't understand a shit off this!! The Expansion pack is not working, but When I just have the Gba expansion pck into my ds it's says a ds option pack insert. Whats wrong with my gba expansion pack (same troublem with the rumble pack) [​IMG] Can modding make it work or a homebrew program for the ds??
     
  6. IAmTheRad

    IAmTheRad GBAtemp Regular

    Member
    198
    1
    Aug 7, 2006
    Canada
    It works. Sakura can use it just fine. Run the GBA game from the Sakura menu. It'll work then. That's with the .gba expansion, and not exploader or any of that.

    The DS cannot tell what pack is in it when it's an option pack. Rumble or RAM, it's both the same to the system.
     
  7. Chrono_Tata

    Chrono_Tata GBAtemp Advanced Fan

    Member
    851
    0
    Jan 26, 2008
    Thailand
    If you are loading from the M3 firmware (Sakura or Touchpod), and it still doesn't work properly, then maybe you have a defective unit. I don't have any suggestions other than get a replacement, unfortunately.

    Also, could you explain what "Some roms work, but not all, and when it's working the game looks broken" mean exactly? Do you get graphical glitches, or black screens, or freezes or something?
     
  8. emilito
    OP

    emilito Member

    Newcomer
    26
    0
    Sep 1, 2009
    United States
    Yes, when the gba roms work it's coms grapic glitches, frezze and black screens. Help me here!!!

    PS: Hey a yellow thing inside the Expansion pack is sticking out is that the problem??