EZ-Flash 3in1 won't save

Discussion in 'EZ-Flash' started by cadw, May 13, 2012.

May 13, 2012

EZ-Flash 3in1 won't save by cadw at 3:25 PM (1,777 Views / 0 Likes) 10 replies

  1. cadw
    OP

    Newcomer cadw Member

    Joined:
    Apr 13, 2011
    Messages:
    25
    Location:
    Almere, NL
    Country:
    Netherlands
    I have my EZ-flash 3 in1 now for a view years. When I bought it it also wouldn't save, 3 or 4 years later, it still won't. The battery isn't the problem, it still gives 3V. If I test my SRAM it says:

    Verify
    Nor Flash id=0x227e2202
    start SRAM verify.
    verify Err: Add=0, S=74, D=84

    Write
    Nor Flash id=0x227e2202
    start SRAM verify.
    SRAM check done. Data written to
    SRAM

    ***Finished OK***
     
  2. Coto

    Member Coto GBAtemp Addict

    Joined:
    Jun 4, 2010
    Messages:
    2,278
    Country:
    Chile
    read sram corrupted (data already held by electricity). Writing new sram OK will usually work if you have little battery charge left.

    Battery itself must be the issue. A good idea would be to swap the battery, erase SRAM then make a new one while loading a GBA Game.
     
  3. cadw
    OP

    Newcomer cadw Member

    Joined:
    Apr 13, 2011
    Messages:
    25
    Location:
    Almere, NL
    Country:
    Netherlands
    Are you sure that this will work. If you are, I can order a few batteries on deal extreme.
     
  4. 8BitWalugi

    Member 8BitWalugi Taiyohhhhhh!

    Joined:
    Mar 22, 2008
    Messages:
    3,271
    Location:
    Side 7
    Country:
    Australia
    Usually the battery is dead which causes the SRAM to corrupt. Kinda like old Gameboy games.
     
  5. cadw
    OP

    Newcomer cadw Member

    Joined:
    Apr 13, 2011
    Messages:
    25
    Location:
    Almere, NL
    Country:
    Netherlands
    But the battery still gives 3V, how can it be dead?
     
  6. 8BitWalugi

    Member 8BitWalugi Taiyohhhhhh!

    Joined:
    Mar 22, 2008
    Messages:
    3,271
    Location:
    Side 7
    Country:
    Australia
    I wouldn't know, aside from 'it happens'.

    Sorry bro.
     
  7. Coto

    Member Coto GBAtemp Addict

    Joined:
    Jun 4, 2010
    Messages:
    2,278
    Country:
    Chile
    Yes but look for the specific model the EZ 3-in-1 has. If the battery still outputs 3V, then SRAM gets corrupted suddenly, it only means it can't give the current required by eeprom sram chip, so it'll lose its data.
     
  8. cadw
    OP

    Newcomer cadw Member

    Joined:
    Apr 13, 2011
    Messages:
    25
    Location:
    Almere, NL
    Country:
    Netherlands
    It is an EZ5C13 with an CR1220 battery.
     
  9. how_do_i_do_that

    Member how_do_i_do_that Blue Wizard is about to die.

    Joined:
    May 16, 2008
    Messages:
    4,811
    Country:
    Antarctica
    If the battery gives you 3V, the rom your using is not SRAM.
     
  10. Metal Militia31

    Newcomer Metal Militia31 Member

    Joined:
    Jan 13, 2010
    Messages:
    11
    Location:
    USA
    Country:
    United States
    I have the Same issue and I changed the battery today and it won't save.( i actually just started doing this the last two days) but i have R4 Wood with the EzFlash 3in1. The games dont save at all. and It might be a minor issue because Im a noob at stuff like this.
    Thanks in advance
     
  11. sonicrings

    Member sonicrings GBAtemp Maniac

    Joined:
    Oct 7, 2012
    Messages:
    1,079
    Location:
    Johto
    Country:
    Canada
    I'm getting this exact same problem, and I used GBATA to SRAM patch my ROMs. I am trying to run any Sonic Advance game, but none save...
     

Share This Page