Error installing A9LH on New 3DS: firm1.bin is invalid or corrupt

Discussion in '3DS - Homebrew Development and Emulators' started by brkun, Nov 23, 2016.

  1. brkun
    OP

    brkun GBAtemp Fan

    Member
    427
    71
    Mar 9, 2015
    United States
    Any help? Already changed the files from a9lh folder and nothing. Is it something with my Nand?

    edit: Found the error, thanks to Discord 3DS Hacking group.

    Just download the updated files from plailect guide and be sure that you are using data_input V4 (not V3) and SafeA9LHInstaller 2.6.6;
     
    Last edited by brkun, Nov 23, 2016
  2. sup3rgh0st

    sup3rgh0st Top Tier Ghost

    Member
    292
    183
    Apr 22, 2010
    United States
    Hey, I'm running into the exact same problem, I'm using the data_input V4 provided on the guide, and SafeInstaller 2.6.6, and it gives me the error on an o3DS. Any suggestions?
     
  3. iMolly

    iMolly Newbie

    Newcomer
    4
    0
    Nov 23, 2016
    United States

    I'm having the same issue. Double checked the files, downloaded them again, put them back on SD still same error. "Error: firm1.bin is invalid or corrupted"

    *Edit* I should add I'm on old 3ds XL so my version is 2.0.3 should I still use 2.6.6 ?
     
    Last edited by iMolly, Nov 23, 2016
  4. sup3rgh0st

    sup3rgh0st Top Tier Ghost

    Member
    292
    183
    Apr 22, 2010
    United States
    I'm in the exact same situation, 2.6.6 and 2.6.4 both result in the same error
     
  5. iMolly

    iMolly Newbie

    Newcomer
    4
    0
    Nov 23, 2016
    United States
    I've been trying 2.0.3 and got the error 3 times now. Even tried using a different computer and SD with files copied and same thing. I'll try using the 2.6.6 but the tutorial gives you the downloads for both depending which 3ds you have so I figured 2.0.3 should work.

    Have you tried using 2.0.3 ?
     
  6. sup3rgh0st

    sup3rgh0st Top Tier Ghost

    Member
    292
    183
    Apr 22, 2010
    United States
    yep, that's the version suggested to use in the guide, gives the same error
     
  7. iMolly

    iMolly Newbie

    Newcomer
    4
    0
    Nov 23, 2016
    United States
    Well I tried to use 2.6.6, but when SafeA9 loads it still says v2.0.3

    If anyone else is having this issue on o3ds and fixed it please say something !
     
  8. sup3rgh0st

    sup3rgh0st Top Tier Ghost

    Member
    292
    183
    Apr 22, 2010
    United States
    The guide was updated 15 minutes ago!! o3DS users need data_input_v3 instead of data_input_v4
     
    Last edited by sup3rgh0st, Nov 25, 2016 - Reason: Fixed double post formatting
    angelhp likes this.