Emunand black screen after update

Discussion in '3DS - Flashcards & Custom Firmwares' started by Lucifer666, May 30, 2017.

  1. Lucifer666
    OP

    Lucifer666 all the world needs is me

    Member
    1,496
    733
    Apr 22, 2011
    The Fourth Dimension
    Was on 11.2 in Emunand, booted via Luma3DS and just updated from System Settings.

    Now I cannot load up Emunand anymore. I've updated Luma to the latest version before bootstrap9 or whatever it's called since I'm still on menuhax

    Select menu works just fine, holding L boots sysnand just fine, tried launching EmuNAND with the GW launcher too, which usually works, but now it doesn't.

    Any advice? I just wanted to be on the latest version so I can play online. (Yes I'm aware of ban threats I don't really care)

    Thanks
     
  2. otakusensei

    otakusensei Advanced Member

    Newcomer
    82
    12
    Sep 21, 2007
    United States
    Gateway's launcher has not been updated for 11.3 or 11.4, so you can't run Gateway on an updated Emunand. I'm hoping you made a backup.
     
  3. Lucifer666
    OP

    Lucifer666 all the world needs is me

    Member
    1,496
    733
    Apr 22, 2011
    The Fourth Dimension
    Gateway is not the biggest issue, just getting it to work on Luma would be nice

    I restored a backup from January (which was fine, just had to reinstall 1 CIA) and now it works again but I'd like to be on 11.4

    Can I get this working on Luma without messing around with my entrypoints? Believe it or not I'm still OK with menuhax and won't upgrade unless I have to

    I'm wondering if the problem came from updating while on an older version of Luma? Do you think now that I'm on the one behind the latest, updating should be safe? Or is the problem totally unrelated
     
  4. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,517
    5,474
    Mar 17, 2010
    Norway
    Alola
    B9S is a lot easier to install than A9LH was. Shouldn't take you much more than 30 min to install. I definitely recommend upgrading, it'll save you some headaches.

    When updating Luma, make sure you update boot.3dsx, Luma3DS.dat and arm9loaderhax.bin. Even the *hax version of Luma uses arm9loaderhax.bin.
     
  5. Quantumcat

    Quantumcat Dead and alive

    Member
    11,859
    6,369
    Nov 23, 2014
    Australia
    Canberra, Australia
    Change to Luma to 7.0.5. If Luma 7.1 isn't compatible with a9lh it probably won't be compatible with menuhax either.
     
  6. Lucifer666
    OP

    Lucifer666 all the world needs is me

    Member
    1,496
    733
    Apr 22, 2011
    The Fourth Dimension
    I don't 100% follow you there, when I boot my 3DS menuhax throws me into HBL and that's where I select Luma

    The root of my SD has Luma3DS.dat, /luma/ has config.bin (is this arm9loaderhax.bin? or something else altogether), and /3ds/Luma3DS/ contains the .3dsx and .smdh files to launch from HBL. I don't remember adding the .dat and .bin file; I think Luma set those up itself

    [​IMG]

    This is the DL for 7.0.5. All I did was copy the 3dsx and smdh. Did I do this wrong?

    Thanks so much

    EDIT: Searching my SD for arm9loaderhax.bin yielded nothing, I don't have it on there (at least by that name)

    EDIT 2: I may very well move to B9S once keeping up with Luma becomes paramount, I've just also become curious as to why I had this problem at all from a technical standpoint :)

    That's what I did, I updated it to the last one before they removed *hax and a9lh support
     
    Last edited by Lucifer666, Jun 3, 2017
  7. Quantumcat

    Quantumcat Dead and alive

    Member
    11,859
    6,369
    Nov 23, 2014
    Australia
    Canberra, Australia
    You need arm9loaderhax.bin as well, even though you have menuhax.

    https://github.com/AuroraWright/Luma3DS/wiki/Installation-and-upgrade
     
    Last edited by Quantumcat, Jun 3, 2017
  8. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    2,201
    1,469
    May 1, 2016
    United States
    Copy the arm9loaderhax.bin from that release to the root of your SD card. It doesn't matter if you don't use a9lh.