Homebrew Question EdiZon cheats are always active

smhrambo

Member
OP
Newcomer
Joined
Sep 16, 2018
Messages
6
Trophies
0
Age
34
XP
235
Country
Germany
Hi,
I have the problem, that every time i start a game edizon activates all cheat codes.
What I tried so far:
Start the game.
Go back to edizon.
Deactivate all cheats.
Go back to the game.
Play a little bit.
Save the game.
Kill the game.
Restart the game, but all cheats are active again.
 

TerpToke

Well-Known Member
Member
Joined
Sep 17, 2018
Messages
164
Trophies
0
Age
29
Location
Ohigho
XP
775
Country
United States
Hi,
I have the problem, that every time i start a game edizon activates all cheat codes.
What I tried so far:
Start the game.
Go back to edizon.
Deactivate all cheats.
Go back to the game.
Play a little bit.
Save the game.
Kill the game.
Restart the game, but all cheats are active again.
For the best experience, open the/atmosphere/system_settings.ini file and change dmnt_cheats_enabled_by_default = u8!0x1 to dmnt_cheats_enabled_by_default = u8!0x0.
 
Last edited by TerpToke,

Musicparadox

New Member
Newbie
Joined
Jul 21, 2019
Messages
1
Trophies
0
Age
28
XP
42
Country
United States
Hi I am also having this issue but when I look in my atmosphere folder I don't see a system)settings.inifile how do I get this file. Also even with hidden files displayed on my computer I still cant see this file. So I am assuming I am missing it.
 

Nischie

Member
Newcomer
Joined
Jul 21, 2019
Messages
11
Trophies
0
Age
26
XP
96
Country
Japan
Hi I am also having this issue but when I look in my atmosphere folder I don't see a system)settings.inifile how do I get this file. Also even with hidden files displayed on my computer I still cant see this file. So I am assuming I am missing it.
system_settings.ini it should be there, inside atmosphere folder, not system_settings.inifile but system_settings.ini
 
  • Like
Reactions: MagnesG

sillz

Well-Known Member
Member
Joined
Jan 17, 2018
Messages
105
Trophies
0
Age
40
XP
195
Country
Canada
I am having the same issue with my switch leaving the cheats on through Edizon. I had installed some cheats for Mario kart Version 1.7.1 and when I get to the select character screen it just shows a picture of a cart, the characters are invisible. ( kinda wierd but all other cheats are working)

I did try the change noted above in the system setting.ini to dmnt_cheats_enabled_by_default = u8!0x0. but this did not work.

I read another thread saying you should hold down the L button when loading and the cheats will be disabled. when I do that the cheats are still enabled but the characters now show up and are no longer invisible.

My switch is on firmware 9.1.0 AMS 0.10.1 and using Edizon version 3.0.1
 

Barkermsh

Active Member
Newcomer
Joined
Nov 22, 2016
Messages
27
Trophies
0
Age
36
XP
426
Country
I'm having the same problem, I changed it from 1 to 0 in the system settings file a few months ago.. which worked.

But recently it's always activating the cheats again, I can't even turn them off. When I go into Edizon and untick them all, go back into the game and the cheats are still active. Checked my system settings file and it's still set to 0.

Really confused, I'm running Switch Version 9.0.1 (haven't updated in a while, so no idea why it stopped working) and Edizon 3.1.0
 

Gamerjin

Well-Known Member
Member
Joined
May 25, 2016
Messages
2,026
Trophies
1
XP
4,298
Country
United States
sdcard:\atmosphere\config\system_settings.ini
if
A) this file exist, look for this line:
Code:
; dmnt_cheats_enabled_by_default = u8!0x1
change that to:
Code:
dmnt_cheats_enabled_by_default = u8!0x0
notice that the ";" is gone, and that "u8!0x1" is now "u8!0x0"
after saving the changes, try the game again.
(you may need to reboot the switch, if it doesnt look like it working....)
----------------------------------------------------------------------------------
B) this file does not exist, there should a "atmosphere\config_templates\system_settings.ini"
copy that to "atmosphere\config\system_settings.ini" then goto Option A
----------------------------------------------------------------------------------
C) If somehow, you delete "atmosphere\config_templates",(like i did once)
copy and paste what in the spoiler to a file called "system_settings.ini" and put that in "atmosphere\config". now bear in mind, this has the default setting for everything except one thing. there are no comment lines, this is the "bare-bones" minimum to get you started.
[eupld]
[ro]
[atmosphere]
dmnt_cheats_enabled_by_default = u8!0x0
[hbloader]
 
Last edited by Gamerjin,

wii07

Well-Known Member
Member
Joined
Sep 9, 2019
Messages
106
Trophies
0
Age
35
XP
286
Country
Finland
thx alot. putting the file into sdcard:\atmosphere\config\ did it. i had it directly in sdcard:\atmosphere\.
 
Last edited by wii07,
  • Like
Reactions: Gamerjin

Teito

New Member
Newbie
Joined
Feb 19, 2020
Messages
2
Trophies
0
Age
28
XP
30
Country
Peru
Hey guys, Im having an issue with FE three houses, all the cheats from other games are off but in the case of FE cheats are always active. my dmnt_cheats_enabled_by_default value is already u8!0x0. any help?
 
  • Like
Reactions: Sm0k3r83

FellDragonGrima

Well-Known Member
Member
Joined
May 1, 2017
Messages
233
Trophies
0
Age
27
XP
470
Country
United States
Hey guys, Im having an issue with FE three houses, all the cheats from other games are off but in the case of FE cheats are always active. my dmnt_cheats_enabled_by_default value is already u8!0x0. any help?
The same goes for me, although the cheats seem to be working fine. I just have to turn the ones I don’t want off before continuing my game.
 

Teito

New Member
Newbie
Joined
Feb 19, 2020
Messages
2
Trophies
0
Age
28
XP
30
Country
Peru
Cheats are working fine for me, it's just that they are always active in spite of the dmnt_cheats_enable_by_default is already 0
 

caUnknown

Active Member
Newcomer
Joined
Sep 29, 2019
Messages
44
Trophies
0
Age
40
XP
304
Country
Canada
Cheats are working fine for me, it's just that they are always active in spite of the dmnt_cheats_enable_by_default is already 0

Follow Gamerjin's post.
https://gbatemp.net/threads/edizon-cheats-are-always-active.535104/#post-8935202

Alternatively do this first:
Copy "system_settings.ini" from "atmosphere" folder to "atmosphere\config". Make changes to system_settings.ini file, remove semi-colon (; ) from the beginning of this (dmnt_cheats_enabled_by_default = u8!0x0) line.
 
Last edited by caUnknown,

TerpToke

Well-Known Member
Member
Joined
Sep 17, 2018
Messages
164
Trophies
0
Age
29
Location
Ohigho
XP
775
Country
United States
Ironically over some months I ran into this issue again, but moving the system.ini file to Atmosphere>Config AND removing the ; in front of the dmnt cheat line we edited in the past, worked perfectly!
 
  • Like
Reactions: sabin1981

miraclaime

custom themes maniac
Member
Joined
Jun 12, 2015
Messages
485
Trophies
0
Location
In your house, naked
XP
376
Country
Indonesia
for those whove failed even after making the changes in system_settings.ini file, you need to REBOOT YOUR SWITCH to make the change apply in your switch

after rebooting your cheat shouldnt be auto on anymore.
 
  • Like
Reactions: sabin1981

beefsquatch

Member
Newcomer
Joined
Jul 7, 2020
Messages
7
Trophies
0
Age
34
XP
54
Country
United States
sdcard:\atmosphere\config\system_settings.ini
if
A) this file exist, look for this line:
Code:
; dmnt_cheats_enabled_by_default = u8!0x1
change that to:
Code:
dmnt_cheats_enabled_by_default = u8!0x0
notice that the ";" is gone, and that "u8!0x1" is now "u8!0x0"
after saving the changes, try the game again.

thanks for explicitly calling this out. life. saver.
 
  • Like
Reactions: Gamerjin

LawrenceGee

Active Member
Newcomer
Joined
Nov 13, 2020
Messages
29
Trophies
0
Age
33
XP
389
Country
United States
My cheats are always active and I do have the correct settings, not sure what to do.

--------------------- MERGED ---------------------------

My lines are already like this. Cheats always on. On newest atmosphere and switch firmware.
 

Attachments

  • Edited Line.PNG
    Edited Line.PNG
    13.5 KB · Views: 778

Gamerjin

Well-Known Member
Member
Joined
May 25, 2016
Messages
2,026
Trophies
1
XP
4,298
Country
United States
My cheats are always active and I do have the correct settings, not sure what to do.

--------------------- MERGED ---------------------------

My lines are already like this. Cheats always on. On newest atmosphere and switch firmware.
did you change while running the switch, for example using filezilla+ftpd-light? if so, try rebooting the switch. also check for a toggle file in the cheats of the game youre playing. if you're using tom's version of edizon called edizon-se. it creates a toggle file once you activate a cheat.
 

kidkat210

Well-Known Member
Member
Joined
Nov 9, 2016
Messages
747
Trophies
0
Age
27
XP
1,518
Country
United States
I somewhat have the same problem. Removed the semicolons and copied the file from config templates to config. Reboot my switch, then it just hangs on the Nintendo logo. To get it to fully boot, I have to delete/move the ini
 
General chit-chat
Help Users
  • x65943 @ x65943:
    just where do you live mate
    Gift
  • KenniesNewName @ KenniesNewName:
    Midwest weathers been like 90 all week
    Gift
  • KenniesNewName @ KenniesNewName:
    We don't have garage parking areas at the apartment either so my car bakes in the sun
    Gift
  • KenniesNewName @ KenniesNewName:
    Midwest weather is so bipolar in the summer
    Gift
  • x65943 @ x65943:
    also in midwest, and today at least was really nice - in the 70s with light drizzle and good cloud cover
    Gift
  • x65943 @ x65943:
    have been quite a few scorchers this year tho
    Gift
  • KenniesNewName @ KenniesNewName:
    Depends on the area I'm more up north
    Gift
  • KenniesNewName @ KenniesNewName:
    Supposed to be in the 80s all next week
    Gift
  • Mariposa @ Mariposa:
    hiii! how's everyone doingg
    Gift
  • Dark_Phoras @ Dark_Phoras:
    Hi, I'm fine, how are you?
    Gift
  • Dark_Phoras @ Dark_Phoras:
    Good morning folk
    Gift
  • Dark_Phoras @ Dark_Phoras:
    Everyone is sleeping, I wonder if it's a holiday in the other countries as well
    Gift
  • The Real Jdbye @ The Real Jdbye:
    no, it's just the universal internet dead zone
    Gift
  • The Real Jdbye @ The Real Jdbye:
    and a monday
    Gift
  • Dark_Phoras @ Dark_Phoras:
    It's a holiday in a lot of countries, I checked in the meantime. This is usually one of the most moved periods of the day
    Gift
  • Dark_Phoras @ Dark_Phoras:
    It marks the death of Shmi, Anakin's mother
    Gift
  • The Real Jdbye @ The Real Jdbye:
    but Anakin isn't real
    Gift
  • Gift
  • Gift
  • Dark_Phoras @ Dark_Phoras:
    Assumption Day on 15 August is a nationwide public holiday in Andorra, Austria, Belgium, Burundi, Cameroon, Central African Republic, Chile, Republic of Congo, Côte d'Ivoire, Croatia, Colombia, Costa Rica, Cyprus, East Timor, France, Gabon, Greece, Georgia, Republic of Guinea, Haiti, Italy, Lebanon, Lithuania, Luxembourg, Republic of North Macedonia, Madagascar, Malta, Mauritius, Republic of Moldova, Monaco, Montenegro (Albanian Catholics), Paraguay, Poland (coinciding with Polish Army Day), Portugal, Romania, Rwanda, Senegal, Seychelles, Slovenia, Spain, Syria, Tahiti, Togo, and Vanuatu;
    Gift
  • The Real Jdbye @ The Real Jdbye:
    what does that have to do with Anakin's mom?
    Gift
  • Dark_Phoras @ Dark_Phoras:
    It was a joke based on the analogy of Anakin as a chosen one conceived through divine intervention without sexual intercourse
    Gift
  • DEMONGreninjaPG @ DEMONGreninjaPG:
    what is going on here
    Gift
  • Dark_Phoras @ Dark_Phoras:
    Anakin and his mother serve as an analogy of Jesus and Mary in Star Wars universe
    Gift
  • Gift
    DEMONGreninjaPG @ DEMONGreninjaPG: ?