DSI Error for Gamecube backups on USB Loader GX

Discussion in 'Wii - Backup Loaders' started by Y2CRZY, Jan 8, 2018.

  1. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    20
    Oct 27, 2002
    France
    Engine room, learning
    Sorry jeannotte, I understand you want to help.
    it's just, a lot of users just through "post syscheck" without knowing how to read it, or if IOS is really the problem and syscheck would not help fix the problem at all.
    But at least, we can tell him to "fix" (it's not really broken, but it's always nice) his slot249 to install r52 instead.

    for some reasons, for a week I don't receive any notification when I'm tagged.


    before answering, I'll tell you the differences, because most guide don't.

    r52 can only mount HDD from USBport0.
    r53 is a beta version, but released anyway. it can mount USB Port0 and Port1, has a first-try of Plug'n'Play (you plug microphone, or Portal, or wiispeak, or USB accessory AFTER booting the game).

    it was later found that r53 had more issues which weren't known are release date (but guides never cared to update/fix their informations, so a lot of people still end with using the bad version. Or the author are just plain stupid to mix r52 and r53 with different base.... they never tried to think by themselves).
    - r53 has "some HDD" (not all of them) init/mount issue when using EmuNAND
    - r53 has game incompatibility (Just dance, and another game I always forgot)
    - r53 doesn't work with wii games on SD card (wiiflow let you do that, not USBGX)

    If you don't need to use 2 USB Ports at the same time (why would you?), then you don't need r53 at all !
    if you care about plug'n'play, it was a (failed?) test, just plug your USB accessory for your game before powering the console.


    Now, how to replace d2x cIOS :
    download this :
    D2x cIOS Installer FULL package for Wii (not vWii)

    create a a folder on your SD card :
    sd:/apps/d2x_installer/
    extract in that folder.
    launch d2x installer from HBC (first be sure you have internet access.... and you are not in 2019 because nintendo will close eShop/network access for the Wii)
    Press A, and use d-PAD to select this :

    What : d2x v8 Final (or v10 r52, these are actually EXACTLY the same thing, except for one thing : r52 is supposed to fix a HDD compatibility issue)
    where : 249
    base : 56
    version : 21008 / 21010, or 65535 if you don't have priiloader and plan to insert and play disc game from system menu.

    Press A to Install from network.
    once done, exit the installer.
     
    Last edited by Cyan, Jan 12, 2018
  2. Y2CRZY
    OP

    Y2CRZY Member

    Newcomer
    1
    Jan 8, 2018
    United States
    @Cyan
    Thanks a bunch man it worked! I tested a few games and no more dsi! I even turned off the wii and no problems (yet) if I do have any problems i'll report them back here.

    @Everyone
    Thanks for all your guys help I really appreciate it, this whole thing was getting me a little stressed out lol
    Again i'm very grateful for the help everyone! Peace. :)
     
  3. Y2CRZY
    OP

    Y2CRZY Member

    Newcomer
    1
    Jan 8, 2018
    United States
    Sorry to bother you guys again but i'm getting the exception dsi again..
    Since Friday it has been working fine, I can load my Gamecube backups and everything was good. I only just now got the error maybe 15 minutes ago and it's been happening every time I try to load a GC game. It happened after I played Paper Mario I hit the R+Z+B+down to go back to the menu and switch games and when I picked a new game the dsi error came up.
    I tried a few things.

    1) I went to the d2x cios installer to see if I needed to rewrite the slot 249 again, I didnt see the option for d2x v8 Final so I just exited and tried to download that the files again and replaced them on my SD card, looked again on d2x cios and the d2x v8 option still wasn't there.

    2) Then I went to Nintendont and loaded a random game, exited then went back to USB loader and it worked one time, I played the game on USB Loader for a few mins and thought my issue was fixed so I reset again and picked another GC game to load, got the dsi error.

    I'm going to post another sys check but i'm wondering what happened again? I didn't touch any settings this time but just play a few gamcube games also my wii games are fine still nothing wrong with those. I'm confused what exactly causes the "Exception dsi occurred"? And what can I do to fix it this time? and hopefully not have to deal with this again.

    Edit: Just tried a sys check, deleted the one from friday off my sd and tried to make a new one it's not showing up. I can try again if you need it.
     
  4. GreyWolf

    GreyWolf GBAtemp Guru

    Member
    7
    Mar 2, 2015
    United States
    Nindendont doesn't use a cIOS. It uses only an unpatched IOS58. The report you posted on the previous page looked fine other than the beta53 version in slot 249 and it shouldn't be affecting the loader or Nintendont. It only has problems when a retail game is running.

    When EXACTLY is the exception occurring? Before or after the USB Loader GX logo comes back up? If it's before it isn't the loader that's crashing. It's possible you don't have the loader's forwarder installed or you have USB Loader GX set to the wrong title for the ReturnTo feature.
     
  5. Y2CRZY
    OP

    Y2CRZY Member

    Newcomer
    1
    Jan 8, 2018
    United States
    @GreyWolf

    The exception comes up right after I press start on whatever gamecube game I try to play in USB loader. I just click on the game I hear the Gamecube startup jingle I press start and immediately I get the exception dsi screen.

    Edit: I do have the Melee disc in my wii and sometimes play on that because I already have a physical memory card with a save on there. But I only play that from the wii menu not in usbloader.

    Edit 2: When I go to the option "display as a channel grid" when I pick a Gamecube game I get " Error: To run GameCube games with Nintendont you need the boot.dol file in your Nintendont Loader Path."
     
    Last edited by Y2CRZY, Jan 15, 2018
  6. Y2CRZY
    OP

    Y2CRZY Member

    Newcomer
    1
    Jan 8, 2018
    United States
    I was also wondering if their was a way to use my save data from USB in Nintendont?
     
  7. Thirty3Three

    Thirty3Three Musician Member

    Banned
    10
    Mar 22, 2013
    United States
    Wherever you want me, baby.
    You have to run a DSi game first, and then the error will go away.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice