1. Zyleq

    OP Zyleq Newbie
    Newcomer

    Joined:
    Jul 28, 2017
    Messages:
    2
    Country:
    United States
    Originally i was doing a ctrtransfer to carry over my ctrnand from my n3dsxl to my n2ds. but recently when i tried to use flash cart it would boot to an black screen. i also tried ds download play but also gives me an black screen. i was recommend the troubleshooting guide but that was unsuccessful.
     
    Last edited by Zyleq, Jan 31, 2018
  2. Quantumcat

    Quantumcat Dead and alive
    Member

    Joined:
    Nov 23, 2014
    Messages:
    15,149
    Country:
    Australia
    Lacius likes this.
  3. Zyleq

    OP Zyleq Newbie
    Newcomer

    Joined:
    Jul 28, 2017
    Messages:
    2
    Country:
    United States
    nope didn't work i believe i must of corrupted my twl_firm or something. Do you know how i would go about fixing that.would restoring my nand work?
     
  4. E1ite007

    E1ite007 Weird avatar guy
    Member

    Joined:
    Nov 19, 2016
    Messages:
    671
    Country:
    Mexico
    The troubleshooting guide has the TWL_FIRM to install, but you said that you followed the guide and didn't worked... so the TWL_FIRM isn't broken.
    What steps of the troubleshooting guide did you do?
     
  5. Sonic Angel Knight

    Sonic Angel Knight GBAtemp Legend
    Member

    Joined:
    May 27, 2016
    Messages:
    13,475
    Country:
    United States
    What CFW you using? Like list some information on your system setup please. :teach:
     
  6. marioluigipeach10

    Newcomer

    Joined:
    Jun 14, 2018
    Messages:
    8
    Country:
    United States
    Hello, I have the same issue, I'm currently running 11.6 on my 'Old' 3DS. I used the 3DS.guide but now my DS games give me a black screen. Actually anything that uses DS functions don't work anymore, not even the DS wifi settings. I tried my R4 on it but that didn't work, but When I played by r4 on my 2DS, it worked just fine. I'm running 9.1 Luma and I'm using gm9. Ive heard that those are outdated or something as there are apperently better methods, idk. I followed the guide and installed the required cia files, but to no success. So I know it's not the TWL.FIRM, I can assume that something went wrong during the installation process...What's worse is that this is a pretty rare problem, not alot of people know how to fix this. help.
     
  7. Quantumcat

    Quantumcat Dead and alive
    Member

    Joined:
    Nov 23, 2014
    Messages:
    15,149
    Country:
    Australia
    Try updating to the latest firmware. There's no advantage being on 11.6.
     
  8. marioluigipeach10

    Newcomer

    Joined:
    Jun 14, 2018
    Messages:
    8
    Country:
    United States
    Alright, I updated to 11.8, and assuming its a starting point, DS/DSi functionality is still broken. Immediately, nothing noticeable has changed for me. I believe Luma 9.1 can't be abliterated by 11.8 so...
     
  9. marioluigipeach10

    Newcomer

    Joined:
    Jun 14, 2018
    Messages:
    8
    Country:
    United States
    Does anyone have any suggestions?
     
  10. TurdPooCharger

    Member

    Joined:
    Jan 1, 2018
    Messages:
    6,544
    Country:
    United States
    You said you already tried this?

    Maybe you have NVRAM type brick?

    Are you using EmuNAND? DSiWare doesn't work with that.

    Probably not related, but worth trying for your DS flashcart:

    Lastly, perhaps your flashcart has a time bomb?

    Or it's really old, so it's not on the DS cart whitelist (aka, blocked).
     
    Last edited by TurdPooCharger, Oct 11, 2018
  11. marioluigipeach10

    Newcomer

    Joined:
    Jun 14, 2018
    Messages:
    8
    Country:
    United States
    Yes, I tried the 3ds.guide for restoring the DS/DSi Mode functionality.

    I don't know about the NVRAM brick, because I'm not familiar with any DS Bricker type applications.

    I checked using Luma3DS, I'm not using EmuNAND.

    Yeah that's not related.

    My Flashcart's fine, I tried it on my 'old' 2DS and it's fine.

    It's not blocked, since it works on my 'old' 2DS.
     
  12. TurdPooCharger

    Member

    Joined:
    Jan 1, 2018
    Messages:
    6,544
    Country:
    United States
    Check if your DSi (TWL) firmware works by playing a TWLNAND installed title. Either download a DSiWare game at that iso site or use TWiLight Menu++ and Launcher with a *.nds rom like Mario Kart DS.

    If this works, try playing a physical DS game cart. Don't use your DS flashcart; a 3DS game is acceptable but not favored. If you don't own a DS game, stop by a GameStop and ask if they'll let you quickly debug your 3DS. Just let them know your dilemma; don't mention you have custom firmware as some salesclerks are sticklers about homebrew.

    If DSiWare doesn't work and SysNAND Restore, CTRTransfer with GodMode9, nor DSi functionality repair guide fixed your 3DS DSi Mode...
    Your last available software based repair methods are:
    If these three do not work, your fault is presumed hardware based in nature.

    If DSiWare works but your DS (or 3DS) game isn't read or played when launched...
    You may be looking at cleaning or replacing your game slot reader.
    and
     
  13. marioluigipeach10

    Newcomer

    Joined:
    Jun 14, 2018
    Messages:
    8
    Country:
    United States
    Specs: Running latest 3DS software 11.10.0-43U. Latest version of GM9. Don't know about Luma. If there are other important programs that I need to check please list how to access them and update.

    Problem: My o3DS still does not boot anything NTR related. Not even the internet settings. I've looked into this issue and what I do know for SURE, is that this is a software problem only, and that this was caused most likely by user error. I have tried the latest method for fixing this issue that is shown on 3ds.guide. But to no avail. People say that this issue may have been caused by an error during the Flashing NTRboot thing, assuming that it modifies the 3DS's NTR functionality to boot DS software. (Right?)

    What I have done: Okay so what I have done is that I looked into the whole CTRTransfer thing. A short question, is the 9.2.0 CTRTransfer different from the 11.5.0 version, because I followed the 11.5 version in hopes of fixing my o3DS's DS functions. I hope what I have followed is the correct one... Anyway, so I was in the middle of the process of transferring images on the guide, and when I was asked to open the 'Scripts from Plailect's Guide', all the sudden I get this issue that there are 'too many arguments' in the script. Now at this point in GM9, the top of the screen was yellow, which meant that I had reached a point where I could possibly lose a lot of data and games if done incorrectly. (Spoiler: I did lose all my games and save data:sad:) So then I realized that I was on GM9 version 1.3, which I guess couldn't understand the code or something? I fixed this issue by getting the latest version (v1.8.0). Though I may have made a mistake by cutting the CTRTransfer process short due to having to manually remove the SD card to edit the files in order to actually UPDATE the GM9. I finished the process and... I didn't work. DS games still give me a black screen and all my games and saves are gone because I forgot to create and emergency backup.

    Conclusion: I seriously messed up now, I probably should have just taken what I had. I guess now that my 3DS is done, I'll probably continue to look for answers and see what is going on with my o3DS's NTR. I have looked into the Flasher NTRBoot to see if that's the issue, maybe I messed up during the process? If you guys have any answers this please do give feedback. I probably should have followed the 9.2.0 CTRTransfer that I was recommended. Yes I know this is mostly my fault.




     
    Last edited by Quantumcat, Jul 27, 2019
  14. TurdPooCharger

    Member

    Joined:
    Jan 1, 2018
    Messages:
    6,544
    Country:
    United States
    @marioluigipeach10, it's been a while. Is your DS(i) mode still bricked?

    Some things have changed since you last replied.

    1. CTRTransfer in Decrypt9WIP has drawbacks erasing some console unique files.

    2. The TWLFix-CFW from the current DSi / DS functionality is broken after completing the guide is known to fail if your firmware has fake TWL system tickets.

    3. Here's another o3DS with persistently bricked DS(i) mode. Despite seemingly being unrelated, hardware failure from the camera was determined to interfere with TWL_FIRM.
     
    Last edited by TurdPooCharger, Jul 26, 2019
    Lacius likes this.
  15. marioluigipeach10

    Newcomer

    Joined:
    Jun 14, 2018
    Messages:
    8
    Country:
    United States
    Thanks! I'll look into all of these and update you when I try all these out.
     
  16. marioluigipeach10

    Newcomer

    Joined:
    Jun 14, 2018
    Messages:
    8
    Country:
    United States
    I removed the fake Title, ran the DS restoration program through the Homebrew Channel.

    It worked. My 3DS's TWL functionality works! :D
     
    TurdPooCharger likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - troubleshooting, functionality, following