Download ERROR! (ret = -1) with Waninkoko's homebrews

Discussion in 'Wii - Hacking' started by ThoMiCroN, Jul 7, 2012.

  1. ThoMiCroN
    OP

    ThoMiCroN Newbie

    Newcomer
    6
    0
    Jul 7, 2012
    Canada
    Hi guys ! I have a persistent problem since months and I can't do anything about it !

    I want to use the following Waninkoko's homebrews :
    • Firmware Updater v4.3b
    • Custom IOSX rev20b
    It's always the same problem. After it connects to Internet, it tries to download some IOS, and then :

    Download ERROR! (ret = -1)


    If one looks at this : http://fathertom.net...error_codes.pdf

    It says :

    1) Your SD card is not formatted as FAT16 or FAT32 properly, reformat it.

    My SD is perfectly fine. It's in FAT32, and I tried with another one.

    2) You deleted the file, after you selected it for install… stop doing shit like this.

    IMPOSSIBRU ! I don't do shit like this.

    3) Appears, when there is no “WAD” folder on your device. (SD-card)

    There is one, but I don't care since I use Internet for that, and not the wads.

    Install the required cIOS! For your HomeBrew App!

    Maybe it's that. Then, what can I do ? Most of all, how could I install any cIOS if the cIOS installer doesn't work !
     
  2. Lacius

    Lacius GBAtemp Guru

    Member
    6,418
    2,664
    May 11, 2008
    United States
    Firmware Updater v4.3b and Custom IOSX rev20b are both outdated and not recommended. I highly suggest you use ModMii to install the recommended IOS and cIOS files.
     
  3. Anon10W1z

    Anon10W1z GBAtemp Maniac

    Member
    1,112
    56
    Feb 18, 2012
    United States
    Somewhere over the rainbow
    Yes, I agree! ModMii can download the cIOS's and SM 4.3 for you.

    BTW, why do you want 4.3? There are no advantages to it!
     
  4. ThoMiCroN
    OP

    ThoMiCroN Newbie

    Newcomer
    6
    0
    Jul 7, 2012
    Canada
    Well, because I prefer to have the latest version, it annoys me not to have it, even though it's not essential.
     
  5. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    6,037
    929
    Nov 6, 2002
    Portugal
    Proud to be Portuguese but I am in USA.
    Well, believe it or not.. I have 3.2u and I dont need the latest version and I dont have an error like you. Yes, I am using Waninkoko's homebrews. The 4.3 really have no advantage. Anon1 is right, listen to people who have experience. You will be fine. Good luck. :)
     
  6. Hielkenator

    Hielkenator GBAtemp Psycho!

    Member
    4,219
    385
    Feb 7, 2010
    Netherlands
    Modmii will get your wii up to date. SAVE.
    Wanin's apps with all respect, have been known to cause un repairable bricks.

    it's outdated and unsafe.
    Trust me I've been there, it happens, and when it happens your to late.
    Consider yourself lucky you got an error .

    Use modmii to get your files and follow the instructions provided.