Downgrading to 2.1.0 fails

Discussion in '3DS - Flashcards & Custom Firmwares' started by kristiansja, Apr 30, 2016.

  1. kristiansja
    OP

    kristiansja Advanced Member

    Newcomer
    62
    26
    Apr 30, 2016
    Norway
    i think i have tried downgrading emuNAND to 2.1.0 5 times now and they all fail im using an old 3ds with GATEWAY Emunand with Luma3DS

    here is a plaisysupdater error report
    http://pastebin.com/c9bzETvN
    and this is where it fails
    Code:
    0004003000009802 : v.12288 -> v.02049 ->

    //////////////////////////////////////////
    Edit
    //////////////////////////////////////////
    thansk to everyone for the help, i now have arm9loaderhax. The problem was that i werent on 10.7
     
    Last edited by kristiansja, May 1, 2016
  2. a9lh-1user

    a9lh-1user GBAtemp Fan

    Member
    327
    129
    Apr 1, 2016
    Gambia, The
    Last edited by a9lh-1user, Apr 30, 2016
  3. kristiansja
    OP

    kristiansja Advanced Member

    Newcomer
    62
    26
    Apr 30, 2016
    Norway
  4. a9lh-1user

    a9lh-1user GBAtemp Fan

    Member
    327
    129
    Apr 1, 2016
    Gambia, The
    okay then you have a "backup" if something goes wrong :) GOOD!
    Also you are using this guide : https://github.com/Plailect/Guide/wiki or anything else?
    Last question: if you used the Plailect guide did you DG to 9.2.x and made backups after that?
    (do you have a CLEAN 9.2.x sysNAND of yur OLD 3DS?)
    Or did you use your GW emuNAND?
     
  5. kristiansja
    OP

    kristiansja Advanced Member

    Newcomer
    62
    26
    Apr 30, 2016
    Norway
    i have a 9.2 sysnand and i created a emunand out of that
     
  6. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    Did you disable FIRM0/FIRM1 protection within your CFW? (I believe both Cakes and Luma3DS can do it)
    The EmuNand downgrade can't proceed properly if you have it enabled.
     
    a9lh-1user likes this.
  7. a9lh-1user

    a9lh-1user GBAtemp Fan

    Member
    327
    129
    Apr 1, 2016
    Gambia, The
    That means you are dealing with the Gateway NAND.
    Sorry i dont now anything about that from personal experience.
    I made 3 OLD 3DS and 4 NEW 3DS till now (with 6 different guides from Plailect because it feels like they change every day like Aureinand / Luma3DS) and NONE had problems by DG to 2.1.0 .
    But i dont own a Gateway, but i read that they've done a BAD job by plaing with your NAND (Aurora Wright and others are cleaning that mess for some people!)

    So sorry i couldn't help you because of missing knowledge :(
    Hope someone else could help you ...... people with a Gateway and emuNAND experience in getting it to A9LH :)

    — Posts automatically merged - Please don't double post! —

    @CrispyYoshi there is no CFW till now he will DG to 2.1.0 :)
    @CrispyYoshi OOPS my mistake forgett it!!!!!!
     
    Last edited by a9lh-1user, Apr 30, 2016
    CrispyYoshi likes this.
  8. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    Actually, they need a CFW to boot into their EmuNand, and their first post suggests they are using Luma3DS, which blocks FIRM0/FIRM1 patches by default.

    It can be disabled by holding Select in the Luma3DS settings, but they might have to get the dev version of Luma3DS in order to do it.

    EDIT: Nevermind, it seems (or is implied) that Luma3DS does not block FIRM0/FIRM1 patches on EmuNAND: https://github.com/AuroraWright/Luma3DS/wiki/Other-features-and-notes (CTRL+F "FIRM write-protection")
     
    Last edited by CrispyYoshi, Apr 30, 2016
    a9lh-1user likes this.
  9. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    @kristiansja I think your next best bet is to get rid of your Gateway EmuNand before you downgrade it. I'm hoping you don't have anything important on your SysNand.

    To do this, you should:
    - Flash your double-formatted 9.2 emunand or your very first sysnand backup (the one you dumped before using TinyFormat, but otherwise your very first EmuNand backup) to your sysnand using Decrypt9 directly from HBL after a boot. Don't launch Luma3DS when you do this.
    - Set up menuhax again if you have to, then follow the guide from the beginning of Part 3: https://github.com/Plailect/Guide/wiki/Part-3-(RedNAND)

    (You might have already done part 3, but please re-do it just to be absolutely safe.
     
    Last edited by CrispyYoshi, Apr 30, 2016
  10. kristiansja
    OP

    kristiansja Advanced Member

    Newcomer
    62
    26
    Apr 30, 2016
    Norway
    flashed a realy old nand and crated redNAND, still get the error (2 tries) WTF?!
     
  11. Tiibz

    Tiibz GBAtemp Regular

    Member
    119
    18
    Aug 22, 2014
    France
    Got the same problem with a o3ds a few days back, the solution was quite simple: just update your emunand to 10.7 (you can do another format after that to be sure if you want) and the downgrade will go through (it did first time for me after the update)
     
    kristiansja likes this.
  12. kristiansja
    OP

    kristiansja Advanced Member

    Newcomer
    62
    26
    Apr 30, 2016
    Norway
    Okay will try.
     
  13. pbanj

    pbanj The "friendly" neighborhood sandwich

    Member
    2,732
    1,433
    Dec 29, 2014
    United States
    in a ziploc
    Chances are you have modified twl/agb stuff on your sysnand. So when making the emunand it transfers. The downgrader has issues with that. Updating of emunand to 10.7 should clear it out and let you downgrade to 2.1
     
    XRaTiX likes this.
  14. kristiansja
    OP

    kristiansja Advanced Member

    Newcomer
    62
    26
    Apr 30, 2016
    Norway
    thanks man, finally worked, have restored to 9.2 on sysnand and emunand :) quick question, when compiling a a9lhx fork do i replace the otp.bin with mine?
     
    CrispyYoshi likes this.
  15. pbanj

    pbanj The "friendly" neighborhood sandwich

    Member
    2,732
    1,433
    Dec 29, 2014
    United States
    in a ziploc
    Yes. You can just use the stuff that's included in the guide https://github.com/Plailect/Guide/wiki/Part-5-(arm9loaderhax-&-Luma3DS) you won't have to compile anything, just put ur otp in the right place.
     
    kristiansja likes this.
  16. SirBeethoven

    SirBeethoven 3.145.... something. E=mc2

    Member
    1,809
    552
    Nov 26, 2015
    United States
    @Plailect could you add this to the Guide?
     
  17. Plailect

    Plailect GBAtemp Advanced Fan

    Member
    516
    1,222
    Jan 30, 2016
    United States
    You do not have to be on 10.7 to do the downgrade...
     
  18. pbanj

    pbanj The "friendly" neighborhood sandwich

    Member
    2,732
    1,433
    Dec 29, 2014
    United States
    in a ziploc
    This is why he had to upgrade to 10.7
    He also could have used a CIA installer to install the unpatched ver of twl and agb.
     
  19. Ricken

    Ricken And you must keep your soul

    Member
    2,240
    2,478
    Jan 19, 2016
    United States
    Shibuya, The small one from Vegas
    To be fair one of the first things you do with RedNand is update it :P
     
  20. SirBeethoven

    SirBeethoven 3.145.... something. E=mc2

    Member
    1,809
    552
    Nov 26, 2015
    United States
    Oh ok, my mistake. I've just heard of the select few that have problems if not on 10.7. This is probably just to do with patched TWL and AGB firm that they need to update the firms to normal first to downgrade.