Downgrading 4.2 to 4.1 Wii via Hombrew

Discussion in 'Wii - Hacking' started by nknave, Oct 4, 2009.

Oct 4, 2009
  1. nknave
    OP

    Member nknave GBAtemp Regular

    Joined:
    Jun 23, 2009
    Messages:
    154
    Country:
    Mexico
    Hi guys, I'm here to share with you all that I've been experimenting with my Wii (BootMii as Boot2 or else I wouldn't do it) and the new Firmware, I'm an enthusiast.


    Well first of all, I tried the following to downgrade back to 4.1 and ended up as a brick.

    WAD Manager 1.5

    Uninstalled IOS70, reinstall all old IOS that I originally had when I had 4.1 installed.

    After doing this, black screen, nothing booted, of course, I fixed with cBoot2/Wad Manager 1.4 patched.


    My next attemp will be removing all STUBS and see if that has any effect.


    Has anyone tried to this this in any way?
     


  2. G0dLiKe

    Member G0dLiKe who needs a title ;)

    Joined:
    Aug 2, 2009
    Messages:
    1,674
    Country:
    United States
    No, not really.

    My way down from 4.2 to 4.1 was with BootMii Nand backup...
     
  3. comboace

    Newcomer comboace Newbie

    Joined:
    Sep 13, 2009
    Messages:
    2
    Country:
    United States
    Did you also install the 4.1 system menu?
     
  4. nknave
    OP

    Member nknave GBAtemp Regular

    Joined:
    Jun 23, 2009
    Messages:
    154
    Country:
    Mexico
    Yup, I'm sure I did everything necessary, but didn't contemplate the new Nintendo Stubbs, which I will now, and I got a funky feeling SystemMenu481(4.2U) leaves some traces which prevents older SystemMenus installed. [​IMG]
     
  5. beegee7730

    Banned beegee7730 ITS PAAFEKUTO!

    Joined:
    Mar 31, 2009
    Messages:
    1,693
    Location:
    England
    Country:
    United Kingdom
    You do know AnyRegionChanger will do this?
    Also, did you install IOS60 and 4.1 System Menu?
     
  6. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    i think you bricked because you uninstalled IOS 70.


    try install v6174 of IOS 60 then the system menu of 4.1
     
  7. nknave
    OP

    Member nknave GBAtemp Regular

    Joined:
    Jun 23, 2009
    Messages:
    154
    Country:
    Mexico
    The method was like this:

    Once all new is installed including stubs and IOS70 (must), I did the following.


    Uninstalled IOS70 first, Installed IOS60, Installed SM4.1 and all other IOS......... = black screen.

    I'm thinking it's either residues from 4.2 or the stubs might be making noise.

    I'll try some stuff when I get home.

    I'ts maily for knowledge purposes rather than downgrading for sure, I think 4.2 is fine in my book, and PreLoader is working [​IMG]
     
  8. piratesmack

    Member piratesmack GBAtemp Advanced Fan

    Joined:
    Mar 28, 2009
    Messages:
    787
    Location:
    $(pwd)
    Country:
    United States
    If you updated through Nintendo, you have boot2v4 (same version that the "lu64" wiis have) and downgrading will probably brick you.
     
  9. comboace

    Newcomer comboace Newbie

    Joined:
    Sep 13, 2009
    Messages:
    2
    Country:
    United States
    I was also wondering about IOS61 since that was used as a bug fix for WM+ and that was for 4.1. I do know it's used for the shop channel.
     
  10. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    @piratesmack - He can downgrade to 4.1 - or down to any menu 3.4 or newer...

    @comboace: IOS61 is only used by the shop channel and the HBC. It has nothing to do with the WM+ fix. The 4.0 and 4.1 menu use IOS60.

    Delete the stub IOS60 with ATD then install IOS60 v6174 and SM4.1 without removing IOS70. An unused IOS won't bother anything.

    Stubs for IOS30,40,50 shouldn't cause any issue.

    Also, I'm assuming you're overwriting the system menu, not uninstalling then reinstalling the older one. If you uninstall it, that's what's causing the brick (settings.txt goes missing when you do that).
     
  11. markehmus

    Member markehmus GBAtemp Advanced Fan

    Joined:
    Jul 26, 2008
    Messages:
    896
    Location:
    in the GAME
    Country:
    Canada
    did the nintendo update and installed new hackmiiv5 and could get anyregionchanger to do it it wouldnt run,
    niether did firmware-downgrader-mod-1.24 and 7 hours of playing with apps on the new 4.2, so many apps dont work rite.

    i did install the new boot mii prior so i just nand dumped then updated reinstalled bootmii,screwed around, hated it, recovermii to 3.2u.

    yesterday morning i was on 3.2 without any homebrew, not even preloader or HBC,just have wiikey 1.9s.
    last nite i tried everything mentioned above , now loving the new bootmii.
    this was done on my spare wii in the closet as i love 4.1 and use it on my regular daily wii.

    maybe today i may try the waninkoko 4.2 updater to see how it results with homebrew.
    will firmware-downgrader-mod-1.24/AnyRegionChanger work?? does it matter since recovermii does??
    ahh im nosey so maybe i will check
     
  12. antonkan

    Member antonkan GBAtemp Maniac

    Joined:
    Jun 13, 2009
    Messages:
    1,063
    Location:
    Burlington, ON
    Country:
    Canada
    Well, if you have system menu 4.2, you CANNOT downgrade to system menu 4.1 and below because 4.2 has boot2v4 rather than boot2. It will brick your Wii!
     
  13. piratesmack

    Member piratesmack GBAtemp Advanced Fan

    Joined:
    Mar 28, 2009
    Messages:
    787
    Location:
    $(pwd)
    Country:
    United States
    But to do that, he would have to downgrade IOS60 (4.0-4.1) or IOS50 (3.4).

    I thought Boot2v4 won't run downgraded IOS's
     
  14. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    but if your wii originally can install bootmii as boot2, then you get recover that by installing bootmii v4
    then you can possibly downgrade.
    but as for those with bootmii as IOS and are on 4.2, i dont think there is a way of downgrading.
     
  15. lettuce

    Member lettuce GBAtemp Advanced Fan

    Joined:
    Jul 27, 2006
    Messages:
    635
    Country:
    United Kingdom
    Well i downgrade from 4.2 to 4.1. (make sure you have ISO60 v6174 on your system first not ISO60 v6400) For safety measures make sure u have a backed Nand and boot2 install if possible. Heres what i did:

    Used IOS-Downgrader
    Downgrade to FW to 3.2 using cIos Downgrader
    Run Waninkoko's 4.1 updater
     
  16. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    yea but i bet you used waninkoko's 4.2 updater and/or installed bootmii as boot2.
     
  17. nknave
    OP

    Member nknave GBAtemp Regular

    Joined:
    Jun 23, 2009
    Messages:
    154
    Country:
    Mexico

    In my case, I'm not using Boot2v4 cause I never updated that part of my Wii (it is stupid to do this).


    Remember that Boot2v4 started on Some Wii's with FW v 3.4, so if you Wii came with that version, all corresponding IOS to that version will run on your Wii and no bricks will Happen.

    There is no Wii on a retail store that comes with a Boot2v5???? that only supports newer IOS that came with this latest update.


    Basicly, yes you may Downgrade to at least 4.0 on any Wii without a fear of Brick (at your own risk).



    Oh, and thanks for keeping up with the thread, With the help of some coments here I found out that my Wii wasn't booting cause I did uninstall the SM before reinstalling and settings.txt were lost and therefore, the black screen of death.


    Cheers.
    Please lock the thread.
     
  18. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    Pretty sure that only matters if you downgrade below 3.4. People need to get their misconceptions about boot2v4 sorted out.
     
  19. 0M39A

    Member 0M39A GBAtemp Fan

    Joined:
    Apr 24, 2009
    Messages:
    374
    Country:
    Australia
    quick question (its probably obvious but im tired [​IMG] )

    if i for some stupid reason update to 4.2 via nintendo, and get my boot2 updated to boot2v4, then run the hackmii installer and get bootmii back, would i still be able to use my old 3.2e nand backups with the new boot2 version?

    cant imagine any reason i would need to, as i have been on 4.1 for a while now and have plenty recent backups of that i could use.
     
  20. Thomas83Lin

    Member Thomas83Lin Retro Gamer

    Joined:
    Jul 22, 2009
    Messages:
    1,485
    Country:
    United States
    Not that i recommend downgrading, but i have a boot2v4 running older IOS's just fine

    edit: If it matters though this wii does have bootmii installed to boot2 with the boot2v4, That might make the difference
     

Share This Page