Do I need to install some emulator on PSP for it to launch PSX games?

Discussion in 'PSP - Hacking & Homebrew' started by niceme.me, Apr 27, 2016.

  1. niceme.me
    OP

    niceme.me Member

    Newcomer
    42
    4
    May 24, 2015
    Poland
    Hi,

    PSP 3004 6.60 PRO, psx eboots not working what I can do about it? Im guessing adding pure psx ISO on PSP SD not gonna work and I get licence error when trying to open eboots(same happens with PSP games that I need to open play as ISO)
     
  2. nxwing

    nxwing GBAtemp Addict

    Member
    2,007
    4,077
    Jul 22, 2013
    Philippines
    The Capital
    What version of PRO CFW exactly?

    — Posts automatically merged - Please don't double post! —

    Also, niceuserna.me
     
  3. niceme.me
    OP

    niceme.me Member

    Newcomer
    42
    4
    May 24, 2015
    Poland
  4. nxwing

    nxwing GBAtemp Addict

    Member
    2,007
    4,077
    Jul 22, 2013
    Philippines
    The Capital
  5. niceme.me
    OP

    niceme.me Member

    Newcomer
    42
    4
    May 24, 2015
    Poland
    I should first format my memory stick and then drop 6.61 update?
     
  6. nxwing

    nxwing GBAtemp Addict

    Member
    2,007
    4,077
    Jul 22, 2013
    Philippines
    The Capital
    That could help too
     
  7. yeshuachrist

    yeshuachrist GBAtemp Regular

    Member
    193
    56
    Sep 1, 2010
    United States
    try the "popsloader" plugin, there are a few versions floating around, with that plugin you can use a lower version of pops on the 6.61 firmware. Some eboots were made for/with older versions of popsloader. (or just avoid the 6x firmware on psp completely, meaning downgrade).
     
    Last edited by yeshuachrist, Apr 27, 2016
  8. Arecaidian Fox

    Arecaidian Fox Pink Foxi

    Member
    923
    991
    Sep 5, 2013
    United States
    Snohomish, WA
    No offense, but I had nothing but headaches with 6.61. It broke so many plugins designed for 6.60 it was ridiculous. AFAIK, it was basically released for ONE game to use, otherwise, everything else should work fine. None of my POPS games have had trouble on 6.60 PRO C-2, either.
     
  9. yeshuachrist

    yeshuachrist GBAtemp Regular

    Member
    193
    56
    Sep 1, 2010
    United States
    (the best version of pops is 3.52, if I remember correctly, maybe it was 3.51, one of the 4x versions are supposed to be good too ... ... ... ... some versions of pops have random hangs in certain games)
     
  10. nxwing

    nxwing GBAtemp Addict

    Member
    2,007
    4,077
    Jul 22, 2013
    Philippines
    The Capital
    Davee released a plugin that allows 6.60 plugins to work on 6.61.