DLDI Auto-patching

Discussion in 'DSTT' started by Psi, Mar 30, 2008.

  1. Psi
    OP

    Psi Newbie

    Newcomer
    9
    0
    Mar 15, 2008
    Canada
    Doesn't dldi auto-patching mean you don't have to do any dldi patching? Just drag n' drop?

    Because for some of the homebrew apps i use (including DSOrganize and Moonshell) it keeps giving me errors saying "dldi error, please patch dldi". I can still open the apps but some functions wont work. This is my first time with a ds cart (but I am somewhat computer savvy) so please don't start calling me an idiot if it's just me making mistakes.
     
  2. Bri

    Bri GBAtemp Psycho!

    Member
    3,413
    2
    Dec 25, 2007
    United States
    First, yes DLDI auto-patching means you don't have to do any DLDI patching.

    I don't get those errors with either DSOrganize or Moonshell. Do you have the latest kernel installed (v1.09)?

    -Bri
     
  3. Guat

    Guat Member

    Newcomer
    32
    0
    Mar 23, 2008
    Puerto Rico
    The two times i have gotten the DLDI error were because i once tried to run an older version of an emulator, and the other was when i tried to run an app that was already patched for another brand of card.

    After checking your kernel version, and if you are still having problems, try re-downloading the latest versions of the apps you are having problems with.
     
  4. Seina

    Seina Advanced Member

    Newcomer
    76
    0
    Jan 27, 2008
    United States
  5. Bri

    Bri GBAtemp Psycho!

    Member
    3,413
    2
    Dec 25, 2007
    United States
    I've used the one from ndstt.com and it works fine with the DSTT. It's not patched as far as I know, but it's not the newest version. My guess is that Psi isn't using that version, but forgot to select the option to not patch moonshell when he installed it, so it got patched for another cart.

    -Bri
     
  6. Psi
    OP

    Psi Newbie

    Newcomer
    9
    0
    Mar 15, 2008
    Canada
    Hmm, well i am using v1.09 (1.08a) and i did download moonshell from the dstt website, i will check if my version of dsorganize is outdated or for the wrong card though (I don't have my ds with me right now so i can't check at the moment) but i guess since i can still do what i use those programs for its alright...
     
  7. Bri

    Bri GBAtemp Psycho!

    Member
    3,413
    2
    Dec 25, 2007
    United States
    Psi, I don't know what the problem might be then. Maybe try installing v1.10 of the kernel (just came out yesterday I think) and see if you're still having problems. It seems like you have an already-patched version of the applications (maybe patched for the wrong cart), or that they're not installed properly.

    -Bri