CycloDS Evolution Firmware v1.53 Released!

Discussion in 'CycloDS' started by Rayder, Jan 12, 2009.

  1. Rayder
    OP

    Rayder Mostly lurking lately....

    Former Staff
    6,613
    130
    Jan 14, 2007
    United States
    USA
    CycloDS Evolution Firmware v1.53 has been released and is availablee. Changes in this release include:

    * Linking between NDS and GBA pokemon games via EZ3in1 NOR supported
    * Game compatibility fixes (2746, 3191)

    Those game numbers are Phantasy Star Zero and Think Kids, BTW.

    I didn't post an official release about it because I suck at doing graphics and stuff, I'll leave that to someone who can make it look all pretty. But I thought everyone would want to know anyway. Once an "Official" topic has been created, this post could be closed. I gotta head off to work......

    Source:
    http://www.teamcyclops.com/forum/showthread.php?t=10444

    Link to update page:
    http://www.cyclopsds.com/cgi-bin/cyclods/e...pl?page=support
     
  2. frantier123

    frantier123 GBAtemp Regular

    Member
    176
    0
    Nov 9, 2008
    Senegal
    Do anyone have errors after updating firmware?

    I cannot run Animal Crossing and Brain Age ... and all commercial roms I tink ...
     
  3. Eon-Rider

    Eon-Rider GBAtemp Maniac

    Member
    1,021
    15
    Jun 15, 2008
  4. frantier123

    frantier123 GBAtemp Regular

    Member
    176
    0
    Nov 9, 2008
    Senegal
    Argh. Mine dun even LOAD!
     
  5. skarthebloodchild

    skarthebloodchild Keep It Old School

    Member
    2,215
    64
    Jan 13, 2004
    Greece
    Greece
    Maybe they will release some version 2 with some more fixes.
    Looks like a buggy firmware if what you say is true.
     
  6. frantier123

    frantier123 GBAtemp Regular

    Member
    176
    0
    Nov 9, 2008
    Senegal
    Awww.

    I downgrade back to v1.51 ... but still can't work.

    I guess it my problem. Anyone know how to fix this?


    Edit: Right. Nevermind. I got it working after I downgraded to v1.51 and delete the CycloDS folder...

    Looks like I will stick to v1.51 for now -.-"


    Edit Edit: Yay! I manage to get v1.53 working after using this method:

    2. Delete any .sav file.

    3. Run CycloDS.. Next, run the rom that the .sav file u delete.

    4. The rom should run .... but will take a bit long ... i say 10 secs?

    5. You should now be able to run other roms.
     
  7. kikoexe

    kikoexe GBAtemp Regular

    Member
    136
    0
    Jul 9, 2006
    ^that's weird.. i just placed the update.evo file in the root of my micro sd, started the update and after the process, i tried to run some games and they loaded perfectly.. i didn't do anything else like deleting .sav files or whatever.. the loading process doesn't take more than 5 seconds.. so i guess this update is ok.. [​IMG]
     
  8. frantier123

    frantier123 GBAtemp Regular

    Member
    176
    0
    Nov 9, 2008
    Senegal
    I dunno ... maybe is becos CycloDS cannot read R4's sav file ... so mus create a save file by emself first inorder to run r4's .sav file.
     
  9. unz

    unz Chaotic Neutral

    Member
    283
    21
    Jul 14, 2008
    Curmudgeon's quarters
    Yeah, 1.53 works just fine for me too. Installed with no problems and it loads all my games/saves without a hitch.

    Thanks for the heads up Rayder. [​IMG]
     
  10. AC/DS

    AC/DS GBAtemp Regular

    Member
    173
    0
    Nov 20, 2008
    Star Wars:The Clone Wars still freezes at the same point though [​IMG] At least for me.
    Have they ironed out the EZ 3-in-1 issues? Would like to buy one, if only for Mother 3.
     
  11. davrizio

    davrizio Member

    Newcomer
    10
    0
    Jan 1, 2009
    United States
    Mine updated fine as well...

    Games do take longer to load it seems...

    Still no fix for those of us who have the EZ Flash 3in1 Plus... just tried it and no luck. [​IMG]
     
  12. camintmier

    camintmier Member

    Newcomer
    41
    0
    Nov 27, 2008
    United States
    WV, USA
    Just updated a minute ago and tested it out. Everything seems to run fine. Only had one minor problem. I use the alternate save path, so I had to turn it back on after the update. Other than that, everything's golden. It detects old (1.51) saves and all just fine.
     
  13. KillerKlown

    KillerKlown Member

    Newcomer
    23
    0
    Jan 11, 2009
    United States
    Texass
    Mine is fine sooo far... Thanks again guys!
     
  14. KillerKlown

    KillerKlown Member

    Newcomer
    23
    0
    Jan 11, 2009
    United States
    Texass
    Mine is fine sooo far... Thanks again guys!
     
  15. unz

    unz Chaotic Neutral

    Member
    283
    21
    Jul 14, 2008
    Curmudgeon's quarters
    That's strange. I use the alternative save path too, but the update didn't change any of my settings.
    That was the first thing I checked after the reboot.

    Edit: w00t! 50th post! Halfway to the trading forum...
     
  16. volcomstone00009

    volcomstone00009 Advanced Member

    Newcomer
    62
    0
    Jan 1, 2009
    United States
    it takes quite a bit longer than normal but it runs fine after that.... [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG]

    EDIT: I think i might downgrade....idk...ill see about the other games
     
  17. DeMoN

    DeMoN GBAtemp Guru

    Member
    7,649
    100
    May 12, 2004
    United States
    Has anyone checked if there's support for the EZ Flash +?
     
  18. Santee

    Santee Jalapeño

    Member
    812
    319
    Nov 13, 2008
    United States
    Conneticut
    nope after i updated checked browser and game with rumble support didn't work unless your suppose to do something other than run games
     
  19. DeMoN

    DeMoN GBAtemp Guru

    Member
    7,649
    100
    May 12, 2004
    United States
    No, the older firmware couldn't run GBA games without GBA Exploader, I'm wondering if this patch fixed that problem because many people with EZ Flash+ are experiencing it.
     
  20. Santee

    Santee Jalapeño

    Member
    812
    319
    Nov 13, 2008
    United States
    Conneticut
    i have a plus and cyclo i meant are you supposed do something other than run the browser and play the game with rumble support