Connection Problems (Can't ping externally)

Mythical

Well-Known Member
OP
Member
Joined
May 11, 2017
Messages
2,147
Trophies
1
Age
23
XP
2,923
Country
United States
So I've been trying to set up my wifi so I can host my Killing Floor 2 Servers.
My wifi is cable line -> modem -> router -> ethernet to hosting pc
On this wifi I was having troubles with my port forwards going though, which lead me to realize people can't even ping my external ip (I can internally).
What I've done:
1) Set up static ip
2) turned off upnp
3) setup port forwards on router
4) configured firewall on router and hosting pc
5) restarted router
After this the ports don't seem to be forwarded and even without all of this I'm unable to have my external ip pinged from outside my network (it seems I'm completely unable to recieve packets)
I've tried completely disabling firewall temporaily, dmz, open nat, turning off extra programs and antivirus and I still can't get it to work.
I also called my isp and made sure there weren't any issues on their end.
I also this wirelessly on my network as well.

Does anyone have any clue why my computer internet works just fine except I can't ping my external ip externally and I can't get port forwards to go through?
This is very frustrating and I can't seem to figure out my problem.
 

Joom

 ❤❤❤
Member
Joined
Jan 8, 2016
Messages
5,996
Trophies
1
XP
5,794
Country
United States
A lot of routers block ping requests as a security measure. This can usually be disabled in the router's firewall. You also shouldn't be using ping requests to see if a port is open. You can either use the site CanYouSeeMe, or you can use the CLI tool nmap. It's also a good idea to not have a firewall or AV on the server host. It's an even better idea to not run this out of your house, but I guess everyone has to experience this headache at least once.
 

notimp

Well-Known Member
Member
Joined
Sep 18, 2007
Messages
5,782
Trophies
1
XP
4,382
Country
Laos
Usually you fix that problem by putting the modem/router into something called 'bridge mode' (if they support it), which would disable the 'routing part' of it, or to add your secondary routers IP to the modem/routers DMZ (demilitarized zone), basically disabling all firewall aspects of the modem/router combo for the secondary router.

Or in lesser 'broad stroke' ways, if your modem/router is actually configurable beyond that. ;)
 
Last edited by notimp,
  • Like
Reactions: Alexander1970

Mythical

Well-Known Member
OP
Member
Joined
May 11, 2017
Messages
2,147
Trophies
1
Age
23
XP
2,923
Country
United States
Usually you fix that problem by putting the modem/router into something called 'bridge mode' (if they support it), which would disable the 'routing part' of it, or to add your secondary routers IP to the modem/routers DMZ (demilitarized zone), basically disabling all firewall aspects of the modem/router combo for the secondary router.

Or in lesser 'broad stroke' ways, if your modem/router is actually configurable beyond that. ;)
I tried bridged mode and it made my internet break, had to do a whole reset of both modems/routers. Thanks for the help though :D
 
  • Like
Reactions: Alexander1970

notimp

Well-Known Member
Member
Joined
Sep 18, 2007
Messages
5,782
Trophies
1
XP
4,382
Country
Laos
Bridge mode should make the router/modem behave as a modem/switch only (so dropping all routing functionality). ;)

Main issue here is, that we dont know what your router/modem does exactly. ;) Personally I'm also behind 'double routers' (but I can port forward ;) ), and I never had problems with pinging the wider internet, even at default settings.. ;)

So most of what you are doing is actually trying to figure out what that 'box does' and trying to prevent some of that.. ;) DMZ or bridge mode are the 'inelegant' solutions of "stop most of what you are doing (firewall)" - that would help most people in those situations. That you didnt have to use them is actually a good thing.. ;)
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Coto @ Coto: YYZ - Rush . Neil Peart was a living legend.