1. shining8930

    OP shining8930 Newbie
    Newcomer

    Joined:
    Oct 24, 2018
    Messages:
    8
    Country:
    Taiwan
    Hi everybody
    I have a PS4 version 5.50
    But don't want to update 6.72
    Recently saw Joonie86 porting Hen 2.1.3
    So I downloaded the 5.50 source code to compile
    But an error occurred during compilation
    I don’t know if my method is wrong or the file is missing
    Can somebody help me Please
    I have been confused for weeks
    Or can you help me compile 5.50 HEN
    Thank you everyone
     
  2. MostlyUnharmful

    MostlyUnharmful GBAtemp Fan
    Member

    Joined:
    Feb 8, 2018
    Messages:
    387
    Country:
    Italy
    Well, even if you use it on FW 5.50 it's still the same exploit, so unless you have a broken Bluray, in my opinion you don't have a lot of advantages against updating to FW 6.72, anyway post the error...

    From what I recall, compiling it wasn't difficult but I was never able to link it with the linker available on Debian and I lost interest before trying to grab the right Ubuntu version.
     
    KiiWii and Leeful like this.
  3. shining8930

    OP shining8930 Newbie
    Newcomer

    Joined:
    Oct 24, 2018
    Messages:
    8
    Country:
    Taiwan
    First let me thank you for your reply
    Many people recommend keeping the lower firmware version
    However, there happens to be a ported HEN2.1.3
    I want to keep the firmware version without upgrading
    :rofl2::rofl2::rofl2:
     
  4. Leeful

    Leeful GBAtemp Member
    Developer

    Joined:
    Sep 4, 2015
    Messages:
    1,316
    Country:
    United Kingdom
    Even if you port and compile hen to work on 5.50 you will still need a webkit and a kernel exploit that works on 5.50.
     
    KiiWii likes this.
  5. godreborn

    godreborn Retired
    Member

    Joined:
    Oct 10, 2009
    Messages:
    12,909
    Country:
    United States
    I think that may be included. I asked joonie about control, since it doesn't work back ported. he couldn't get it to work on any firmware between 5.05 and 6.72 despite the fact that the game says it's for 6.50. someone asked about it on psx place, and I checked with pkg viewer. unfortunately, he said it forced him to update to 6.72, so it's a bizarre game to say the least.
     
    shining8930 likes this.
  6. shining8930

    OP shining8930 Newbie
    Newcomer

    Joined:
    Oct 24, 2018
    Messages:
    8
    Country:
    Taiwan
    kernel ?
    Are you talking about this
    “ ps4-ipv6-uaf-5.50”

    I watched some YouTube
    After using the web core
    Then use NetCat GUI to inject hen2.1.3.bin
    Can achieve Jailbreak effect
     
    Last edited by shining8930, Sep 18, 2020
    Leeful likes this.
  7. Leeful

    Leeful GBAtemp Member
    Developer

    Joined:
    Sep 4, 2015
    Messages:
    1,316
    Country:
    United Kingdom
    Yes, thats the one for 5.50.
    If you are having trouble compiling Hen make sure you are using Ubuntu 16.04.5 {16.04.06 also works). Which SDK are you using?
     
  8. shining8930

    OP shining8930 Newbie
    Newcomer

    Joined:
    Oct 24, 2018
    Messages:
    8
    Country:
    Taiwan
    I am using Ubuntu 20
    Because joonie said he used Ubuntu 20 to compile HEN files
     
  9. Leeful

    Leeful GBAtemp Member
    Developer

    Joined:
    Sep 4, 2015
    Messages:
    1,316
    Country:
    United Kingdom
    Personally I have never been able to compile any PS4 payloads on anything above ubuntu 16.04.06. (apart from the latest mira versions)
    I cant even compile the xVortexSDK on 20.04 without it throwing errors.
    I think on later versions of ubuntu you need to change something in the make files but I have no idea what.

    I just use ubuntu 16.04.5 to compile any ps4 payloads (including the latest hen for 6.72) and I have no trouble at all.

    What errors are you getting when you try and compile hen?
     
  10. MostlyUnharmful

    MostlyUnharmful GBAtemp Fan
    Member

    Joined:
    Feb 8, 2018
    Messages:
    387
    Country:
    Italy
    You are not alone. I only tried with the original Vortex HEN and I recall I was able to compile it but it failed at link time or the executable produced was huge in comparison to their release.

    I tried to gather more info about the tinkering of the ELF structure, or the lack of it, and got confused about the -T option in the makefile: I thought it was an option for "ln" but it made no sense, I realized a lot late it was an option passed to the linker by gcc, but at that time I had already lost interest... ^__^;

    Also, looks like I can't find the ported HEN sources for FW 5.50.
     
    shining8930 and Leeful like this.
  11. shining8930

    OP shining8930 Newbie
    Newcomer

    Joined:
    Oct 24, 2018
    Messages:
    8
    Country:
    Taiwan
    When I try to compile HEN appears
    Missing file Ps4.h

    Please let me thank you again
    You answered my question very seriously
    No matter what the result is
    I will sincerely thank

    — Posts automatically merged - Please don't double post! —

    [​IMG]
    But I have seen any hen version
    Ps4.h file is missing
    I don't know how they compile...

    — Posts automatically merged - Please don't double post! —

    Do not worry
    Most people choose to upgrade the system version
    joonie transplanted the hen
    If we can't use
    We also have the option to upgrade the system
    I just Can not accept the 550
    I put in the closet for two years:rofl::rofl:

    — Posts automatically merged - Please don't double post! —

    HEN Code?
    Search Joonie86 in github
    You can find it
    [​IMG]
    [​IMG]
     
    Leeful likes this.
  12. MostlyUnharmful

    MostlyUnharmful GBAtemp Fan
    Member

    Joined:
    Feb 8, 2018
    Messages:
    387
    Country:
    Italy
    That's why @Leeful asked about which SDK version you were using, you also need the proper PS4-SDK library and headers files, I suppose one with the offsets for FW 5.50.

    I tried to build HEN with Joonie86 forked PS4-SDK repository but doesn't look like it's the right one (does it still have the conflicting type error for __dev_t from 2~3 years ago?), tried with esc0rtd3w's and it doesn't built it either but I think this one fails at link time as I remember, so next I would probably need to hunt the right Ubuntu version with the specific linker as I only have Debian on my PCs but right now I'm not in the mood...

    P.S. the instruction aren't super clear but to build the HEN you need to use an env variable to point to path where you have compiled the SDK, something like "export PS4_SDK=/path/to/the/root/of/PS4-SDK".
     
    Leeful likes this.
  13. Leeful

    Leeful GBAtemp Member
    Developer

    Joined:
    Sep 4, 2015
    Messages:
    1,316
    Country:
    United Kingdom
    Here is Joonies Hen for 5.50 compiled without errors. (on Ubuntu 16.04.06)
    Screenshot from 2020-09-19 10-25-36.png
    If you have trouble loading it directly with binloader using chedochaps 5.50 exploit try loading miraloader.bin first (port 2020) then send Hen to port 2021.
    You might not have to do this on 5.50 but on 6.72 chedochaps exploit and binloader does not load Hen directly, you have to load it through miraloader first.(miraLoader NOT mira!)
    If you need help getting the 5.50 miraloader.bin just let me know and I'll upload it.

    EDIT: sorry, I just checked the mira github and there is no build for 5.50 so if Hen does not load directly with the binloader in chedochaps 5.50 exploit you are stuck.:(
     

    Attached Files:

    Last edited by Leeful, Sep 19, 2020
    susi91 and shining8930 like this.
  14. shining8930

    OP shining8930 Newbie
    Newcomer

    Joined:
    Oct 24, 2018
    Messages:
    8
    Country:
    Taiwan
    I am still stuck in environmental issues
    Thank you so much for helping me compile
    Otherwise I will still report an error
    [​IMG]
    I will continue to learn how to compile
    thank you
    Thank Very very much
     
    Leeful likes this.
  15. Leeful

    Leeful GBAtemp Member
    Developer

    Joined:
    Sep 4, 2015
    Messages:
    1,316
    Country:
    United Kingdom
    Have you tried the Hen bin I uploaded on your 5.50 ps4?
     
    shining8930 likes this.
  16. shining8930

    OP shining8930 Newbie
    Newcomer

    Joined:
    Oct 24, 2018
    Messages:
    8
    Country:
    Taiwan
    Currently 5.50 has successfully loaded Hen2.1.3
    I think this is very helpful for players below 6.02
    Thank you for your help to me and everyone
    [​IMG]
     
    Leeful likes this.
  17. Leeful

    Leeful GBAtemp Member
    Developer

    Joined:
    Sep 4, 2015
    Messages:
    1,316
    Country:
    United Kingdom
    Happy to hear it works.:):)
     
    shining8930 likes this.
  18. shining8930

    OP shining8930 Newbie
    Newcomer

    Joined:
    Oct 24, 2018
    Messages:
    8
    Country:
    Taiwan
    You saved my bad weekend
    Have a nice day
    :yay::yay:
     
    Leeful likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - compile, please, error