Clearing up a Misconception about SDXC cards update

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Fisherman765, May 21, 2018.

  1. ikithme

    ikithme GBAtemp Regular

    Member
    2
    Mar 28, 2015
    United States
    Your testing is skewed and not in a good way, the problem and confusion that is going on is:
    If you do NOT have the newest Firmware and you insert a card that requires the update, does it also update your Firmware to the newest version?

    Many have said yes, some have said no. That is the confusion. What you are describing is not relevant as both times you were at the latest Firmware so it only pulled in the update for the SDCard.
     
  2. GBA rocks

    GBA rocks GBAtemp Fan

    Member
    4
    Jan 4, 2013
    wow this is HUGE news
    hope I’m reading this right
    this should be pinned or something
     
  3. starburst

    starburst GBAtemp Regular

    Member
    2
    Apr 15, 2017
    Spain
    Google's translation is accurate in this case. The optional step asks you to replace a second file (BCPKG2-1-Normal-Sub) using the previously patched one.
     
  4. rajkosto

    rajkosto GBAtemp Advanced Fan

    Member
    11
    Apr 6, 2017
    all firmwares since 2.0.0 (and no firmwares) contain the exFAT support, it depends on how you get it and what NCA gets installed as package2
     
  5. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    19
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Not sure what you mean but obviously not every firmware update contains the exFAT support. I have heard people specifically say that 5.x includes it though.
     
  6. rajkosto

    rajkosto GBAtemp Advanced Fan

    Member
    11
    Apr 6, 2017
    Only because thats the firmware they got when they pressed update from the SDXC prompt.
    If you did it when 2.0.0 latest you would get 2.0.0 with exFAT.
    Stock 5.0.x does not contain exFAT and thats unlikely to change for any future firmware, unless nintendo changes their licencing model with microsoft.
     
  7. Raugo

    Raugo GBAtemp Fan

    Member
    6
    Nov 22, 2014
    The games with 1.0.0 firmware like Zelda have a update partition and inside of it are the exfat package2. I extracted it but I don't have a 1.0.0 switch to try it. I also tried the same method with a 3.0.2 console and works.
     
  8. rajkosto

    rajkosto GBAtemp Advanced Fan

    Member
    11
    Apr 6, 2017
    You can't use that package2.
    It's signed/encrypted for devkits, not retail consoles.
     
  9. Raugo

    Raugo GBAtemp Fan

    Member
    6
    Nov 22, 2014
    I'm the author of this tutorial. This step is optional because the switch have two copies of the package2 partition the second one only is used if the first one are corrupted or have some problem. Don't need to inyect it to make it works but if you like to have the two partitions with the same content like in the official state you can inyect it.

    Ok ok, it's a shame.
     
    charlieb, GBA rocks and PikachuPro like this.
  10. Flash77

    Flash77 Newbie

    Newcomer
    2
    May 23, 2018
    France
    Oh good thé tuto have changed ! Now is possible with a game great news thanks
     
  11. riyyi

    riyyi Advanced Member

    Newcomer
    4
    Sep 13, 2009
    Netherlands
    PikachuPro likes this.
  12. charlieb

    charlieb GBAtemp Fan

    Member
    5
    Jan 15, 2016
    That's a shame. quite a few of us are on 1.0.0 and are stuck

    edit:
    I've learnt there is no exfat drive for 1.0.0 except a dev one that requires dev keys. so no exfat drive for 1.0.0 ever
     
    Last edited by charlieb, May 25, 2018
  13. hippy dave

    hippy dave BBMB

    Member
    15
    Apr 30, 2012
    United Kingdom
    e: dammit wrong place
     
  14. i4ybrid

    i4ybrid Member

    Newcomer
    3
    Jul 31, 2007
    United States
    OP is wrong, I just went from 4.1.0 to 5.0.2 cause of this post cause I wanted the SDXC update. Oh well, I would have needed SDXC support no matter what, so that kind of blows.
     
  15. GBA rocks

    GBA rocks GBAtemp Fan

    Member
    4
    Jan 4, 2013
    Read the whole thread, there is a way to get exFAT support while staying on 4.1.
    The OP was updated with an edit.
     
Loading...