Cannot launch Wii eShop games from Wii U

Discussion in 'Wii U - Homebrew' started by OriginalHamster, Dec 6, 2016.

  1. OriginalHamster
    OP

    OriginalHamster UStealthy

    Member
    3,381
    642
    Nov 2, 2008
    Cote d'Ivoire
    Hi, I'm having a problem when trying to launch my legit Wii eShop games from Wii U menu, every time I launch a Wii game the screen goes black, after about 1 minute the Wii U reset itself to the system menu... What happen? I can access to the Wii menu just fine :/

    I played Metroid Trilogy just fine about one month ago, now I downloaded SMG2 and Kirby Return to Dreamland and cannot play them!

    I haven't made any change on vWii recently, just installed latest HBC. On Wii U I installed haxchi with Kirby Mass Attack...
     
    Last edited by OriginalHamster, Dec 6, 2016
    zeldaism likes this.


  2. zeldaism

    zeldaism GBAtemp Advanced Fan

    Member
    780
    263
    Apr 19, 2016
    United States
    Do you have the latest fw.img(Dimok's branch)?
     
    Last edited by zeldaism, Dec 6, 2016
  3. OriginalHamster
    OP

    OriginalHamster UStealthy

    Member
    3,381
    642
    Nov 2, 2008
    Cote d'Ivoire
    I apply a fw.img yeah, don't remember what was it, kinda did that step blindly.

    I'm not sure if it was Dimok one tbh, I completely rush to get a working fw.img
     
    Last edited by OriginalHamster, Dec 6, 2016
    zeldaism likes this.
  4. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    zeldaism likes this.
  5. zeldaism

    zeldaism GBAtemp Advanced Fan

    Member
    780
    263
    Apr 19, 2016
    United States
    Forgot to ask that as well.
     
  6. OriginalHamster
    OP

    OriginalHamster UStealthy

    Member
    3,381
    642
    Nov 2, 2008
    Cote d'Ivoire
    Not sure... I remember having aplied a fw.img once, I though it wasn't permanent... :c

    At the time trying to play Wii games on Wii U I boot them directly, I didn't load any fw.img, not even started HBL or haxchi.
     
    zeldaism likes this.
  7. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    If it is rednand your problem is vwii doesn't work in rednand and neither does wii eshop.

    So the titles worked when booting normally? Are these games legit or pirated?
     
  8. OriginalHamster
    OP

    OriginalHamster UStealthy

    Member
    3,381
    642
    Nov 2, 2008
    Cote d'Ivoire
    No, they don't, what I mean is that even when booting directly I got black screen, they are legit eShop downloads.
     
  9. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    Have you messed with system files? Sounds like you bricked OSv1 somehow
     
  10. OriginalHamster
    OP

    OriginalHamster UStealthy

    Member
    3,381
    642
    Nov 2, 2008
    Cote d'Ivoire
    But I can access to Wii menu through Wii channel O.o
     
  11. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    Thats because vWii boots OSv0 while wii eshop games boot OSv1
     
    zeldaism likes this.
  12. OriginalHamster
    OP

    OriginalHamster UStealthy

    Member
    3,381
    642
    Nov 2, 2008
    Cote d'Ivoire
    That's bad, what can I do?
    Cannot I revert fw.img to a clean one?
     
    Last edited by OriginalHamster, Dec 6, 2016
  13. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    fw.img doesn't effect that. Try deleting and reinstalling the games. (SMG2 is the smallest iirc)
     
  14. OriginalHamster
    OP

    OriginalHamster UStealthy

    Member
    3,381
    642
    Nov 2, 2008
    Cote d'Ivoire
    None of them works... I better delete all of them?
     
  15. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    You should yes
     
  16. zeldaism

    zeldaism GBAtemp Advanced Fan

    Member
    780
    263
    Apr 19, 2016
    United States
    Do you still have metroid prime? If so try launching it.
     
  17. CeeDee

    CeeDee hm?~

    Member
    3,825
    5,378
    May 4, 2014
    United States
    somewhere
    Super Paper Mario (US) or New Super Mario Bros. Wii (EU) would be smaller.
     
  18. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    I meant of the ones the OP had installed
     
  19. OriginalHamster
    OP

    OriginalHamster UStealthy

    Member
    3,381
    642
    Nov 2, 2008
    Cote d'Ivoire
    Delete them all... Downloading Kirby RtD again, I hope it works :c, fingers crossed.
    OSv1 should be installed within the first Wii VirtualConsole title right? How I'm supposed to screw that, never messed with system files, I'm not that advanced user to do that :c
     
    Last edited by OriginalHamster, Dec 6, 2016
  20. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    afaik the wii u boots a fw.img in the content folder. I think that fw.img is booted with the help of OSv1