Bypassing the mandatory updates when using the eShop?

Discussion in '3DS - Homebrew Development and Emulators' started by SonikkuTheGreat, Feb 4, 2015.

  1. SonikkuTheGreat
    OP

    SonikkuTheGreat Advanced Member

    Newcomer
    50
    7
    Aug 3, 2010
    United States
    Virginia
    Recently as you probably know, Nintendo updated Club Nintendo with its final rewards, which are tons and tons of Wii U, Wii, and 3DS games. I'm interested in the 3DS games, but I realized that I can't download any of the 3DS games, because I'd need to update my system (the eShop asks you to update when you load it up if you're on outdated system software), and since I'm using Ninjhax, this is a problem. I want to be able to use Ninjhax and download stuff from the eShop. Could something be created that could bypass the mandatory updates? I mean, I'm just assuming that since I already have Ninjhax installed, that if I updated to the latest firmware version, it'd remove the hack or stop me from being able to use it.

    Oh, and my 3DS' version is 9.2.0-20 U.
     
  2. lPolarisl

    lPolarisl GBAtemp Fan

    Member
    334
    92
    Jan 24, 2015
    Hungary
    Haven't tested it myself (I'm in the same situation as you are), but i think the following can be done :
    -Back up your SD card.
    -Downgrade to 4.x.
    -set up emunand.
    -go into the eshop on emunand and download what you need.
    -back up that sd card.
    -restore the 9.2 nand.
    -copy your first backup to your sd card.
    -copy your second backup to your sd card, without overwriting.

    -(optional) come back to speak about how it went :)
     
  3. LoneGrenade

    LoneGrenade IT Technician/Rookie Coder

    Member
    157
    64
    Mar 14, 2009
    Canada
    ~/ #

    I don't think this will work because the ticket.db would still be from the original 9.2 NAND.

    There's more information on it here: http://gbatemp.net/threads/tutorial-moving-eshop-content-from-emunand-to-sysnand.379879/
     
  4. lPolarisl

    lPolarisl GBAtemp Fan

    Member
    334
    92
    Jan 24, 2015
    Hungary
    Maybe, but the NNid will still be the same...
     
  5. gamesquest1

    gamesquest1 Nabnut

    Member
    GBAtemp Patron
    gamesquest1 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    14,148
    9,501
    Sep 23, 2013
    but you still wouldnt be able to launch them unless you merge the new ticket.db into your old 9.2 nand.....and flashing modified nands to sysnand is always a "do at your own risk" situation
     
  6. lPolarisl

    lPolarisl GBAtemp Fan

    Member
    334
    92
    Jan 24, 2015
    Hungary
    Then it would be setting up an emunand with 9.2, but this still doesn't work without a gateway :(
     
  7. SonikkuTheGreat
    OP

    SonikkuTheGreat Advanced Member

    Newcomer
    50
    7
    Aug 3, 2010
    United States
    Virginia
    So I'd need a Gateway for any of this? That sucks, since I'm fairly low on money. Those things are so expensive.
     
  8. lPolarisl

    lPolarisl GBAtemp Fan

    Member
    334
    92
    Jan 24, 2015
    Hungary
    In theory setting up emunand without gateway should be possible, but it doesn't work... We can only hope that it freezes only because it is still in beta, and that they'll fix it sooner or later :(
     
  9. nosklo

    nosklo Member

    Newcomer
    49
    14
    Oct 16, 2010
    Brazil
    You could buy a new SD Card, make a emunand in it, and load it in classic mode, using MT Card's laucher.dat, every time you want to play your eShop games.

    It works without the gateway card.

    Here's a guide.
     
  10. gamesquest1

    gamesquest1 Nabnut

    Member
    GBAtemp Patron
    gamesquest1 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    14,148
    9,501
    Sep 23, 2013
    if you downgrade to 4.x you can use the MT launcher i think to run 9.5 emunand so you could access eshop and download your games.....but then you have the 6.x save issue for retail games, if you wanted you could just use MT download them to your eshop , then update back to 9.2 in sysnand, then you have them redeemed so they don't expire and once you learn everything about how to merge a new ticket.db with your 9.2 nand you could try merging, no need to buy any card, but comes with the risk of something going wrong....but it should be fine as long as you follow the guides 100%......just know that if anything goes wrong a nand mod would be your only recovery route, but a nand mod is something i would recommend any 3ds owner who relies on exploits having :)
     
  11. SonikkuTheGreat
    OP

    SonikkuTheGreat Advanced Member

    Newcomer
    50
    7
    Aug 3, 2010
    United States
    Virginia
    Well, I don't know about that. I care very much about my systems and are cautious when I use homebrew on them (well, I failed a lot on my old Wii; would you believe I bricked it 4 times? Thank goodness I fixed it every time). Since this obviously looks like something that would either mess up my 3DS or something else, now I'm just wondering if I should give up and update. I really want to redeem a code from CN's new updated rewards catalog. I'm just thinking about what I would lose. Would I never be able to hack my 3DS again? I can't get Gateway, and smea said he won't update Ninjhax to work on newer system versions, so I'm thinking I may be screwed.

    What should I do?
     
  12. Jhyrachy

    Jhyrachy GBAtemp Regular

    Member
    215
    71
    Jul 25, 2011
    Italy
    I'll hijack this threa.
    I have 9.2 sysnand, if i downgrade and i boot on emunand (9.5 emunand) can i still play my original 3ds games?

    Or emunand disable the use of cartdridge?
     
  13. nosklo

    nosklo Member

    Newcomer
    49
    14
    Oct 16, 2010
    Brazil
    Maybe I'm missing something, but this problem seems overrated - You can just start your retail game save from scratch and then it will work, right?
     
  14. gamesquest1

    gamesquest1 Nabnut

    Member
    GBAtemp Patron
    gamesquest1 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    14,148
    9,501
    Sep 23, 2013
    yeah, if you dont have any games that use 6.x save encryption, or you don't care about restarting some games, then its not an issue really....but some people really valued their saves
     
  15. nosklo

    nosklo Member

    Newcomer
    49
    14
    Oct 16, 2010
    Brazil
    Yes, you can still play your original games on the emunand. That's exactly what "classic mode" is for. The only thing you lose is the save game for some newer games that use the new encryption. But even then, you can just start a new save game from scratch and it will work from that point on.
     
    Jhyrachy likes this.
  16. Jhyrachy

    Jhyrachy GBAtemp Regular

    Member
    215
    71
    Jul 25, 2011
    Italy

    Wait, could you explain?

    Let's say i have a game called Z
    I play this game NOW, on my 3ds with sysnand at 9.2
    If i use it in classic mode on emunand 9.5, i could lose the save?
    Why?

    I smell something about "emunand, even 9.5, use 6.x encryption and your game uses 9.2 encryption, so they are not compatible" am i right?
     
  17. gamesquest1

    gamesquest1 Nabnut

    Member
    GBAtemp Patron
    gamesquest1 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    14,148
    9,501
    Sep 23, 2013
    classic mode when booted from 6.x+ will be able to use 6.x encrypted saves .....people are using MT mode classic mode so they can access eshop etc without buying a gateway card, 6.x saves are dependent on keys initialized during boot up, so if you down grade to 4.x to be able to use the MT launcher you loose these keys, but if you own a gateway card you can boot into classic mode from a 6.x-9.2 FW, which allows classic mode to still use the legit keys and as such use properly 6.x encrypted saves
     
    Jhyrachy likes this.
  18. Jhyrachy

    Jhyrachy GBAtemp Regular

    Member
    215
    71
    Jul 25, 2011
    Italy
    I think i'll just use them on my brother 3ds XD

    Thanks a lot for your help!
     
  19. Pluupy

    Pluupy Woof!

    Member
    969
    716
    Sep 13, 2009
    United States
    I feel the same way as TC. I also want to redeem a Club Nintendo game but am conflicted because I need to update to use the eShop. Really sucks. Running 9.2U.

    I've decided to just update anyway. Eventually even the present version will be hackable. I'll just keep buying games.
     
  20. SonikkuTheGreat
    OP

    SonikkuTheGreat Advanced Member

    Newcomer
    50
    7
    Aug 3, 2010
    United States
    Virginia
    You know what, you're right. I'll update. We'll be able to hack the newest software eventually. Thanks for giving me the incentive.