Applications Not Working

Discussion in 'Wii - Hacking' started by the_grape, Mar 22, 2009.

Mar 22, 2009

Applications Not Working by the_grape at 10:42 PM (566 Views / 0 Likes) 4 replies

  1. the_grape
    OP

    Newcomer the_grape Newbie

    Joined:
    Mar 22, 2009
    Messages:
    3
    Country:
    Canada
    Hey, I've been using my homebrew for quite awhile now, and it's worked fine for me for a long time. I'm using Wii version 3.2U (the best one), and I've been able to use emulators and other apps like ocarina just fine. Recently, however, my homebrew channel refuses to run certain (by certain i mean most) apps. The only apps that still currently work are the WAD installer and IOS something-or-other, all the other apps prompt this error message:

    Error

    This is not a valid Wii application

    This message applies to ocarina, my emulators, everything that had previously worked fine. I've tried re-installing the homebrew channel twice with no success.

    Is there a way to fix this? thanks in advance.
     
  2. kedest

    Member kedest GBAtemp Psycho!

    Joined:
    Feb 6, 2007
    Messages:
    3,283
    Country:
    Netherlands
    Are you using old versions of the applications? Since a recent update, the HBC will refuse certain invalid old files. All new applications should come in DOL format. ELF files might be old and there's a change they will not work.
     
  3. the_grape
    OP

    Newcomer the_grape Newbie

    Joined:
    Mar 22, 2009
    Messages:
    3
    Country:
    Canada
    that very well could be the problem, the few that i checked just now were in ELF format. Now i have to find all my apps in DOL format... :/
     
  4. kedest

    Member kedest GBAtemp Psycho!

    Joined:
    Feb 6, 2007
    Messages:
    3,283
    Country:
    Netherlands
    Most applications have updated dol files. Check out wiibrew.
    For the applications without a new dol file, there's a converter application available that turn it into a dol
     
  5. the_grape
    OP

    Newcomer the_grape Newbie

    Joined:
    Mar 22, 2009
    Messages:
    3
    Country:
    Canada
    thanks for the help, i've got it all sorted out [​IMG]
     

Share This Page