Another Zero Collection issue... No Sub Weapon?

Discussion in 'NDS - Console and Game Discussions' started by Makoto0729, Jun 11, 2010.

  1. Makoto0729
    OP

    Makoto0729 GBAtemp Regular

    Member
    121
    3
    Jul 28, 2009
    United States
    I've been playing Venom's version... and for some reason, my sub weapon doesn't work. I've tried mapping it to different buttons, so it's not that it's simply not reading... but nothing happens at all when I try to use my sub weapon, be it as the pistol, sword, spear, or shield boomerang...

    It doesn't make the game unplayable, since I can swap weapons anytime, but it is a bother...

    Does anyone know what might cause this or how to fix it?
     
  2. BoxShot

    BoxShot Chiyo-chan :3

    Member
    3,447
    3
    Dec 18, 2008
    United States
    Middle of the ocean.
    Go to the menu with the controls setting. The bottom half should be attack style change it to type b to use a sub weapon with a single button. (or whichever you choose)
     
  3. Bently

    Bently GBAtemp Fan

    Member
    495
    3
    Sep 17, 2009
    Canada
    Ontario
    I think your supposed to hold the SUb weapon and press attack, thats what I do. (Hold R+ press b) Im also on Venom version of the game.
     
  4. moosh1989

    moosh1989 Member

    Newcomer
    46
    1
    Jul 24, 2009
    Leeds,UK
    i do the same thing with it and its the same with the clean version
     
  5. ShinRyouma

    ShinRyouma GBAtemp Advanced Fan

    Member
    956
    2
    Dec 6, 2008
    Indonesia
    Surabaya
    You can change the button config, I change it so I can change to sub/main weapon by pressing R button.
     
  6. Rubedo

    Rubedo Aikawa is OLEV

    Member
    741
    3
    Jul 29, 2008
    United States
    But you shouldn't have to do that.
    I played through Z1 with B - jump, Y - main weapon, A - subweapon and R - dash. This doesn't work in Z2 for some reason.
     
  7. worlok375

    worlok375 GBAtemp's prince

    Member
    1,005
    1
    Feb 17, 2009
    United States
    I had this problem too, then I figured out to hold down the sub-weapon button and then press the other weapon button.