Acekard 2i for DSi using a DSL Please advise!

Discussion in 'Acekard' started by neildunne, Jan 19, 2010.

  1. neildunne
    OP

    neildunne Being friendly and helpful costs nothing

    Newcomer
    12
    0
    Apr 30, 2009
    Darwen, Lancashire
    Hi guys, im sorry for being a pain but could you please advise on the setup of an Acekard 2i for a DSi, using a DSL. I have read various posts on doing this but am still a little unsure on the EXACT process. I have ordered 2 Acekard 2i, one for my daughters DSL and the other for my sons DSi. My sons DSi is already on firmware 4.1E so i beleive to get the card working in sons DSi i will have to use my daughters DSL. I know i have to download the official Acekard 4.21 firmware for the Card and place all the files from this folder on the card. This is where i loose it a little, i have downloaded a zip file containing two files, one called ak2ifw_update_14_DSi.nds and the other called ak2ifw_update_14_DSL.nds . Which one do i place on the Acekard 2i with the Acekard firmware to put into the DSL to set it up for my sons DSi? Sorry for being so long winded but i just want to explain in detail what i think i should be doing (im a bit out of touch at 45 yrs old lol) Thank you for any advice i may receive
     
  2. kingsanto

    kingsanto GBAtemp Regular

    Member
    113
    0
    Sep 15, 2009
    United States
    If you're going to upgrade the card firmware from a DS Lite, you'll need ak2ifw_update_14_DSL.nds on there. You'll have to start it up and run that file to do the update.
     
  3. iwakura

    iwakura HHNNNNNNGGGG

    Member
    1,161
    0
    Jul 20, 2006
    United States
    California
    Hey,

    you'll want to copy the ak2ifw_update_14_DSL.nds to your microSD (the root of the microsd works fine) and plug the
    microsd into the ACekard and then boot up the AK with your DSlite. Run the app just mentioned, and it should turn the screen blue, an prompt you to press start to update.

    Press start, wait for the progress to reach 100%, and turn off the DS lite. The acekard is now updated.
     
  4. neildunne
    OP

    neildunne Being friendly and helpful costs nothing

    Newcomer
    12
    0
    Apr 30, 2009
    Darwen, Lancashire
    Hi kingsanto, and thanks for your prompt reply. Now this is where i get confused because on a DS site i was reading last night they stated that you only use the ak2ifw_update_14_DSL.nds if you are updating a batch of Acekards, and this is what i found strange. I dont want to doubt your knowledge in any way bud, but are you 100% sure? I just dont want to muck it up for my son, as i also read on various sites that you can brick your Acekard if you use the wrong file

    iwakura has said the same so i'll take it as so..............Please dont be offended kingsanto, as i said, i just wanted to be 100%....................THANK-YOU GUYS
     
  5. iwakura

    iwakura HHNNNNNNGGGG

    Member
    1,161
    0
    Jul 20, 2006
    United States
    California
    Yep 100%. Done updates with both ds lites and dsi's. Updated at least 30 by now. [​IMG]
     
  6. soulx

    soulx GBAtemp Legend

    Member
    10,130
    4,708
    Apr 4, 2009
    Canada
    Ya.

    He's right. I did the same thing.
     
  7. Gariscus

    Gariscus Former Team Cyclops Mod

    Member
    646
    1
    Jun 5, 2009
    ak2ifw_update_14_DSL.nds is meant for upgrading multiple Acekards and it works on both DSi and DS lite/Phat...
    ak2ifw_update_14_DSi.nds is meant for upgrading one Acekard at a time and works on both DSi and DS lite/Phat...
     
  8. Jakob95

    Jakob95 I am the Avatar

    Suspended
    4,344
    67
    Jan 15, 2009
    United States
    New York City
    I used the ak2ifw_update_14_DSi.nds on my DS lite. The ak2ifw_update_14_DSL.nds is only for if your Acekard 2i is bricked and if you have another flashcart you could boot up ak2ifw_update_14_DSL.nds on that other flashcart and take it out and put the AK 2i into your DS lite and it will update it. The ak2ifw_update_14_DSi.nds is the one you should use to update your AK 2i.
     
  9. snake218

    snake218 Member

    Newcomer
    19
    1
    Jan 11, 2010
    United States
    1. Copy the latest acekard official firmware to your micro sd
    2. copy to the root of your Micro SD the file ak2ifw_update_14_DSi.nds or the ak2ifw_update_14_DSL.nds
    3. insert your card into the dsl, and run the file
    4. follow the instructions
    5. in about 1 minute it should be done, if done correctly when you try it at your dsi it will show the Danny Phantom icon instead the acekard icon

    Just a note, you can use ak2ifw_update_14_DSi.nds or the ak2ifw_update_14_DSL.nds, both will work, but if you use the ak2ifw_update_14_DSL.nds it will promt you at the begginig of the process, when you run the file, that eject and insert again the cartridge without turning the dsl off

    PD sorry for the bad english
     
  10. neildunne
    OP

    neildunne Being friendly and helpful costs nothing

    Newcomer
    12
    0
    Apr 30, 2009
    Darwen, Lancashire
    This is exactly what i mean! Even in this post i have people saying to use the ak2ifw_update_14_DSi.nds file and others saying to use the ak2ifw_update_14_DSL.nds file, so i still have that feeling of uncertaintity.
     
  11. SamAsh07

    SamAsh07 GBAtemp Addict

    Member
    2,696
    67
    Jan 27, 2009
    Bosnia and Herzegovina
    Bahrain
    Wow Acekard2i is complex in setup??
     
  12. Gariscus

    Gariscus Former Team Cyclops Mod

    Member
    646
    1
    Jun 5, 2009
    Both upgraders do basically the same thing(they are also able to be run on any DS/i). I just wish those .nds files included a readme to avoid confusion.
     
  13. dilav

    dilav GBAtemp Maniac

    Member
    1,230
    40
    Nov 22, 2006
    United States

    actually i think your first line is wrong.
    ak2ifw_update_14_DSL.nds is meant for upgrading multiple Acekards and unbricking (with a unbricked flashcart) and it works ONLY on DS lite/Phat. (On DSi it doesn't run after it tells you to eject)

    ak2ifw_update_14_DSi.nds is meant for upgrading one Acekard at a time and works on both DSi (fw
     
  14. Gariscus

    Gariscus Former Team Cyclops Mod

    Member
    646
    1
    Jun 5, 2009
    The first line is not wrong(not all of it anyway). As ak2ifw_update_14_DSi.nds works with all DSes I assumed ak2ifw_update_14_DSL.nds would too. I didn't add the bit about unbricking Acekards because I didn't know how to word it and I thought it would just confuse neildunne further...
     
  15. neildunne
    OP

    neildunne Being friendly and helpful costs nothing

    Newcomer
    12
    0
    Apr 30, 2009
    Darwen, Lancashire
    So the long and the short, and general census is............i can use EITHER of these files to get the Acekard 2i working for the DSi which is already on 1.4 firmware, using the DSL to do the process???
     
  16. Gariscus

    Gariscus Former Team Cyclops Mod

    Member
    646
    1
    Jun 5, 2009
    Yep.
     
  17. Dark^'^Knigh

    Dark^'^Knigh GBAtemp Maniac

    Member
    1,043
    5
    Apr 25, 2007
    Paradise
    I can confirm this process is all you need to do for it to work:
    1. download DSi FW update file (Megaupload link is provided in various tutorials & threads)
    2. place this DSi fileonto your AK2i
    3. run it in your DSL - blue screen appears simply press "start" button & approx. 30 secs later its done
    4. take the AK2i out of the DSL & put it into your DSi. Note: AK icon is replaced with Danny Phantom
    5. Success

    Potential problem: If you are unlucky (like me and quite a few others), you may receive a clone AK2i. Now, you will probably quickly ascertain this if the above steps don't work TRUST ME!..If at step 3 the update hangs on 0% progress, then you may have the same problem I just had with it. Here's the thread with a working link for the R4i FW Update http://gbatemp.net/index.php?showtopic=184332&st=30
    I used it today and my AK2i now works on my DSi FW1.4