3rd party controller problem. Need help!

Discussion in 'Wii - Emulation and Homebrew' started by sadbear, Jul 26, 2012.

Jul 26, 2012
  1. sadbear
    OP

    Newcomer sadbear Newbie

    Joined:
    Jul 26, 2012
    Messages:
    1
    Country:
    Norway
    Ok, so... I bought a 3rd party snes mockup controller from ebay to get a genuine experience playing emulators on the wii.
    I got the controller and plugged it into my wiimote and launched the snes emulator. Now this is where my problem starts.

    The directional pad (up, down, rigt, left) on the controller dont work. All the other buttons work as they should.
    I thought maybe the controller broke during shipping, but they worked on my VC games...

    I've been searching the entire day for a solution and I've even tried my hand at some programming on my own (even though I dont know anything about it) using devkitpro and some guides
    explaining how to recompile with the correct controller ID, Unsuccessfully!

    So now as a last resort I make my own topic at a forum which I normally never do. Searching for some able help with this problem.

    #1 - I have tried the newest version of every emulator i use (snes, nes and vba) with no success..
    #2 - I have also tried all the old revisions posted in this thread: http://gbatemp.net/t...sic-controller/
    #3 - I loaded a homebrew app which said that my controller ID was: 0x0 (3rd party unsupported)

    This is the controller i bought: http://www.ebay.com/...#ht_3271wt_1392

    As stated above i've been reading all day trying to fix this problem, and due to my lack of programming skills, I've concluded that I will not be able to solve this problem myself without some help from you guys!

    Thanks for looking into my issue. (I apologize for any grammatical mistakes, english is not my first language)
     

Share This Page