wiiu_usb_helper broken??

Discussion in 'Wii U - Homebrew' started by aljpn91, Mar 12, 2017.

  1. aljpn91
    OP

    aljpn91 Banned

    Banned
    276
    91
    Dec 28, 2015
    i just tried to install some dlc i got from wiiu_usb_helper, and it failed to install giving me the "signatures must be patched to install" error when running wupinstaller after loading mocha
    turns out the archive was missing some files after comparing it to the dlc i got from another source, that installed just fine

    doesn't usb helper gets it's data from nintendo servers?
    why are important files missing from these packages?
    can this be fixed if i redownload the archive?
     
    Last edited by aljpn91, Mar 12, 2017
  2. Felek666

    Felek666 Archdemon | #AMDForever

    Member
    3,227
    3,328
    Jan 3, 2017
    Poland
    reddit.com/r/satania/
    Just redownload it again. Wii U USB Helper like every NUS downlader has chance to miss some files or download them in wrong way. That's why you use Copy to SD function because it verifies files and redownloads if one is missing.
     
  3. aljpn91
    OP

    aljpn91 Banned

    Banned
    276
    91
    Dec 28, 2015
    i restarted the download and it's now downloading the missing files
    just need to wait and see what happens next

    it's all there now, from now on i'll download everything twice, just to make sure i get the whole thing before i try to install it
     
    Last edited by aljpn91, Mar 12, 2017
  4. Link'sSpiritualAwakening

    Link'sSpiritualAwakening Advanced Member

    Newcomer
    69
    9
    Mar 21, 2015
    United States
    If it says signatures must be patch to install... it means exactly that. Redownloading isn't going to help. You need to run Mocha cfw or something else that patches signatures, then your wupinstaller.
     
  5. aljpn91
    OP

    aljpn91 Banned

    Banned
    276
    91
    Dec 28, 2015
    i did run mocha before running wup installer and there were indeed some missing files from the archive that i ended up downloading after hitting the download button a second time, therefore the error had nothing to do with sigpatches
    i got an error telling me i had a corrupt sd card too once, and that turned out to be fake too, because what was actually corrupt were the files themselves
    point is, never trust error messages
     
    Last edited by aljpn91, Mar 16, 2017